Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

RTE dialog field not working in 6.3.3

Avatar

Level 1

I'm having a very similar issue to this thread that was closed with no resolution: RichText not working for touch UI AEM 6.4

In my local instance (6.3.0), the rich text editor is working fine in my custom component but in 6.3.3 it won't even allow me to add anything to the field or show any of the plugins. In 6.3.3 there is an "Uncaught ReferenceError: $this is not defined" console error.

6.3.0

1578537_pastedImage_2.png

6.3.3

1578538_pastedImage_3.png

6.3.3 console error:

1578542_pastedImage_5.png

This is the dialog.xml:

<?xml version="1.0" encoding="UTF-8"?>

<jcr:root xmlns:sling="http://sling.apache.org/jcr/sling/1.0" xmlns:cq="http://www.day.com/jcr/cq/1.0" xmlns:jcr="http://www.jcp.org/jcr/1.0" xmlns:nt="http://www.jcp.org/jcr/nt/1.0"

    jcr:primaryType="nt:unstructured"

    jcr:title="Button"

    sling:resourceType="cq/gui/components/authoring/dialog">

    <content

        jcr:primaryType="nt:unstructured"

        sling:resourceType="granite/ui/components/coral/foundation/container"

        margin="{Boolean}true">

        <items jcr:primaryType="nt:unstructured">

            <tabs

                jcr:primaryType="nt:unstructured"

                sling:resourceType="granite/ui/components/coral/foundation/tabs"

                maximized="{Boolean}true">

                <items jcr:primaryType="nt:unstructured">

                    <quote

                        jcr:primaryType="nt:unstructured"

                        jcr:title="Quote"

                        sling:resourceType="granite/ui/components/coral/foundation/container"

                        margin="{Boolean}true">

                        <items jcr:primaryType="nt:unstructured">

                            <text

                                jcr:primaryType="nt:unstructured"

                                sling:resourceType="cq/gui/components/authoring/dialog/richtext"

                                fieldLabel="Item Description"

                                name="./text"

                                useFixedInlineToolbar="{Boolean}true">

                                <rtePlugins jcr:primaryType="nt:unstructured">

                                    <format

                                        jcr:primaryType="nt:unstructured"

                                        features="*"/>

                                    <misctools

                                        jcr:primaryType="nt:unstructured"

                                        features="specialchars">

                                        <specialCharsConfig jcr:primaryType="nt:unstructured">

                                            <chars jcr:primaryType="nt:unstructured">

                                                <copyright

                                                    jcr:primaryType="nt:unstructured"

                                                    entity="&amp;#169;"/>

                                                <trademark

                                                    jcr:primaryType="nt:unstructured"

                                                    entity="&amp;#8482;"/>

                                                <registered

                                                    jcr:primaryType="nt:unstructured"

                                                    entity="&amp;#174;"/>

                                                <emDash

                                                    jcr:primaryType="nt:unstructured"

                                                    entity="&amp;#8212;"/>

                                                <pound

                                                    jcr:primaryType="nt:unstructured"

                                                    entity="&amp;#163;"/>

                                                <nbsp

                                                    jcr:primaryType="nt:unstructured"

                                                    entity="&amp;#160;"/>

                                            </chars>

                                        </specialCharsConfig>

                                    </misctools>

                                </rtePlugins>

                                <uiSettings jcr:primaryType="nt:unstructured">

                                    <cui jcr:primaryType="nt:unstructured">

                                        <inline

                                            jcr:primaryType="nt:unstructured"

                                            toolbar="[format#bold,format#italic,format#underline,#justify,#lists,subsuperscript#subscript,subsuperscript#superscript,links#modifylink,links#unlink,links#anchor,#image,findreplace#find,findreplace#replace,spellcheck#checktext,misctools#specialchars,misctools#sourceedit,#styles,#paraformat,table#table]">

                                            <popovers jcr:primaryType="nt:unstructured"/>

                                        </inline>

                                    </cui>

                                </uiSettings>

                            </text>

                        </items>

                    </quote>

                </items>

            </tabs>

        </items>

    </content>

</jcr:root>

Any ideas of how to fix?

Thanks!

1 Accepted Solution

Avatar

Correct answer by
Level 5

rachelb88688093

This is a known issue with the inital release 6.3.3.0.

AEM 6.3.3.0 was reuploaded. You can download it again and install this one instead to resolve the issue.

https://www.adobeaemcloud.com/content/marketplace/marketplaceProxy.html?packagePath=/content/compani...

Best Regards,

Aneet Arora

View solution in original post

3 Replies

Avatar

Level 10

This could be a bug in the upgrade. If the RTE is not working as shown in the video:

Then something needs to be fixed at the software level.

Please report this to AEM Customer Care by raising a support ticket so it can be fixed.

Avatar

Correct answer by
Level 5

rachelb88688093

This is a known issue with the inital release 6.3.3.0.

AEM 6.3.3.0 was reuploaded. You can download it again and install this one instead to resolve the issue.

https://www.adobeaemcloud.com/content/marketplace/marketplaceProxy.html?packagePath=/content/compani...

Best Regards,

Aneet Arora