Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

i18n translator changes not being reflected in QA or Prod

Avatar

Level 4

Using http://<hostname>:<port-number>/libs/cq/i18n/translator.html UI for translation is not getting reflected in PROD or QA. When we click on save we get the below error in logs. Please help.

 

*ERROR* [203.91.220.17 [1443092281966] POST /libs/cq/i18n/translator.translations.json HTTP/1.1] 
org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException org.apache.sling.scripting.jsp.jasper.JasperException: /apps/cq/i18n/translator/translations/POST.jsp(737,2) File "/apps/cq/i18n/translator/translations/languagenodes.jsp" not found

at org.apache.sling.scripting.jsp.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:40)
        at org.apache.sling.scripting.jsp.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:407)

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

have you customized or orverridden the "/libs/cq/i18n/translator/translations" in /apps ?? If so see if the same has been moved to QA or Prod env

View solution in original post

2 Replies

Avatar

Correct answer by
Community Advisor

have you customized or orverridden the "/libs/cq/i18n/translator/translations" in /apps ?? If so see if the same has been moved to QA or Prod env

Avatar

Level 4

Yes it customized in prod and QA but not in DEV