Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Error in testing replication agent for AEM instance to Marketing Cloud and Creative Cloud sync

Avatar

Level 2

We are repeatedly experiencing the following error when we test our replication agents:

Failed to get an access token for user: mac-deloitteemeanorthpartnersand-replication msg: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty

Please can you advise?

Cheers,

Dave

kautuksahni

1 Accepted Solution

Avatar

Correct answer by
Level 2

Hi - we fixed by updating Java and restarting server.

Thanks!

Dave

View solution in original post

5 Replies

Avatar

Administrator

This problem is addressed in this post:- Trying to Configuring AEM Assets integration with Marketing Cloud and Creative Cloud

// If you make any mistake in initial configuration then trying to fix it later. It will not work because your latest changes will not be reflected in code. The workaround is manually clear and recreate the configuration.

~kautuk

Avatar

Level 2

Hi

Thanks for your reply, we have deleted and tried again a number of times.

Can you tell me more about the nature of the error:

mac-deloitteemeanorthpartnersand-replication msg: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty

It states that the trustAnchors must not be empty, how is this set?

Cheers,

Dave

Avatar

Administrator

I am following-up internally.

Would get back to with the update.

Is this happening on AWS/Cloud? or locally?

It looks to me certificate issue at Java installation level, See this java - InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty - Stack Over...

kautuk

Avatar

Level 2

Thanks, we will look at that link.

This is occurring on AWS.

Cheers,

Dave

Avatar

Correct answer by
Level 2

Hi - we fixed by updating Java and restarting server.

Thanks!

Dave