Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.0 upgrade to AEM 6.2 - com.adobe.cq.social.cq-social-blog Removed

Avatar

Level 2

Hello,

I am in the process of upgrading my AEM 6.0 instance to AEM 6.2. We have a rather large blog that utilizes the cq-social-blog (com.adobe.cq.social.cq-social-blog). I realize that the social blog was deprecated in AEM 6.1 and completely removed in AEM 6.2. I need this functionality back for AEM 6.2. I tried to include the dependency in the POM files but I am getting some rather strange errors that I am not able figure out.

Here is what I included in the parent POM:

<dependency> <groupId>com.adobe.acs</groupId> <artifactId>acs-aem-commons-bundle</artifactId> <version>3.3.0</version> <scope>provided</scope> </dependency> <dependency> <groupId>com.adobe.cq.social</groupId> <artifactId>cq-social-blog</artifactId> <version>1.0.15</version> </dependency> <dependency> <groupId>com.adobe.cq.social</groupId> <artifactId>cq-social-storage</artifactId> <version>1.0.0</version> </dependency>

And here is what I am including the in the bundle POMs:

<dependency> <groupId>com.adobe.aem</groupId> <artifactId>uber-jar</artifactId> <classifier>apis</classifier> </dependency> <dependency> <groupId>com.adobe.cq.social</groupId> <artifactId>cq-social-blog</artifactId> </dependency> <dependency> <groupId>com.adobe.cq.social</groupId> <artifactId>cq-social-storage</artifactId> </dependency>

Here is the exception I am getting, which from doing research, sounds like a dependency issue:

02.11.2016 13:52:56.500 *ERROR* [0:0:0:0:0:0:0:1 [1478112776389] GET /content/sites/foo/blog.html HTTP/1.1] org.apache.sling.servlets.resolver.internal.SlingServletResolver Original error class java.lang.LinkageError

java.lang.LinkageError: loader constraint violation: loader (instance of org/apache/felix/framework/BundleWiringImpl$BundleClassLoaderJava5) previously initiated loading for a different type with name "com/adobe/cq/social/blog/BlogManager"

This exception is occurring when I try to get a Blog object from a BlogManager object. Any help porting over the cq-social-blog in AEM 6.2 in much appreciated. 

PS: I realize that the blog has been replaced with the new 'Journals' feature, but my team and I do not have capacity at this point in time to convert the existing AEM 6.0 blog to journals.

1 Accepted Solution

Avatar

Correct answer by
Employee

In AEM 6.0 were you using cloud storage for the blog or local JCR? If cloud storage, then please contact Support and open an RFH ticket and we can provide advice on how to migrate the blog to AEM 6.2 Journal using the ugc migration utility here: https://github.com/Adobe-Marketing-Cloud/aem-communities-ugc-migration

If you were using JCR storage then please note that replication of UGC including blog/journa is no longer supported as of AEM 6.1. It is not possible to use the 6.0 cq-social-blog components on 6.1 or later due to the architectural changes that were introduced with the Storage Resource Provider and the Social Component Framework. It will be necessary to migrate to social-journal in order to use AEM 6.2

 

Here are some links for further information:

https://docs.adobe.com/docs/en/aem/6-2/develop/communities/scf.html

https://docs.adobe.com/docs/en/aem/6-2/develop/communities/scf/srp.html

View solution in original post

3 Replies

Avatar

Level 8

Hi,

Much has changed between 6.0 and 6.2.

I don't know for a fact, but it might not be possible to port the 6.0 blog feature to 6.2.

Have you looked at the 6.2 blog feature at all?  Browse to the Community Components Guide at

Blog on publish instance 

Notice that

  • the guide is best experienced on the publish instance
  • you have to be signed in to post
  • the old blog allowed editing only from the author instance

See also Blog Feature for AEM 6.2

There are also tools available for moving content that might be helpful for blog content.

See AEM Communities UGC Migration Tool on github (you will need to select an SRP).

Last, I would suggest working through your account representative.

- JK

Avatar

Correct answer by
Employee

In AEM 6.0 were you using cloud storage for the blog or local JCR? If cloud storage, then please contact Support and open an RFH ticket and we can provide advice on how to migrate the blog to AEM 6.2 Journal using the ugc migration utility here: https://github.com/Adobe-Marketing-Cloud/aem-communities-ugc-migration

If you were using JCR storage then please note that replication of UGC including blog/journa is no longer supported as of AEM 6.1. It is not possible to use the 6.0 cq-social-blog components on 6.1 or later due to the architectural changes that were introduced with the Storage Resource Provider and the Social Component Framework. It will be necessary to migrate to social-journal in order to use AEM 6.2

 

Here are some links for further information:

https://docs.adobe.com/docs/en/aem/6-2/develop/communities/scf.html

https://docs.adobe.com/docs/en/aem/6-2/develop/communities/scf/srp.html

Avatar

Level 2

Hi,

Were you able to migrate blogs to social journals in 6.2 ?

If yes, could you please let me know the steps you have taken to achieve this ?

I am in the process of migrating 6.1 to 6.3.