since ‎12-01-2017
Online
jamiec4451712
Level 2
Re: Adobe Admin Console Support Portal: Don't hide ticket...
Avatar

Manish_Singh_1

Employee

Manish_Singh_1
- Adobe Experience Cloud Core Services
Hello @jamiec4451712 We have forwarded your request to our team for further review. Thank you for your suggestions Regards,Manish Singh

Views

191

Like

1

Replies

0
Re: Replication Queue blocked - Failed to register namesp...
Avatar

jamiec4451712

jamiec4451712
- Adobe Experience Manager
Our team recently came across this issue as well. Symptoms:Replication queue stuck and has pending itemsReplication log shows: error: com.day.cq.replication.ReplicationException: Repository error during node import: Failed to register namespace mapping xmpGImg -> http://ns.adobe.com/xap/1.0/g/img/Resolution:Visit the CRX Explorer (https://hostname.or.ip/crx/explorer/index.jsp)Click "Node Type Administration"Click "Namespaces"Add a new namespaceURL: http://ns.adobe.com/xap/1.0/g/img/Prefix: xmpGI...

Views

422

Like

1

Replies

0
Re: setting Secure and HttpOnly flag in Cookie
Avatar

kautuk_sahni

Community Manager

Total Posts

6.0K

Likes

1.1K

Correct Reply

1.1K
kautuk_sahni
- Adobe Experience Manager
Nice Reply.

Views

861

Likes

0

Replies

0
I know this is an old question, but our team ran into a v...
Avatar

jamiec4451712

jamiec4451712
- Adobe Experience Manager
I know this is an old question, but our team ran into a very similar issue and I posted details of our solution here: https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/aem-session-cookie-with-httponly-and-secure-flag/qaq-p/206712/comment-id/75793#M75793

Views

3.0K

Like

1

Replies

0
Re: AEM Session Cookie with httponly and secure flag
Avatar

jamiec4451712

jamiec4451712
- Adobe Experience Manager
I know this is an old question, but our team ran into it recently and found a solution that may be helpful to others. I decompiled AEM's TokenUtil class and tried to find the place where the login-token cookie is set, and the secure flag is set or not based on the request's isSecure() method. If the request is secure, then the flag is set. Otherwise, it's not. So the question really becomes: how do we get the request to be marked as secure. It ends up there's a few solutions here. The first is t...

Views

1.4K

Likes

2

Replies

0
Re: Get rewritten URL in Java/Rhino
Avatar

Arun_Patidar

MVP

Total Posts

3.1K

Likes

1.2K

Correct Reply

884
Arun_Patidar
- Adobe Experience Manager
Can you try with below if helpsforward mapping: resourceResolver.map()reverse mapping: resourceResolver.resolve()ResourceResolver (Apache Sling 7 API)

Views

753

Likes

0

Replies

0
Re: Persisting Sling Model / OCM
Avatar

Brendan_Robert

Employee

Brendan_Robert
- Adobe Experience Manager
You are correct, some of these jars are not found as OSGi bundles in AEM. You need to update your bundle to include these, I'm pretty sure that the embed-dependency line from my example should do the trick.

Views

895

Likes

0

Replies

0
Re: getting error while installing a package
Avatar

jamiec4451712

jamiec4451712
- Adobe Experience Manager
This isn't a realistic error. This is happening to you during a dry run install (test install). The way this works (for some reason) is that the session reverts all changes it's made every 1024 nodes. So basically, your package installs a bunch of nodes, then they're reverted (removed) and then it tries to install one of their children, which throws this error.The solution is to just install the package without testing (this error won't happen then) or break the package down into smaller pieces....

Views

1.2K

Like

1

Replies

0
Re: AEM 6.4 - No overlay in Edit or Design more
Avatar

Ravi_Pampana

MVP

Ravi_Pampana
- Adobe Experience Manager
I faced similar issue while upgrading from AEM 6.2 to AEM 6.4. Pages loading fine in preview mode but in edit mode page is blank and not able to edit any component/add components. After lot of debug found there is exception (see view source in edit mode and you might see some exception) in one of the jsp which is reading property using jcrResourceResolver and calling login administrator in backend. In AEM 6.4 bundles using login administration will throw exception as we need to update to system ...

Views

1.3K

Like

1

Replies

0
Re: AEM Image Component with uploaded SVG
Avatar

nicolec5933381

nicolec5933381
- Adobe Experience Manager
It worked, do not forget to refresh the bundle

Views

3.6K

Likes

0

Replies

0
Re: Multifield in content fragment model
Avatar

jamiec4451712

jamiec4451712
- Adobe Experience Manager
I am currently looking into the same thing. Basically, Content Fragments appear to be AEM's solution to Content Types for structured data, instead of for abstract information. However, sometimes this structured data gets really complicated.I came across this article which seems like it may be on the right track. I'm going to give it a shot, but just wanted to add this to the thread since this is the first result for a lot of related queries on Google.

Views

3.2K

Likes

0

Replies

0
Re: Edit SAML SP Initiated Response
Avatar

MC_Stuff

MC_Stuff
- Adobe Experience Manager
jamiec4451712 wrote... Thanks for the reply. The problem is that the IDP does not have a session store, so loses SP context during SP initiated authentication and cannot properly redirect the user to the consume URL. The solution is to urlencode the AuthnRequest and other parameters and place them in the query string. The simplest way to do this is to change that form from a POST to a GET. That simple change will solve our problems. Essentially, the IDP does not currently support SP initiated vi...

Views

1.0K

Likes

0

Replies

0
Re: Cannot use SCF.addComponent manually
Avatar

jamiec4451712

jamiec4451712
- Adobe Experience Manager
Thanks for your answer,The documentation you linked states that I should be using SCF.addComponent, which is the exact situation I'm describing above. My primary concern here is that there's literally a line of code that says:var model = addModel(component);where addModel does not return a value. Clearly this is a bug, and I should in fact be using SCF.addComponent, especially when the element has been lazy loaded as an HTML resource, so it has the data-component-id and data-scf-component alread...

Views

919

Likes

0

Replies

0
Re: Links disappearing from RTE
Avatar

amalaa38504084

amalaa38504084
- Adobe Experience Manager
Hi Katauk,I don't find the method you suggested in AEM 5.6.1. Please let know where this should be changed for AEM 5.6.1I see same issue happening in my richtext but the anchor tag is nested inside div tag this html is added using custom rte plugin.ThanksAmala

Views

1.2K

Likes

0

Replies

0
Re: Error "File /META-INF/tags/HelloTag.tag not found" when creating custom JSP Tag lib
Avatar

arunjoshh

arunjoshh
- Adobe Experience Manager
The issue was fixed in https://issues.apache.org/jira/browse/SLING-7044This fix will be included in AEM 6.3.1.1, you can contact Adobe to get the pacth for this issue.ThanksArun

Views

5.1K

Like

1

Replies

0