since ‎24-09-2015
‎10-12-2019
roseh59748588
Level 1
"internet needs to be 4.0 or greater"?
Avatar

roseh59748588

roseh59748588
- Adobe Experience Cloud
Trying to instal Adobe photoshop elements education version but it says "internet needs to be 4.0 or greater"? i have a windows 8 computer its a year old I'm sure it is up to date.

Views

92

Likes

0

Replies

0