since ‎20-08-2010
‎10-12-2019
daleschimpf
Level 2
Re: Using @SlingServlet with path property daleschimpf - Adobe Experience Manager
Hey maadddog:I went back and re-ran the code using a resourceType instead of a path and apparently that example is NOT working for me either. I must have been confusing it with another example which I did get working. Sorry about that.It just seems like the selector is not being recognized or registered with the system.Hope someone is monitoring this forum and can make some suggestions.ThanksDale
1005
Views
2
Likes
0
Answers
Using @SlingServlet with path property daleschimpf - Adobe Experience Manager
I am trying to work through a couple of the training videos which demonstrate how to write a custom sling servlet using the path property.I have had success getting other code examples working.The 2 examples I am referring to are:1. The ServiceUserDemoServlet code example in the "Identifying Service Users, Administrative Sessions and Associated Risks" video in the "Adobe Experience Manager 6.1: Using Security" course (ID: WWFO_WBT_12003) (Class ID : 00087554).2. The MySafeMethodServlet code exam...
1570
Views
2
Likes
2
Answers and Comments
Re: Error Running App Imported on Publish Instance daleschimpf - Adobe Experience Manager
That link appears to be talking about installing and configuring AEM to work on a pre-existing application server.So you can't use a Turnkey JEE version?You can't configure JEE and Standalone versions in Author/Publish configurations?I need to administer my own application server and install 2 AEM instances on it to run any sort of JEE based Author/Publish configuration?ThanksDale
950
Views
0
Likes
0
Answers
Re: Error Running App Imported on Publish Instance daleschimpf - Adobe Experience Manager
Hi Everyone:Still hoping for some discussion and feedback on this issue.Stated another way, I guess the simple question is how do I setup an Author (on JEE)/Publish (on Standalone) environment?AEM JEE comes with AEM Forms installed and Standalone does not so what specific packages do I need to install on Publish (or possibly Standalone) so that both instances match up?Is this even a valid topology? According to this article https://helpx.adobe.com/aem-forms/6/aem-forms-architecture-deployment.ht...
949
Views
0
Likes
0
Answers
Re: Error Running App Imported on Publish Instance daleschimpf - Adobe Experience Manager
Hi Scott:I did a search for "FPIntegrationService" in CRXDE Lite and discovered that Author and Publish have different versions of this jar:Author - /libs/fd/fp/install/adobe-formsportal-services-4.1.28.jarPublish - /libs/fd/fp/install/adobe-formsportal-services-4.2.4.jarShould I try to update Author to have the 4.2.4 version of the jar or is there some other package I should install on Author? If the former is it safe to export the jar from Publish and import it to Author via Package Manager or...
950
Views
0
Likes
0
Answers
Error Running App Imported on Publish Instance daleschimpf - Adobe Experience Manager
Hi:I'm running AEM 6.1 JEE version on jboss in Author mode and I have a site/application I am trying to get running on a Standalone Publish instance. I have not installed AEM 6.1 FP 1 yetAfter publishing the site pages they were blank on Publish so I figured I might have to package up the application and export/import it using Package Manager.I created a package consisting of the following nodes:/apps/dgs/etc/designs/dgs/etc/blueprints/dgsAfter importing this package on Publish I was able to get...
2183
Views
0
Likes
5
Answers and Comments
URL Path Issue Between JEE Author and Standalone Publish Instances daleschimpf - Adobe Experience Manager
Hi:I have a demo I've created in my AEM 6.1 JEE based Author instance which consist of a mock up of a customer website (created using the AEM Site Importer tool), an Adaptive Form based on an XDP and a few supporting pages such as a Forms Portal and Thank You page. The Adaptive Form submits to an AEM Forms Workflow (aka Process Management).After publishing the pages and moving my /apps/demosite and /etc/designs/demosite resources to the Publish instance via Package Manager, the pages do not rend...
478
Views
0
Likes
0
Answers and Comments
Setting Up Publish Instance on AEM 6.1 JEE Version daleschimpf - Adobe Experience Manager Forms
Hi:I was recently attempting to setup a Publish instance on a demo AEM 6.1 JEE server I am running. My goal was to set up more of a real world environment with various instances for the purpose of learning how the instances work together.Before posting this I did a search on this forum and found this thread http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/aem-forms.topic.html/forum__urgb-hi_im_developing.html which contained this link https://helpx.adobe.com/aem-forms...
16973
Views
1
Like
28
Answers and Comments
Re: AEM Forms template jquery error on radio button click daleschimpf - Adobe Experience Manager Forms
Hi:Further to my previous reply, your question about whether the website I imported used jquery got me thinking about a possible version conflict. I commented out the reference to the website's instance of jquery and the radio button's are now working as expected. For the purposes of this demo I think I can get away without the page needing it's jquery reference.Thanks for asking the right questions!Dale
1040
Views
0
Likes
0
Answers
Re: AEM Forms template jquery error on radio button click daleschimpf - Adobe Experience Manager Forms
Hi:Steps to reproduce. Yes, that could be difficult. I assume you mean how did I come to be in this situation as opposed to me just saying well, just click on the radio button and look, it doesn't highlight 🙂Here is the general progression I followed:1. developed the xfa based adaptive form inside the Geometrixx-gov website, just as a sort of first step.2. created a new client branded website using the Site Importer tool.3. I copied the template my adaptive form was based on and got it working ...
1043
Views
0
Likes
0
Answers
AEM Forms template jquery error on radio button click daleschimpf - Adobe Experience Manager Forms
Hi:Hoping someone can shed some light on why I'm getting a javascript error when I click on a radio button on my xfa based AEM Forms template. The knock on effect is that the radio button is not being shown as selected. Through some javascript debugging I've been able to determine that what appears to be happening is that the radio button is being checked and then immediately unckecked.Here are some details on the javascript error:location: /etc/clientlibs/fd/af/guideRuntimeWithXFA.jserror on li...
2287
Views
1
Like
4
Answers and Comments
Re: AEM Forms Tabbed Enrollment Template Bug(s)? daleschimpf - Adobe Experience Manager Forms
Hi Varun:I carried out the steps you detailed to enable logging. The Firebug console created by this logging does not seem to want to allow me to copy the lines I need to copy and sometimes the lines are truncated unless you hover over them with a mouse. What I'll do instead instead of attaching a log file is provide a summary below of what I am observing:BEFORE clicking the Submit button:When I click on the panel with the E-Sign component I see the following calls just prior to the XFA renderin...
1080
Views
0
Likes
0
Answers
Re: AEM Forms Tabbed Enrollment Template Bug(s)? daleschimpf - Adobe Experience Manager Forms
Thanks Varun & Deepak. I had looked over these links before and tried applying some of what is covered there but I couldn't seem to quite accomplish what I was trying to do. I just used your example and it worked perfectly, with a slight mod since index is 0 based 🙂 I will redouble my efforts to look at this resource closer again.Please forgive my incorrect terminology, still very new to this whole environment, having come here from LiveCycle.Re your note Deepak, I actually have 2 E-Sign compon...
1049
Views
0
Likes
0
Answers
AEM Forms Tabbed Enrollment Template Bug(s)? daleschimpf - Adobe Experience Manager Forms
Hi:I posted a few days ago about another issue I was having with an adaptive form I'm working on. Thanks to the feedback received I was able to resolve that issue so thank you for that!I have a few other issues which I believe may be issues associated with the template itself (as opposed to my form built on top of the template). I say this because I have 2 demos based on the same template and I'm observing the same issues on both of my forms and I have observed the same behavior on other adaptiv...
2752
Views
1
Like
5
Answers and Comments
Re: E-Sign Component Rendering Issue (Echosign) After Submit Button is Clicked and Validation Fails daleschimpf - Adobe Experience Manager Forms
Hi Mandeep:Please look for a private forum message I just sent you regarding this.ThanksDale
1042
Views
0
Likes
0
Answers
Re: E-Sign Component Rendering Issue (Echosign) After Submit Button is Clicked and Validation Fails daleschimpf - Adobe Experience Manager Forms
Hi Mandeep:I am seeing the same behaviour when I use the wizard template and navigate back and forth between the panels (only AFTER I try to submit the form when not all required fields are filled out).Could you clarify or expand on what you mean when you say "Same goes for Esign as well" and "Please share the collateral for better understanding".ThanksDale
1038
Views
0
Likes
0
Answers
Re: E-Sign Component Rendering Issue (Echosign) After Submit Button is Clicked and Validation Fails daleschimpf - Adobe Experience Manager Forms
Hi Mandeep:In answer to your questions:a. I am working on a Quickstart instance. Version is AEM 6 SP1 AEM Forms FP1.b. I am using the OOTB Advanced Enrollment template for the issue I am having, located here fd/afaddon/components/page/advancedenrollment. I also have the same issue with the Tabbed Enrollment template.c. Yes, I actually have a label and a scribble signature component on the same panel. I just did a test where I removed those other components. Although this does not resolve the iss...
1036
Views
0
Likes
0
Answers
E-Sign Component Rendering Issue (Echosign) After Submit Button is Clicked and Validation Fails daleschimpf - Adobe Experience Manager Forms
Hi:I've posted about this issue before but I think it got lost in the shuffle a bit as I was also trying to deal with some other adaptive form issues as well (now resolved thanks to this forum's help).I'm having an issue across multiple forms using 2 different form templates I have tried that come with AEM Forms (Advanced Enrollment Adaptive Form Template & Tabbed Enrollment Adaptive Form Template).Simply stated, what is happening is this: If I try to submit a form that has required fields, befo...
2170
Views
1
Like
8
Answers and Comments
Coding URL in submit button invalidates digital signature daleschimpf - Adobe LiveCycle
Hi there:Hoping someone might be able to shed some light on this. I've been working on a set of forms for quite some time and an out of scope late requirements change came down the pipe stating that the forms must now be digitally signed. I went to work on that and made pretty decent progress being able to apply a valid digital signature to the form with fairly minor modifications. The forms are dynamix xfa forms created in Designer ES2 (aka version 9). I do have the Preserve scripting changes s...
1522
Views
0
Likes
0
Answers and Comments