Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

bmillhaus
Community profile bmillhaus Level 2
Job title here
Location here
8 BADGES
Level 2

Level 2

Learn more
Joined the community 12-05-2009 1:59:30 PM
Offline
Top badges earned by bmillhaus
Customize the badges you want to showcase on your profile
Re: Problem with dynamic tables, XML schemas, and JavaScript
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
That works!Thanks so much for your help,Brian

Views

608

Likes

0

Replies

0
Re: Data in dynamic table not traveling with form issue
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
That works!Thanks so much for your help,Brian

Views

523

Likes

0

Replies

0
Re: Problem with dynamic tables, XML schemas, and JavaScript
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Thanks but for some reason I am getting a 'not a valid archive file' error when I try to open the zip file. Could you attach just the form and then the schema as a .xxx file?Thanks again for all your help,Brian

Views

604

Likes

0

Replies

0
Extra task instruction email sent when task is claimed from group que
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Jasmin or whoever can help,Task instruction and reminder emails are sent correctly to my group members but when someone claims a task from the group que they get another task instruction email as soon as it hits their personal que. Is this a bug or is there something I can do to keep it from happening?Thanks for your help,Brian

Views

994

Likes

0

Replies

1
Re: Problem with dynamic tables, XML schemas, and JavaScript
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Thanks so much for your help. I've attached the schema.

Views

606

Likes

0

Replies

0
Data in dynamic table not traveling with form issue
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Jasmin or anyone who can help,I have a form with a dynamic table in it. When that form is filled out and submitted in Workspace only the first row of that table shows up at the next step of the process. I am submitting the form as a PDF because a signature is required and that and everything else shows up at the next step in the process but the dynamic table is giving me trouble.I am attaching the form. It has an embedded schema and some basic calculations JavaScript in it.Thanks for your help,B...

Views

3.0K

Likes

0

Replies

13
Re: Problem with dynamic tables, XML schemas, and JavaScript
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
That definitely fixes my problem with the dynamic table, new rows that are added are empty and new data can be added without changing the data in the earlier rows, but my Workspace problem still exists as only the data in the first row seems to travel with the form when it is rendered in the next step.Should I take this over to the Workspace forum?Thanks so much,Brian

Views

598

Likes

0

Replies

0
Re: Problem with dynamic tables, XML schemas, and JavaScript
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Paul,I attached the form with the embedded schema.All by fields are bound to the schema and as was suggested in the thread PetPal referenced I bound Row1, Table1, and the page to None.When I add a second row to the table the data from the first row is simply copied to the second row instead of the second row being blank. If I change the data in the second row the data in the first row is changed also.As Eric said, we need this to work in a Workspace environment.If I unbind the fields in the dyna...

Views

598

Likes

0

Replies

0
Re: Problem with dynamic tables, XML schemas, and JavaScript
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
That seems to work but when the form is saved the only data saved is the first row's data so it really isn't a solution for me.

Views

604

Likes

0

Replies

0
Re: Problem with dynamic tables, XML schemas, and JavaScript
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
If I open the form in Reader and enter data in the quantity and estimate unit price column it correctly calculates the amount for that row. But if I add another row instead of a blank row being produced the data from the previous row is reproduced. If I change that data it also changes the data for the previous row. The grand total field is correctly calculated though.I am using Reader 9.1.3

Views

601

Likes

0

Replies

0
Issue with claiming and opening tasks in a group cue and attachments
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Jasmin or whoever can answer,When I both claim and open a task in a group cue I see the number of attachments in the attachment tab but there is no list of attachments for me to see. I see the list of attachments just fine if I claim the task first and then open it from my cue of tasks. Is this a bug or am I doing something wrong?Thanks for your help,Brian

Views

1.1K

Likes

0

Replies

2
Problem with dynamic tables, XML schemas, and JavaScript
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
With the XML schema applied my JavaScript does not work correctly when a 2nd row is added to my dynamic table. Instead of a blank row being added the data from the 1st row is copied to the 2nd row and if you change the data in the 2nd row it changes the data in the 1st row also. It works fine if the XML schema data connection is deleted though.Any idea what I can do to get this working with the schema applied the same way it works without the schema?Thanks for your help,Brian

Views

5.1K

Likes

0

Replies

20
Re: Calculation script issue after applying schema
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Thanks that does fix that problem but it seems to create a new one in my real form which I am attaching. My real form has a dynamic table and my javascript handles the growing number of rows and the data in it just fine until I apply the schema. Once I fix my script and change it to use the root node of the schema the first row of the dynamic table works fine. But if I add a new row it already has the data from row 1 in it and if I change the data in row 2 it changes the data in row 1 also.If yo...

Views

521

Likes

0

Replies

0
Re: Calculation script issue after applying schema
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
ABC-1.pdf has a javascript calculation script in it. If I apply ABC.xsd to it the script and bind the different fields to the nodes in the schema the script no longer works and I can't figure out how to make it work.My actual form and schema is much larger but I can recreate the problem with the above form and schema so I assume fixing it on this form will tell me how to fix it on my real form.Thanks again,Brian--EDIT--Apparently I can't attach an XSD file but mine looks like:

Views

510

Likes

0

Replies

0
Calculation script issue after applying schema
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
I have a form with a basic javascript calculation script in it. When I apply an XML schema to the form the script no longer works and I can't figure out how to make it work after the schema has been applied. Obviously the XML has changed but when I change my script to use the new XML it doesn't work. Any idea what I need to do to get this to work?Thanks for your help,Brian

Views

1.5K

Likes

0

Replies

4
Re: Digital Signature Issue
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
That worked, thanks so much.Interestingly I also found that if I did this:In the SetValue activity I set Location /process_data/@processField1 Expression /process_data/FormXML/datasets/data/Form/P1/fromName toit worked also.So if you register the namespace the Expression would be /process_data/FormXML/xfa:datasets/xfa:data/Form/P1/fromName but if you don't register the namespace using the Expression /process_data/FormXML/datasets/data/Form/P1/fromName works.

Views

868

Likes

0

Replies

0
Re: Digital Signature Issue
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
I need to add signatures throughout the workflow so I am trying to work with option 1. Are you sure it isn't the Export Data operation from the FormDataIntegration service not the Import Data operation?With the Export Data operation I can Input xpath /process_data/initForm/object/@document where initForm is a Document Form data type and I can Output xpath /process_data/FormXML where FormXML is an XML data type. That XML looks good when I look at it in the playback. But I can't figure out how to ...

Views

850

Likes

0

Replies

0
Re: Digital Signature Issue
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Jasmin, Maceo29, Jayan, or whoever can help,Ok changing the submit button to submit a PDF instead of the default XDP works as far as keeping the signature with the document but it causes other problems in my process.In order to keep the PDF from rerendering each time and thus removing the signature I had to change the initForm data type from XFAform to Document Form and check the call the rendering service only once checkbox as Maceo29 said.Now I can't figure out how to access the data in the fo...

Views

868

Likes

0

Replies

0
Re: Digital Signature Issue
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
I changed the process to use a PDF instead of an XDP and it doesn't seem to matter as the signature still doesn't travel with the form.

Views

857

Likes

0

Replies

0
Digital Signature Issue
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Jasmin or anyone who can help,I created a PKCS#12 Digital ID file in Acrobat Pro 7 on my PC. When I sign a document in Workspace it places the signature just fine but when I submit the document the signature does not travel with the form like the rest of the inputted data.Any help you can give with this issue would be much appreciated.Thanks,Brian

Views

9.3K

Likes

0

Replies

10
Re: Reader Extending and Complete Buttons
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
That worked Jasmin, thanks a lot. 

Views

494

Likes

0

Replies

0
Re: Reader Extending and Complete Buttons
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
We use the 'inject form bridge' service in our custom render process. Are you suggesting taking it out of our render process and adding it directly to the form during the design and before we add the usage rights?

Views

488

Likes

0

Replies

0
Re: Reader Extending and Complete Buttons
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
If you are referring to the process fields those are added before the usage rights are applied. Basically the form is created in Designer or Workbench and then tested in Workspace and it works fine. The usage rights are added via Acrobat and the form is put back into the repository but when tested in Workspace the Complete button isn't rendered and instead the Submit button from the process fields is on the form itself. So it appears adding the usage rights the way we are doing it makes it so Wo...

Views

489

Likes

0

Replies

0
Reader Extending and Complete Buttons
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Jasmin or anyone who can answer. We are in a situation where for whatever reason many of our users have both Acrobat and Reader on their workstations. If we don't Reader extend our PDF forms and a user opens the form within Workspace in Reader, because say they already had Reader opened, they will get a message about not being able to save data in the form. If we Reader extend the document beforehand in Acrobat, because we don't own the Reader Extension service, and then save it in the repositor...

Views

2.4K

Likes

0

Replies

6
Workspace and Reader Enabling
Avatar
Give Back 10
Level 2
bmillhaus
Level 2

Likes

0 likes

Total Posts

25 posts

Correct reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Give Back 3
Ignite 3
View profile
bmillhaus
- Adobe LiveCycle
Jasmin or whoever might be able to answer,I was under the impression that if a document is rendered within Workspace that it automatically Reader enabled but that doesn't seem to be the case for one of our forms as we are getting 'you can not save information in this form' type messages when users try to enter information and the form rendered in Reader within Workspace.Thanks for your help.

Views

1.1K

Likes

0

Replies

1