Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Krishna_C
Community profile Krishna_C Level 4
Job title here
Location here
17 BADGES
Level 4

Level 4

Learn more
Joined the community 12-09-2013 11:06:22 PM
Offline
Top badges earned by Krishna_C
Customize the badges you want to showcase on your profile
Re: Custom Component doesn't bind to Service
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks for the reply smacdonald2008​Just curious on why we need to restart the bundle. Having a high ranking should have made sure custom component to bind , isn't it ?

Views

887

Likes

0

Replies

1
Custom Component doesn't bind to Service
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi Everyone,I am trying change the default the ContentSyncManager implmentaion provided by Adobe . So I created a class CustomContentSyncManagerImpl class as shown below@Component(metatype=true, label="Day CQ Content Sync Manager", description="Responsible for cache updates and content delivery using zip files.",immediate=true)@Service@Properties({@org.apache.felix.scr.annotations.Property(name = "service.ranking", intValue=10000)})public class CustomContentSyncManagerImpl implements ContentSync...

Views

1.1K

Likes

0

Replies

3
Re: ehcache
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks Kautuk ... This really helps me

Views

710

Like

1

Replies

0
ehcache
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi Everyone,I am trying to use ehcache in AEM 6.1. Please suggest me on the version of ehcache and details on how to implement this within AEM .Thanks,Krishna

Views

1.2K

Like

1

Replies

2
Re: Slow Queries - Issue with Indexing
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks Suresh.I was aware of this but I was hesitant to do a code change to add paths in my queries. In 5.6 path was not indexed so we made sure our queries should not have paths within it for better performance.As a last options I would add paths in my queries and index as well.Thanks,Krishna

Views

536

Likes

0

Replies

0
Re: Slow Queries - Issue with Indexing
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks Opkar. So the cq:template index is of the lowest cost , then I think I may have to check the indexing. This issue is happening only in one of the environments and it is taking the correct the index in other environments. I will check the configuration again.Thanks again 🙂Krish

Views

493

Likes

0

Replies

0
Re: Slow Queries - Issue with Indexing
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi Opkar,Thanks for the information. I will remove the cq:template in queries and I will try to stick to custom properties , I have added this assuming that it could make my search clean. I still have to check whether I can achieve all mu use cases by removing this.Thanks,Krish

Views

493

Likes

0

Replies

0
Slow Queries - Issue with Indexing
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi Everyone,I have created custom lucene index with the properties interested(most of them are custom properties created in our project) and used used cq:template as well as a property to be indexed. Now when I run the query indexing engine is picking up the Default Index for cq:template provided by adobe . So whats the priority for indexing ? Cant I use the same property in two indexes ? Any help is appreciated . Thanks,Krishna

Views

1.1K

Likes

0

Replies

9
Re: Live Copy - ContentCopyAction -Can't create new target as its parent is missing
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks Lokesh. I will raise one . 

Views

470

Likes

0

Replies

0
Live Copy - ContentCopyAction -Can't create new target as its parent is missing
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi Everyone,I am facing in issue while creation of lie copies. I have a content tree something that looks like Source page1 page2 page3 page4 page5I am going to activate these pages one by one in sequence using Java Replicator API based on user approval, I have a live copy with rollout configuration having actions ContentUpdate,ContentCopy,ContentDelete,EditProperties,OrderChildren and trigger as active/publishNow the issue is when I activate the pages one by one some times the copies are create...

Views

725

Likes

0

Replies

3
Re: Proxy Server Configuration
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager Forms
Thanks  Gokul

Views

610

Likes

0

Replies

0
Proxy Server Configuration
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager Forms
Hi ,Is there a way to configure proxy details in AEM 5.6 and AEM 6 versions. My organisation proxy will block me from connecting to package share or any external application. Not sure on where to configure the proxy details. Thanks & Regards,Krishna

Views

853

Like

1

Replies

2
Re: Missing Pages in Live Copy
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi Shekar,Thanks for the reply.Actually I am not moving any pages.Once I activate a page the live copy should be created. I may have more than hundred pages activated sequentially at a go. After the activation I see that 80% of the live copies created and remaining 20% copy pages were missing (which are random ) and these pages have no major differences with the other pages. Not sure what is the issue.Regards,Krishna

Views

532

Likes

0

Replies

0
Missing Pages in Live Copy
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi Everyone,I am creating a copy on activation. In my use case I will be activating hundreds of pages at go.On activation copies are created, but some of the pages are missing. The pages that are missing are similar to the other ones, they don't carry any special content as well. I am using AEM 5.6, are there any hot fixes I have to install ? Or any issue with the process ? Thanks & Regards,Krishna

Views

855

Likes

0

Replies

2
Re: ?debugClientLibs=true in author page
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
AEM merges all the java script files within a Client Library into a single js file.Using ?debugClientLibs=true will download all the js files individually making debugging easier. Krishna

Views

2.2K

Likes

0

Replies

0
Re: Content Copy on Activate Action
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks for the Suggestion Mathias.I will create configs independently and give a try. Thanks,Krishna

Views

466

Likes

0

Replies

0
Re: Content Copy on Activate Action
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks Mathias.It is working well after creating different configs one for copy and one for activate.For both the configs I have same trigger "Activate" . Not sure why this isn't working when I have them both together Krishna Chaithanya

Views

470

Likes

0

Replies

0
Content Copy on Activate Action
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi Everyone,I have a use case where content is copied on Activation.1. I have roll out config created which will be triggered on Activation , it has contentCopy, contentUpdate & targetActivate as sync actions 2. I have my source page created (manually)3. I have my copy page created (manually) which will hold the cq:LiveSyncConfig with details of roll out config & master path & deep set to true (Manually Created a live relation )Now when I activate a immediate child of Source Page, the page is co...

Views

745

Like

1

Replies

3
Custom Rollout - Sync Action
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi ,I am trying to create a custom sync action .I found the on that at https://dev.day.com/docs/en/cq/current/developing/multi_site_manager_dev.html#Creating%20a%20New%20Synchronisation%20ActionIt was suggested to use "com.day.cq.wcm.msm.api.LiveActionFactory" class to create a new action .I found the same can be achieved by using "com.day.cq.wcm.msm.impl.actions.FilteredActionFactoryBase" class .So whats the difference between these factory classes and when should I use them ?Regards,Krishna

Views

375

Likes

0

Replies

0
Re: Issue with moving crypto keys between different instances
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks Sham.Now after installing the key as a separate package and restarting the bundle everything works fine, surely it a problem with the file in repository. I will have key as a separate package. Since key deployment will be single time process so I don't see a big issue with that. Thanks for quick response Sham.Krishna

Views

575

Likes

0

Replies

0
Re: Issue with moving crypto keys between different instances
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks for the reply Sham,When I restart the bundle I get below exception POST /system/console/bundles/92 HTTP/1.1] com.adobe.granite.crypto.internal.Activator setupCryptoSupport: Failed creating CryptoSupport Implementation: javax.crypto.IllegalBlockSizeException: Input length must be multiple of 8 when decrypting with padded cipher at com.sun.crypto.provider.SunJCE_f.b(DashoA13*..)I assume that the (master.binary) file might have corrupted since I am trying to checkout the file to file system ...

Views

559

Likes

0

Replies

0
Issue with moving crypto keys between different instances
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi Everyone,I was trying to protect password available within my OSGi config. I need to use the same key across my instances so I tried to move the key. I went through the article on "EXPORTING KEYS FROM AUTHOR AND IMPORTING ON PUBLISH" available at http://docs.adobe.com/docs/en/cq/5-6/wcm/campaigns/newsletters.html#Exporting keys from author and importing on publish I have used Adobe eclipse plugin to get the master.binary file within the etc/key folder (etc/key/master is used as vault filter) ...

Views

1.2K

Like

1

Replies

4
Create Copy automatically on Source Page Activation
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hello Everyone,I am interested in doing a rollout on activation of the source page and this should be done automatically. I tried creating a rollout configuration which has a trigger "on active" and added edit properties as well to replace for page title and name. I placed this rollout configuration as a property in "cq:LiveSyncConfig" node placed just below the content resource of Source Page.But when I activate my source page nothing happens. Not sure whether what I have done is proper Can som...

Views

454

Like

1

Replies

3
Re: Connecting MS SQL Database from 5.6 using OSGi Service
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks Scott 

Views

535

Likes

0

Replies

0
Re: Connecting MS SQL Database from 5.6 using OSGi Service
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks Scott,It is working fine now .But the other services works fine without having the implementation and interface in the same package .Is this a restriction while using DataSourcePool ?Is there any way to encrypt the password available in DataSourcePool OSGi Configuration ?Thanks,Krishna

Views

516

Likes

0

Replies

0
Re: Connecting MS SQL Database from 5.6 using OSGi Service
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Export package details are fine. Even though the build is successful when I deploy it throws a exception as mentioned.I think there might be problem with OSGi configuration which I am not aware like binding datasourcepool before the service starts (Just a thought)Thanks.Krishna

Views

522

Likes

0

Replies

0
Re: Connecting MS SQL Database from 5.6 using OSGi Service
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi ,Thanks for the reply.I have went through the article already. I have different bundles deployed for my project and ms sql drivers. Both are build successfully.DWhen I deploy the project bundle it throws Impl class not found exception as mentioned in the post. Still both the bundles are active in felix. Thanks,Krishna

Views

523

Likes

0

Replies

0
Connecting MS SQL Database from 5.6 using OSGi Service
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi Everyone,I am trying to connect to MS SQL database in AEM 5.6 . Below is my service class which will provide the connection.@Component@Servicepublic class JDBCConnectionServiceImpl implements JDBCConnectionService{ private static final Logger LOGGER = LoggerFactory.getLogger(JDBCConnectionServiceImpl.class); private static String DATA_SOURCE_NAME="sqljdbc"; @Reference private DataSourcePool source; public Connection getConnection() { Connection con=null; try { DataSource ds = (DataSource) thi...

Views

1.4K

Like

1

Replies

8
Re: Sling Resource type- Page creation
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Thanks for the info Mateusz.

Views

567

Likes

0

Replies

0
Sling Resource type- Page creation
Avatar
Ignite 20
Level 4
Krishna_C
Level 4

Likes

14 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Ignite 20
Give Back 25
Ignite 10
Give Back 10
Ignite 5
View profile
Krishna_C
- Adobe Experience Manager
Hi, When I create a page using Page Manager ,page will be created with properties "cq:template" and "sling:resourceType" .Resource type will be obtained anyway with the template we are gng to pass as a parameter while creating the page. Can I create a page without "sling:resourceType" property .So that if I change the resource type of the template in the future ,that doesn't effect my content ? (I have lot pages .I cant change the resource type of each if template is changed) Thanks,Krishna

Views

876

Likes

0

Replies

2