Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Raja-kp
Raja-kp
Online

Badges

Badges
30

Accepted Solutions

Accepted Solutions
29

Likes

Likes
129

Posts

Posts
120

Discussions

Discussions
25

Questions

Questions
95

Ideas

Ideas
1

Blog Posts

Blog Posts
0
Top badges earned by Raja-kp
Customize the badges you want to showcase on your profile
Re: Managing User Permissions in AEM | AEM Community Blog Seeding
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
Very useful blog.

Views

6

Likes

0

Replies

0
Re: Workflow migration for 6.5 upgrade
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@Alisahali Can you a raise Adobe support ticket to review these steps to be followed for workflow migration- so that we won't be missing any steps. Regards,Raja

Views

18

Likes

0

Replies

1
Re: Log in for CRX in AEM 6.4 and 6.5
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@Magicr CRXDE console authentication is disabled due to AEM Security checklist. Associated bundles are below:Adobe CRXDE Support (com.adobe.granite.crxde-support)Adobe Granite CRX Explorer (com.adobe.granite.crx-explorer)Adobe Granite CRXDE Lite (com.adobe.granite.crxde-lite)Regards,Raja

Views

25

Likes

3

Replies

0
Re: How to implement SAML authentication in AEM
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@ArunaSurukunta Please follow the below steps to implement SAML authentication: 1.Update the SAML keys under /etc/keys in the CRXDE console.2.Add the IdP Certificate to the AEM Trust Store.(a) Go to http:/serveraddress:serverport/libs/granite/security/content/truststore.html(b)Press the Create TrustStore link(c)Enter the password for the TrustStore and press Save.(d)Click on Manage TrustStore.(e)Upload the IdP certificate.(f)Take note of the certificate Alias3.Please update the OSGi configuratio...

Views

34

Likes

3

Replies

0
Re: Scheduler unable to trigger in AEM author instance
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
Hi @ArunaSurukunta Can you verify the user permission of the scheduler script ? Also can you verify the cronjob expression of the scheduler ? Regards,Raja

Views

76

Like

1

Replies

2
Re: segment.SegmentNotFoundException: Error at beginning of oak-run check cmd
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@manu-gupta Based on the log you have provided, you are using the oak run version of 1.38.0.1.Make sure online compaction is disabled to avoid the nodes getting corrupted or removed by data store garbage collection.2.Above AEM6.3 version, you must use oak-run-1.6.x.jar. Download the oak-run-1.6.x.jar version from the link :https://repo1.maven.org/maven2/org/apache/jackrabbit/oak-run/3. After updating the oak run jar - perform the offline compaction again and let us know the result. Regards,Raja

Views

8

Like

1

Replies

0
Re: Facing High Load Issue on PROD Publishers, while installing a AEM React package.
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@sush6 As this is performance related issue with the Production instances,1. What's the CPU/Memory utilization during deployment in Publishers ?2. Are we getting the same issue in lower environment servers ?3. Are we seeing the same issue in Production Author while installing the package ? If yes - what's the configuration change between Author & Publisher ?4. What's the ERROR you are getting while installing the package in Publisher ?5. Can you tail the ERROR Log while installing the package in...

Views

41

Likes

2

Replies

0
Re: Can anyone help me with any documentation for configuring email sending in AEMaaCS
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@lmalyala Please review the configuration in OSGi console - "Day CQ Mail Service" as below: Please refer this article - https://www.albinsblog.com/2019/11/SMTPSendFailedException-Must-issue-a-STARTTLS-adobe-experience-ma... Regards,Raja

Views

81

Likes

2

Replies

0
Re: Cloud manager dispatcher setting
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@chetan001 To figure out this issue is related to Dispatcher configuration or Sling mapping configuration -> Can you share the response of the request from dispatcher log and we can check where/why we are getting the [Actionblocked] error ?

Views

26

Like

1

Replies

0
Re: AEM Cloud Service | How to check dispatcher cached files & headers | CORS issue
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
Can you find the cache root directory from farm file or Virtual host of the website and let us know ?

Views

36

Likes

2

Replies

0
Re: AEM Cloud Service | How to check dispatcher cached files & headers | CORS issue
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
Navigate to the cache directory of the website where you have implemented the configuration change and delete all the files under the cache directory . Regards,Raja

Views

45

Like

1

Replies

2
Re: AEM Cloud Service | How to check dispatcher cached files & headers | CORS issue
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
As mentioned @Asutosh_Jena_ Try to clear the cache from Dispatcher & CDN if you have using.Clearing the cache entirely will be required to ensure the headers are appropriately cached on the next request after a /cache/headers configuration update.Troubleshooting CORSLogging is available under com.adobe.granite.cors:enable DEBUG to see details about why a CORS request was deniedenable TRACE to see details about all requests going through the CORS handler.Please refer this article to troubleshoot ...

Views

51

Like

1

Replies

4
Re: How to migrate ACLs from on premise to aem as a cloud service instances?
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@GK-007 You can archive the ACL migration by using1.Package manager console or2.ACS common tool (https://server:port/miscadmin#/etc/acs-commons/packagers) Please refer these articles for your reference:http://www.aemcq5tutorials.com/tutorials/migrate-users-and-groups-with-acl-permissions-in-aem/https://www.albinsblog.com/2018/09/adobe-experience-manageraemon-premises-to-AMS-cloud.htmlhttps://helpx.adobe.com/la/experience-manager/kb/migrate-users-groups-ACLs.html Regards,Raja

Views

11

Like

1

Replies

0
Re: OSGi console is blank in Production Author
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
Just to add - this is an issue with AWS - WAF rule (AWSManagedRulesLinuxRuleSet) which blocking "config.js" file and AWS technical team is working on fixing the issue. Regards,Raja

Views

7

Like

1

Replies

0
Re: 500 org.apache.commons.mail.EmailException: Sending the email to the following server failed
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@binoyp73053411 Can you tail the error logs and do check the configuration in OSGi console - "Day CQ Mail Service" as below: Please refer this article - https://www.albinsblog.com/2019/11/SMTPSendFailedException-Must-issue-a-STARTTLS-adobe-experience-manager.html Regards,Raja

Views

30

Like

1

Replies

0
Re: Dispatcher redirect failing due to single quote
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@binoyp73053411 Can you let us know where the %27 value in configured ? Source URL or Destination URL ?Also can you share the redirect rule how you have configured ?You can try to add "NE" flag in your redirectmap configuration in the dispatcher file.Using the [NE] flag prevents the special characters will be converted to their hexcode equivalent. Regards,Raja

Views

25

Like

1

Replies

0
Re: Permission sensitive caching
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@Apmag Akamai CDN has no user base where it can check authentication against, so it can't authenticate for permission.There are two parts in this question: Authentication and Authorization. AuthorizationTo grant access by urls we would use property manager rules which can match by value, wildcard or regex. AuthenticationAkamai can validate by Token Auth (this is a simple signed token added as a query parameter or a cookie to a request).JWT-tokens would be possible (requires some advanced configu...

Views

28

Likes

2

Replies

1
Re: Ineffective Form's password protection
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@MHWinter Please post your queries in the Adobe FORM community :https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager-forms/ct-p/adobe-experience-manager-forms-communityif your question related to Adobe forms. Regards,Raja

Views

15

Like

1

Replies

0
Re: OSGi console is blank in Production Author
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
File path :/system/console/res/ui/config.js is unblocked from WAF rules and the OSGi configuration is accessible now. Regards,Raja

Views

31

Like

1

Replies

1
Re: SAML2 Auth for Specific Paths of Dispatcher-Served Published Site
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@thisthatheotter This is can archived by CUG permission or SAML integration with publisher instance.SAML Configuration in Publisher:Configure the required content path in SAML authentication OSGi configuration in publisher instance.2. Configure the Domain name that should redirects to authentication page.3. Create a user/group in publisher instance and grant required permission to the content path (which configured in SAML configuration)4. Disable the cache for content path in dispatcher. https:...

Views

21

Like

1

Replies

0
Re: OSGi console is blank in Production Author
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@Vijayalakshmi_S Thanks for your help on this. I have figured out that the path : system/console/res/ui/config.js is blocked from AWS WAF rule. Due to this, we are unable to view the OSGi configuration. We are started seeing this issue from last week and not sure how this was working earlier.Able to view the OSGi configuration after updating WAF rule in AWS. Checking the WAF rules what went wrong. Regards,Raja

Views

38

Like

1

Replies

3
Re: SDK local instance - Restart - Error 503 authentication
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@ana_belen_cano_ Looks like repository is corrupted. Please change the ERROR log level to DEBUG and the tail the logs.1. Check whether your Apache Sling Authentication Service Bundle is active or not (http://localhost:4502/system/console/bundles/)- if not active then try to activate it manually.2. Stop the AEM instance - Go to folder crx-quickstart/repository/remove folder index -> Start the AEM3. Go for a re-indexing - http://www.wemblog.com/2011/12/how-to-rebuild-index-in-cq5-wem.html"4. Delet...

Views

22

Like

1

Replies

0
Re: AEM - log4j
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@brentd5354857 Navigate to OSGi bundles console - look for log4j bundle version -> All versions from all from 2.0-beta9 to 2.14.1 are impacted.Please refer this article for AEM log4j vulnerability (CVE-2021-44228) :https://www.albinsblog.com/2021/12/apache-log4j2-remote-code-execution-through-JNDI-endpoints.html

Views

51

Like

1

Replies

1
Re: OSGi console is blank in Production Author
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
Hi @Vijayalakshmi_S Enabled the log level to TRACE but we didn't find any errors in the dispatcher logs and the response code is 200 for the /system/console/configMgr. What would be the impact if we perform the framework restart ?

Views

61

Like

1

Replies

5
Upgrade Apache to 2.4.52 version to fix the DOS vulnerability in Apache HTTP server
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
Hi All, It is recommend to update Apache HTTP Server to the latest and stable version i.e. 2.4.52 to fix the DOS vulnerability in Apache HTTP server. Do we have steps to update the Apache version to 2.4.52 ? please share if anyone already performed.

Views

160

Likes

0

Replies

1
Re: OSGi console is blank in Production Author
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@Vijayalakshmi_S We are getting 403 error response code for that js file and the error is occurring for Admin user as well. We will check the Dispatcher log for the OSGi request and let you know.

Views

75

Like

1

Replies

6
Re: OSGi console is blank in Production Author
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
Yeah - we have upgraded to SP10 (last month) but we started seeing this issue from last week.No cache files in author.From Developer tool - we are getting 403 Error code for this page path: server:port/system/console/res/ui/config.js.

Views

79

Like

1

Replies

8
Re: OSGi console is blank in Production Author
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@Vijayalakshmi_S Thanks for your response.One thing I noticed today - I'm able to see the OSGi configuration if I access via IP address but NOT with Author DNS. Yes - I'm able to view/access other consoles in OSGi. Can you please let me know the impact if any ? when we run the framework restart ? As mentioned - we are seeing this issue only in Production Author instance.

Views

90

Like

1

Replies

10
Re: Why the asset upload process failed and how to solve this problem
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@user09510 Can you check the workflow process step -> dam update asset workflow .1. Create a custom log for DAM upload step and tail the logs when you are trying the upload the DAM assets.2. Check the workflow console if anything failed in failure tab. Regards.,Raja

Views

36

Like

1

Replies

0
Re: Unable to setup and run Dispatcher on Linux VM based on Azure Cloud
Avatar
Give Back 100
Level 7
Raja-kp
Level 7

Likes

129 likes

Total Posts

120 posts

Correct reply

29 solutions
Top badges earned
Give Back 100
Affirm 25
Boost 100
Contributor 2
Ignite 10
View profile
Raja-kp
- Adobe Experience Manager
@anuraggoswami3 Please try to include the /etc/sysconfig path in your httpd configuration (httpd.conf) or Update your environment variables under /etc/httpd/conf.d/variable/ (custom or global file) and include file path in your vhost file or httpd.conf file.. Like : Include conf.d/variables/custom.vars Regards,Raja

Views

25

Like

1

Replies

0