Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

jsvasu
Community profile jsvasu Level 3
Job title here
Location here
11 BADGES
Level 3

Level 3

Learn more
Joined the community 22-07-2020 7:16:31 AM
Offline
Top badges earned by jsvasu
Customize the badges you want to showcase on your profile
Tracking play time for videos in adobe
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
Is it some how possible to track the time for which the video is played on a web page in Adobe? or average time the video is played on webpages. I ahve many tutorial pages where the on-demand video content lies. In this case user has to hit play button to get the videos play. Can we track for how long particular video is played? or average second or minutes the video is played?

Views

131

Likes

0

Replies

3
Re: Data Element not populating values for evar correctly
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
@PratheepArunRaj i tried setting the storage of the Data Element to None then it worked for me correctly. It was may be due to because of the nature of the website. Thank you so much for your suggestion on Direct Call. This actually worked better than history change. We are now able to trigger the adobe hit also through "Direct Call". thanks

Views

336

Likes

0

Replies

0
Re: Data Element not populating values for evar correctly
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
@PratheepArunRaj I have implemented Direct call rule but the hits are happening twice ie. one via history change rule which is pushing page URL update from browser via custom code shown below:And one hit is happening via Direct call rule. Moreover, in my data layer, data object "contentType" is existing only for specific detail pages like Articles, Forums, blogs etc, not for whole site. And, if I visit any of the detail pages the content type do get updates but it stays/persist for further navig...

Views

356

Likes

0

Replies

0
Re: Data Element not populating values for evar correctly
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
@PratheepArunRaj on SPA website I have actually made adobe hit to happen via history change rule where I custom code to update the page url like below And, as suggested by you I tried using Data Element change configuration as below. I have my Data Element "page title" configured which I am pulling here in the rule event type & getting the evars to triggered. I have changed the time here from 2000ms to 4500 ms so that event get time to pop the evars value. Is this is fine? However, the evars val...

Views

383

Likes

0

Replies

2
Re: Data Element values populating values for evar correctly
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
@yuhuisg , @Brian_Johnson_, @PratheepArunRaj any help on the issue

Views

423

Likes

0

Replies

0
Data Element not populating values for evar correctly
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
I have webpages as Single page application (SPA) without refresh. I am getting adobe hit for every URL change with the help of History Change event type. Now I am trying to capture some of the data layer objects on every URL change. For this I created seprate data elements and mapped them to evars & enabled a DOM ready event type rule in launch however, I am unable to get anything in the debugger (looks like DOM reday is not right event type). Any suggestions on this? I also tried changing it to...

Views

429

Likes

0

Replies

7
Data Element values not coming up
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
I have webpages as Single page application (SPA) without refresh. I am getting adobe hit for every URL change with the help of History Change event type. Now I am trying to capture some of the data layer objects on every URL change. For this I created seprate data elements and mapped them to evars & enabled a DOM ready event type rule in launch however, I am unable to get anything in the debugger (looks like DOM reday is not right event type). Any suggestions on this? I also tried changing it to...

Views

119

Likes

0

Replies

1
Building Calculated Metrics
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
I am looking to build a calculated metrics for Avg. Number of clicks per visitor (in terms of activity map clicks by visits ). Also, wondering about some great documentation on building calculated metrics thoroughly.

Views

146

Likes

0

Replies

2
Re: Configuring List Variables in Launch
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@Brian_Johnson_ can you help on this issue? How I can get the list var defined in the launch so that the corresponding classification receives the data out of the feedback form when it is successfully submitted?Thanks

Views

356

Likes

0

Replies

0
Re: Adobe Launch, Tracking page view With React without r...
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@Brian_Johnson_ its resolved. Thank you

Views

227

Likes

0

Replies

0
Re: Adobe Launch, Tracking page view With React without r...
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@Brian_Johnson_ can you help on where in rule and how ?

Views

249

Likes

0

Replies

0
Re: Adobe Launch, Tracking page view With React without r...
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
Hi @yuhuisg, I have the same thing implemented at my end. I have webpages which are Single Page Application without refresh. The URL change happens on navigation but not the whole page is refreshed that's why no adobe hit happens until pages are hard refreshed. To solve this I created History Change event in launch and set Send Beacon to s.t() however, Adobe is associating every page view with the page URL that was present when the analytics library first loaded.

Views

274

Likes

0

Replies

0
Re: Analytics data not coming up
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
@vibhatna we have tried implementing the History Change event type to trigger for our usecase. The thing we have found is In adobe debugger the adobe server call is happening but it does not look correct to me because Page URL is remaining the same on each click from where I started navigating on other pages. However, pages are seeing updating in Page/Frame URL.I think the activity map page is not correct here. What does Page/Frame URL tell us?

Views

243

Likes

0

Replies

0
Re: Analytics data not coming up
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
@vibhatnaI also found the same support solution https://helpx.adobe.com/dtm/kb/How_to_use_DTM_for_Single_Page_Apps.html However I am not sure about one thing. Like if we create a direct call rule then we have to map an event to trigger when this direct call success will happen but would I be able to track the general user metrics like Unique visitor, page views, activity map, marketing channels etc? What if I just configure the event as DCR rule and send a beacon & no variable is set. Then also ...

Views

245

Likes

0

Replies

0
Re: Analytics data not coming up
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
@vibhatna I configured a page load rule (DOM ready) and set "Send Beacon" to s.t() however in the debugger I just see adobe call happening for the home page not after that untill I dont referesh the page. Looks like In my case URL is changing but the whole page is not getting refreshed.. only the content below while navigating on pages is getting refreshed. How to track that & send adobe hits?

Views

259

Likes

0

Replies

0
Analytics data not coming up
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
I have configured a new property in Launch for our new subdomain. The Adobe Launch Code is already placed on web pages, however, I can not see any data coming in the report suite. Any possible reason?I have been assuming once the launch code is put on web pages then the web pages should get synced up automatically into adobe report suite for general user metrics like unique visitors, page views, visits, marketing channels, activity map, etc. We don't need to create any page load rules until requ...

Views

391

Likes

0

Replies

7
Re: Configuring List Variables in Launch
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@amgup @Andrew_Wathen_ any thoughts on the previous response

Views

364

Likes

0

Replies

0
Re: Configuring List Variables in Launch
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@amgup well I tried creating the classification rules in classification rule builder like that & tried testing it also before activating it. If I pass the string of key then I get the correct result. However, how it is solving my purpose? How on successful feedback submission this info will get captured? How this is solving my purpose? @amgup @Andrew_Wathen_ Any thoughts on this? I am assuming there is something missing in launch for this list variable. Can you help me in correcting that?

Views

388

Likes

0

Replies

1
Re: Configuring List Variables in Launch
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@amgup, No, I haven't defined any rule in Classification rule builder for my list variable

Views

374

Likes

0

Replies

0
Re: Configuring List Variables in Launch
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@amgup is there is any way out apart from building classification rules. I don't want to build classification rules. I am looking around if AppMeasurement and Launch custom code editor can solve the purpose

Views

394

Likes

0

Replies

0
Re: Configuring List Variables in Launch
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@Andrew_Wathen_ @amgup This is the dummy table I am looking to show up in my report suite Can we directly map List Variable name in the custom code editor? It dint show actually anything to me.And when I tried to put the code like below the "List variable" list1 started appearing in the debugger but it showed the value "Feedback" which I passed in code: s.linkTrackVars = "list1";s.list1="Feedback"; However, I want it like when feedback is successfully submitted it should also capture all the det...

Views

433

Likes

0

Replies

3
Re: Configuring List Variables in Launch
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@amgup I put custom code like that: s.linkTrackVars = "list1";s.list1 = "Desktop,Mobile,Default Form,How would you rate our website?,Hate,Dislike,Neutral,Like,Love,What would you like to share with us"; This is how It is displaying in the server calland also in debugger, the list variable is coming up as such:I guess there is some problem with the custom code I put.

Views

434

Likes

0

Replies

2
Re: Configuring List Variables in Launch
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@Andrew_Wathen_ @amgup My button looks like this. When a user clicks on the Feedback button then the form opens like that & I want to capture the question and its corresponding Answer. I am using the custom code as below but this is printing the complete string as such in the debugger that I have passed.s.linkTrackVars = "list1";s.list1 = "Desktop ,Mobile,Default Form,How would you rate our website?,Hate,Dislike,Neutral,Like,Love,What would you like to share with us"; Thanks

Views

408

Likes

0

Replies

1
Configuring List Variables in Launch
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
I have a feedback button enabled on our webpage. I want to capture the Question & Answer given by the users in this feedback form & analyze them into adobe analytics. I have created a list variable for this & set the conversion classification and its hierarchy also. But in launch how should I configure or map that list variable so that whenever a user gives feedback it floats to adobe analytics? Thanks,jsvasu

Views

714

Likes

0

Replies

14
Re: Adobe Call not happening
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@Andrey_Osadchuk @irama987596 The integrated button on the website actually has a configuration that says we just have to create "success events" in analytics and map them into Feedback Tool's Web Account as below. We are not supposed to build any click event rules to capture as per the button's configuration. Success Events Created in Analytics:This is how they are mapped in Feedback Tool's Web account: We are bringing this Feedback button as a page load rule via Launch so that it appears on ev...

Views

309

Likes

0

Replies

0
Re: Adobe Call not happening
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
@HemanginiS and @irama987596 Thanks, maybe I need to be more elaborative. Even after setting the s.tl() my purpose is not getting solved.I don’t see the Analytics call getting triggered in the developer console window when a user clicksthat Feedback Button (which means the feedback is opened) on my page.This is how I set it up now. I guess from this setting adobe call is happening for page load, not for click on thefeedback button. Any help on that?I want to adobe call to happen when the user wi...

Views

334

Likes

0

Replies

1
Re: Adobe Call not happening
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
Thanks @HemanginiS for your response. Is this being the reason why Adobe Analytics call is not happening? Because as I mentioned this is the DOM Ready rule which is bringing a "Button" on every page load. And, in my first screenshot I showed that, under Actions in “Core-Custom Code” we just put our JS snippet to load the button but have not set the “Adobe Analytics – Send Beacon” action after that? So, should we try adding that?

Views

354

Likes

0

Replies

0
Adobe Call not happening
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Experience Platform Data Collection
Hello, We have configured a button that is populating via Adobe Launch for every page load rule as below: The button is populating on all pages exactly the way we wanted it to be however there is no call happening to Adobe Analytics when we are clicking on the button. I have checked it in the Network of the developer console window, which ideally I guess it should. So at this node, I wanted to confirm, Do we have to do set up a "Send Beacon" here like that ?Best

Views

467

Likes

0

Replies

8
Re: SAINT files upload Status in Adobe Analytics?
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
@atulsingh17 Thanks for the response. I could see the values that I uploaded via Saint file through Browser Export downloaded file, which means I guess my classification file has been imported successfully.

Views

191

Likes

0

Replies

0
SAINT files upload Status in Adobe Analytics?
Avatar
Give Back
Level 3
jsvasu
Level 3

Likes

0 likes

Total Posts

55 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
- Adobe Analytics
Hello! I have uploaded two saint files in the classification importer and after hitting the import file button. I got the same message for both of the files.I have read it usually takes 72 hours to sync up and that time frame is already been completed. Is there is a way to check in adobe if those files are uploaded and propagated to all servers successfully?

Views

218

Likes

0

Replies

2
Likes given to