Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

fionas76543059
fionas76543059
Online

Badges

Badges
19

Accepted Solutions

Accepted Solutions
1

Likes Received

Likes Received
24

Posts & Comments

Posts & Comments
98

Discussions

Discussions
0

Questions

Questions
17

Ideas

Ideas
0

Blog Posts

Blog Posts
0
Top badges earned by fionas76543059
Customize the badges you want to showcase on your profile
Re: In AEM, can you call a service from a WcmUsePojo using annotations ? - Adobe Experience Manager 07-07-2022
thanks Santosh,Is TextComponentModel annotated with @Model so that I can use annotations in it?thanksFiona

Views

75

Like

1

Replies

0
Re: In AEM, can you call a service from a WcmUsePojo using annotations ? - Adobe Experience Manager 06-07-2022
hi Santosh, Are you saying, if you want to use annotations, don't use classes extended from wcmUsePojo : Convert the Class to be a @Model class instead. ? thanksFiona

Views

116

Like

1

Replies

2
In AEM, can you call a service from a WcmUsePojo using annotations ? - Adobe Experience Manager 06-07-2022
hi folks,Can you annotate a class extended from WcmUsePojo with @componentand call a service using @reference? I.e. using felix scr annotations. I tried it and got errors messages about ScriptEvaluationExceptions. The service works fine with bundlecontext. thanksFiona

Views

125

Likes

0

Replies

6
Re: AEM publish servers aren't using the configuration in my OSGi xml files - Adobe Experience Manager 07-06-2022
The problem seems to occur when we are reusing old artifacts on Stage environment. There is a pipeline directive that you can use so that you stop the pipeline reusing old artifacts so I'm going to do this. Hopefully this will resolve my problems.

Views

54

Like

1

Replies

0
Re: AEM publish servers aren't using the configuration in my OSGi xml files - Adobe Experience Manager 30-05-2022
Thanks Santosh. I might proceed to deploying to Prod, but keep a backup file of the configs on Prod just in case, the same thing happens in that environment. At least I can recover then.

Views

72

Like

1

Replies

1
Re: AEM publish servers aren't using the configuration in my OSGi xml files - Adobe Experience Manager 30-05-2022
The filter for the aem.config... package has a mode=update and runs after the aem.apps one.You don't suppose the order of these could ever get mixed up?

Views

82

Like

1

Replies

0
Re: AEM publish servers aren't using the configuration in my OSGi xml files - Adobe Experience Manager 30-05-2022
Thanks Santosh,. Have you idea why I got the above crx/packmgr error messages.? My support ticket guy thought it was because I was flicking between branches that had already been deployed earlier on Staging (i.e. branches that already had been built into packages with checksums that were recognized.) But I've tried flicking between branches a few times on Staging and it didn't reproduce the problem.

Views

87

Like

1

Replies

4
Re: AEM publish servers aren't using the configuration in my OSGi xml files - Adobe Experience Manager 30-05-2022
Thanks Santosh,A subsequent deploy to an updated "develop" worked o.k. so I 'll have to try reproduce it again. I am the only person who installs packages on AEM prod and I do it via Cloud Manager always. With the problem, in crx/packmgr, the "all" package was fine but all its subpackages had this message under them. "A different version seems to be installed..." There is a subpackage, aem.ui.apps. which has a lot of filters including /apps/xxx ( which gets 3 folders, clientlibs,components and t...

Views

91

Like

1

Replies

6
Re: AEM publish servers aren't using the configuration in my OSGi xml files - Adobe Experience Manager 27-05-2022
I did find in the error.log where the configurations were being deleting. This happened during the Cloud Manager deploy that resulted in the crx/packmgr messages "A different version seems to be installed..." and after which the servers had their problems I don't know why the OsgiInstallerImpl deleted them. 25.05.2022 21:22:31.914 *INFO* [OsgiInstallerImpl] org.apache.sling.audit.osgi.installer Deleted configuration com.xxx.soap.services.impl.ConsumeSOAPServiceImpl from resource TaskResource(url...

Views

113

Likes

2

Replies

8