C_M_G
Community profile C_M_G Level 1
Job title here
Location here
1 BADGE
Level 1

Level 1

Learn more
Joined the community 02-11-2017 4:38:38 PM
Offline
Top badges earned by C_M_G
Customize the badges you want to showcase on your profile
Re: How to solve character encoding issues in subject with emoji and special characters?
Avatar
Validate 1
Level 1
C_M_G
Level 1

Likes

0 likes

Total Posts

5 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
C_M_G
- Adobe Campaign Standard
Hm; then I guess the question is, does Adobe have a function that will apply that encoding? The data we're using in the title is not static, but from a resource we have.

Views

2.1K

Likes

0

Replies

0
Re: How to solve character encoding issues in subject with emoji and special characters?
Avatar
Validate 1
Level 1
C_M_G
Level 1

Likes

0 likes

Total Posts

5 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
C_M_G
- Adobe Campaign Standard
Well that's a new one. Something's changed now, and even without a special character, it breaks.The subject is now being UTF-8 encoded, which results in the emoji marker being encoded again, and so it decodes to the raw text of the =?UTF-8 stuff instead of the emoji as intended.Example:Subject: =?utf-8?B?PT9VVEYtOD9RPz1GMD05Rj05ND1BNT89wqBTbGlja2RlYWxzJw==?= =?utf-8?B?IHRlc3QyQiBEZWFsczogV2F0Y2ggRG9ncyAoWGJveCBPbmUpIGF0IE1pYw==?= =?utf-8?B?cm9zb2Z0IFN0b3Jl?=

Views

2.1K

Likes

0

Replies

0
Re: How to solve character encoding issues in subject with emoji and special characters?
Avatar
Validate 1
Level 1
C_M_G
Level 1

Likes

0 likes

Total Posts

5 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
C_M_G
- Adobe Campaign Standard
I just sent another test email to grab some screenshots:Subject: =?UTF-8?Q?=F0=9F=94=A5?= Emoji Test 1Result: https://i.imgur.com/D84v0UR.pngSubject: =?UTF-8?Q?=F0=9F=94=A5?= Émoji Test 2Result: https://i.imgur.com/Q8Kgupo.png

Views

2.1K

Likes

0

Replies

0
Re: How to solve character encoding issues in subject with emoji and special characters?
Avatar
Validate 1
Level 1
C_M_G
Level 1

Likes

0 likes

Total Posts

5 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
C_M_G
- Adobe Campaign Standard
Yes, I've seen that thread before; as you'll note, we're using the same method described there. However, we're encountering the same issue as the last comment in that thread that was never replied to.It works fine until something like é or © shows up and then it all blows up. Something in Campaign is adding a bunch of windows-1252 (latin1) encoding markers to the subject and this causes the =?UTF-8 code to stop working and be displayed verbatim.

Views

2.1K

Likes

0

Replies

0
How to solve character encoding issues in subject with emoji and special characters?
Avatar
Validate 1
Level 1
C_M_G
Level 1

Likes

0 likes

Total Posts

5 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
C_M_G
- Adobe Campaign Standard
We're trying to send out an email with a fire emoji, represented by =?UTF-8?Q?=F0=9F=94=A5?=It works fine for the most part, until an email contains higher ascii such as © or ó, at which point it starts trying to mix encodings and set the rest of the title as windows-1252 according to the header output, at which point you see the above =?UTF-8?...etc string printed out in the subject.We're importing the data as UTF-8, and even tried the "Force Encoding" setting in the master template, but it sti...

Views

4.9K

Likes

0

Replies

12