Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

mallikac4933100
Community profile mallikac4933100 Level 2
Job title here
Location here
8 BADGES
Level 2

Level 2

Learn more
Joined the community 25-07-2017 3:59:29 PM
Offline
Top badges earned by mallikac4933100
Customize the badges you want to showcase on your profile
Radio button in AEM
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
Hi I'm trying to access the radio button value from dialog box of component, i.e., I have configured a radio button on component. I want get the boolean value of the radio button if selected in the component js. But I am not understanding how to know if radio button is checked or not in javascript.sling:resourceType = /libs/granite/ui/components/foundation/form/radio

Views

3.4K

Likes

0

Replies

2
Re: Unable to deploy core package with autoInstallPackage command
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
I would like to mention a new observation, on my system also the core does not deploy with autoInstallPackage. I was under the impression that it works on mine. As you suggested I created a new project on both 10 and 11 and executed the autoInstallPackage command, and it worked in both cases. I'm not sure now what could be the mistake in my project setting in that case.

Views

5.1K

Likes

0

Replies

0
Re: Unable to deploy core package with autoInstallPackage command
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
11 is working on my system though. I will have to recreate the project to change the archetype to 10.

Views

5.1K

Likes

0

Replies

2
Re: Unable to deploy core package with autoInstallPackage command
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
I forgot to mention that the core package gets deployed when clean install -PautoInstallBundle command is executed. Also the project is created on archetype 11.

Views

5.1K

Likes

0

Replies

4
Re: Unable to deploy core package with autoInstallPackage command
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
Yea, my team is using 6.2 AEM version.

Views

5.1K

Likes

0

Replies

6
Unable to deploy core package with autoInstallPackage command
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
Hi All,I am facing an issue in deploying core package. When I run clean install -PautoInstallPackage on the project, the core package is not getting deployed i.e. I am unable to see the core bundle of the project on the console. This command works on my system as in, the core packages gets deployed however when I am testing on my teammates system the same doesn't work.Could there be any maven setting I am missing here which could be causing this. Kindly help.Thanks,Mallika

Views

6.3K

Likes

0

Replies

8
Re: Calling Component in a servlet
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
Thanks Vivek, it worked once I removed the instantiation. 

Views

1.4K

Like

1

Replies

0
Re: Calling Component in a servlet
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
I have a small query about the component attributes. what happens when the immediate attribute is set to false? When can it be activated if configured as false?

Views

1.5K

Likes

0

Replies

0
Re: Calling Component in a servlet
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
I am in a hurry to complete this task. It would be really helpful if you could point out the error for now so that I can correct it asap. Thanks.

Views

1.4K

Likes

0

Replies

0
Re: Calling Component in a servlet
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
Below is my java code snippet for Email servlet@SlingServlet(paths="/bin/sendEmail", methods = "POST", metatype=true)public class EmailServlet extends org.apache.sling.api.servlets.SlingAllMethodsServlet { private static final Logger LOG = LoggerFactory.getLogger(EmailServlet.class); @Reference private SlingRepository repository; public void bindRepository(SlingRepository repository) { this.repository = repository; } @Reference private transient EmailService emailService; @Override protected voi...

Views

1.4K

Likes

0

Replies

0
Calling Component in a servlet
Avatar
Ignite 3
Level 2
mallikac4933100
Level 2

Likes

4 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
mallikac4933100
- Adobe Experience Manager
I have a query regarding the email flow. I have implemented email servlet which receives request from client side in a POST call. Once received I call the EmailService component in the servlet. This component should get configuration details from OSGi (server,port,username,password) and from,to,subject,message details from client side and send the email using javax mail jar. However, the configuration from OSGi is not successful. I want to understand how to call component (gathers configuration ...

Views

5.2K

Likes

3

Replies

8
Likes given to