Avatar

Avatar

nutmix

Avatar

nutmix

nutmix

25-11-2020

Adobe sent me the AEM 6.5 quickstart jar and a key.

 

As per these instructions: https://experienceleague.adobe.com/docs/experience-manager-learn/foundation/development/set-up-a-loc...

 

i created the author and publish dirs, copied in the quickstart jar and rename them aem-author-p4502.jar etc.

 

Adobe dont supply the required license.properties file, and after some searching I find it is supposed to create it on first launch.

 

Anyway, when I run aem-author-p4502.jar it creates a crx-quickstart dir, opens a window saying "starting quickstart on port 4502" then does nothing.

 

if I hit https://localhost:4502 nothing is there (connection refused).

 

I tried creating a license.properties file and pasting in the key, but this results in "push back buffer full" error.

 

I have 16GB ram, I am not running anything else, quad core i7, 2TB 3200 MB/s nvme SSd, and gigabit network with 600Mbit symmetrical uncontested fibre.  I have no proxy, vpn or filewall running (other than standard windows defender).

 

I have java 11 jdk installed and JAVA_HOME correctly set (so I can run mvn etc).

 

>java -version
java version "11.0.9" 2020-10-20 LTS

Java(TM) SE Runtime Environment 18.9 (build 11.0.9+7-LTS)
Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.9+7-LTS, mixed mode)

 

>echo %JAVA_HOME%
C:\Program Files\Java\jdk-11.0.9

 

 

 

Anyone have any ideas how to fix this?

 

== update 1 ==

After some trial and error, I find that if I run the jar file in my downloads folder, without changing its name, it runs, and I get prompted for a browser login. I cant find the login details anywhere, but at least it "ran".  If I follow the tutorial, and put the jar in the author and publish subfolders and rename them, they hang when launched.

 

I now have a license file at least, by not following the developer guide.

 

== update 2 ==

Running either of the renamed jar files results in hanging, with no progress bar appearing.

If I run the un-renamed jar file, I get a loading progress bar, followed by "http://localhost:4502 startup time 20s".  If I then open chrome and go to this url, I get:

HTTP ERROR 503

Problem accessing /. Reason:

    AuthenticationSupport service missing. Cannot authenticate request.

== update 3 ==

More trial and error. I redownloaded the quickstart.jar, but this made no difference and the size is the same.

I notice that if I run my author/aem-author-p4502.jar it hangs. If I delete author/crx-quickstart dir, but have the correct and valid license.properties file along side the jar in the author dir, and try to run the jar, I always get "Fatal error: IOException Push back buffer is full". I have 10GB free ram, and around 1TB free disk space on the ssd.  it does create the crx-quickstart dir however. Then if I run the jar again, I dont get the push back buffer full error, it just hangs.

 

== update 4 ==

Adobe support kindly suggested doing this:

 

    author>java -XX:MaxPermSize=256m -Xmx1024M -jar aem-author-p4502.jar

 

However, this fails, and in the log file it creates we see the same error as double clicking on it:

 

 

 

 

 

 

 

java.io.IOException: Push back buffer is full
	at java.base/java.io.PushbackInputStream.unread(PushbackInputStream.java:229)
	at java.base/java.util.zip.ZipInputStream.readEnd(ZipInputStream.java:359)
	at java.base/java.util.zip.ZipInputStream.read(ZipInputStream.java:197)
	at java.base/java.util.zip.ZipInputStream.closeEntry(ZipInputStream.java:141)
	at com.adobe.granite.quickstart.base.impl.Unpacker.extractFiles(Unpacker.java:168)
	at com.adobe.granite.quickstart.base.impl.Unpacker.unpack(Unpacker.java:69)
	at com.adobe.granite.quickstart.base.impl.upgrade.UpgradeUtil.handleInstallAndUpgrade(UpgradeUtil.java:155)
	at com.adobe.granite.quickstart.base.impl.Quickstart.<init>(Quickstart.java:154)
	at com.adobe.granite.quickstart.base.impl.Main.<init>(Main.java:912)
	at com.adobe.granite.quickstart.base.impl.Main.main(Main.java:981)
Quickstart: aborting
MAIN process: shutdown hook
MAIN process: exiting

 

 

 

 

 

 

 

Note, MaxPermSize is not relevant for java 11.

 

== update 5 ==

Tried rebooting, deleting quickstart dir, running quickstart again, get same "Push back buffer is full" error message the first time, then hangs the second time.

 

== update 6 ==

Although oracle java 11 is on the official AEM 6.5 supported list, I installed Oracle 64 bit java 1.8, deleted the crx-quickstart dir, and ran the jar again. Got the exact same "push back buffer full" error.

 

 

>java -version
java version "1.8.0_271"
Java(TM) SE Runtime Environment (build 1.8.0_271-b09)
Java HotSpot(TM) 64-Bit Server VM (build 25.271-b09, mixed mode)

 

 

Who Me Too'd this topic