Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Who Me Too'd this topic

AEM_Dev_Newbie
Level 2
Level 2

I have been having this issue since last week. Tried to create a new AEM instance so I deleted the crx-quickstart folder and started AEM again. Everything went fine but when I tried to install the AEM service pack it could not be installed. The same behavior is happening for any package being installed through http://localhost:4502/crx/packmgr/index.jsp and I get the following error:

AEM_Dev_Newbie_0-1590404955539.png

Also get the following error in logs whenever the above problem occurs:

*ERROR* [qtp1913257142-71] org.apache.jackrabbit.vault.packaging.impl.ZipVaultPackage Error during install.
org.eclipse.jetty.io.RuntimeIOException: org.eclipse.jetty.io.EofException
at org.eclipse.jetty.server.ResponseWriter.isOpen(ResponseWriter.java:133) [org.apache.felix.http.jetty:4.0.8]
at org.eclipse.jetty.server.ResponseWriter.format(ResponseWriter.java:467) [org.apache.felix.http.jetty:4.0.8]
at org.eclipse.jetty.server.ResponseWriter.printf(ResponseWriter.java:439) [org.apache.felix.http.jetty:4.0.8]
at com.day.crx.packaging.impl.response.StreamedScriptResponse.writeCallback(StreamedScriptResponse.java:228) [com.adobe.granite.crx-packagemgr:1.2.74]
at com.day.crx.packaging.impl.response.StreamedScriptResponse.access$000(StreamedScriptResponse.java:44) [com.adobe.granite.crx-packagemgr:1.2.74]
at com.day.crx.packaging.impl.response.StreamedScriptResponse$1.flush(StreamedScriptResponse.java:82) [com.adobe.granite.crx-packagemgr:1.2.74]
at java.io.PrintWriter.flush(Unknown Source)...

There are more lines in error.log

 

I have tried starting AEM in a completely fresh browser such that not extensions interfere or any scripts don't get blocked. Still no luck. This problem started happening suddenly. There has been no change in the way I start new AEM instances and no change in code or my system's Java installation.

Who Me Too'd this topic