Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

Trigger Project Firefly execution using OpenWhisk alarms

prodriguezgarcia
Level 1
Level 1

Hello,

I'm building an application in Project firefly that will be used to launch a daily automation that ends loading data into Customer Attributes FTP (Target). I've tested the code of the function by calling it from the development web interface (after aio app run) and invoking it directly from the terminal (aio rt action invoke). In both cases, it is working perfectly. The problems come when I try to launch the function daily in an automated way. I'm using nodejs:12, and it seems that it's changing to node10 when using the alarms.

Captura de pantalla 2021-01-26 a las 13.15.40.png

 

The code that I have at my manifest.yml is the same that is provided at this CodeLab:
https://adobeio-codelabs-alarms-adobedocs.project-helix.page/?src=/lessons/lesson3.html

Do you know what can be causing this repeated errors at the alarm execution?

Regards

4 Replies
duypnguyen
Employee
Employee
Hi @prodriguezgarcia, what do you see from the logs if you do `aio activation logs ID`, and you pick any ID from the error line of the alarm? Could you also share the manifest definitions of the action, trigger and rule for this alarm?
prodriguezgarcia
Level 1
Level 1

Hi @duypnguyen! It seem that all my actions that are running with whisk alarms are emitting a timeout error. Result: "The action exceeded its time limits of 60000 milliseconds." My code is just returning the current date so it should not take more than 300ms aprox. The output for 'aio activation logsID' is this:
Captura de pantalla 2021-01-28 a las 9.33.19.png

The manifest file is exactly the same that is provided on the CodeLab:
Captura de pantalla 2021-01-28 a las 9.34.11.png

SarahXu
Level 3
Level 3
Hi @prodriguezgarcia, I believe this issue has already been fixed. I wanted to confirm with you and make sure that this issue is now resolved for you. Thanks!
prodriguezgarcia
Level 1
Level 1

Hi @SarahXu! The issue has been fixed. Thanks for your support.