Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Error: getaddrinfo EAI_AGAIN developers.adobe.io

gokula
Level 5
Level 5

Hello Team, 

 

I'm trying to work on Adobe launch API and following this guide to develop notification service https://medium.com/adobetech/adobe-experience-platform-launch-notification-service-with-adobe-i-o-ru... 

 

As per Implementation steps mentioned in above guide, I've started with project firefly which allows all the operations to set runtime actions. 

 

Now when I initialize my project using following command in terminal 

aio app init <app_name>

 

getting the below error. Can someone please let me know what's the issue. 

 

You are about to initialize the project 'launch_notification'

Error while generating the configuration from the Adobe Developer Console: CoreConsoleAPIError: [CoreConsoleAPISDK:ERROR_GET_ORGANIZATIONS] FetchError: request to https://developers.adobe.io/console/organizations failed, reason: getaddrinfo EAI_AGAIN developers.adobe.io
at ClientRequest.<anonymous> (C:\Users\agiwalg\AppData\Roaming\npm\node_modules\@adobe\aio-cli\node_modules\node-fetch\lib\index.js:1461:11)
at ClientRequest.emit (events.js:315:20)
at TLSSocket.socketErrorListener (_http_client.js:469:9)
at TLSSocket.emit (events.js:315:20)
at emitErrorNT (internal/streams/destroy.js:106:8)
at emitErrorCloseNT (internal/streams/destroy.js:74:3)
at processTicksAndRejections (internal/process/task_queues.js:80:21) {
type: 'system',
errno: 'EAI_AGAIN',
code: 'EAI_AGAIN'
}
Skipping configuration setup..

 

 

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

11 Replies
duypnguyen
Employee
Employee

Hi @gokula - could you try updating your CLI to the latest version with this command:

npm install -g @adobe/aio-cli

Make sure that all the plugins are "core" in the output of this command:

aio plugins --core

Then run the "aio app init <app_name>" command again.

gokula
Level 5
Level 5
Thanks you @duypnguyen for reply. I'm using the latest aio cli version @adobe/aio-cli/6.0.0 win32-x64 node-v14.15.2 with node v14.15.2. all plugins updated but still facing the same error.
tmj
Level 2
Level 2
@gokula doing a quick google search on `EAI_AGAIN` it looks like it maybe a network/proxy issue on the client machine. Could you check whether that is not the case?
duypnguyen
Employee
Employee

one more catch: node 14 is currently not the official supported version of aio-cli. Can you try running with node 12?

gokula
Level 5
Level 5

Hi @duypnguyen, @tmj - Apologies for not replying earlier. Yes, this error seems related to DNS lookup timed out error that either network connectivity or proxy related error and it's still coming and I can't proceed without this ahead. I’ve done some research into this and it looks like it might require Adobe to add proxy support to the aio-cli package. I found the following open issue: https://github.com/adobe/aio-cli/issues/224

 

If this is the issue It might be worth seeing when Adobe push this to progress as its bit stuck for me until add proxy support…

duypnguyen
Employee
Employee

hey @gokula - I will check with our team about this CLI enhancement. Can you now use the AIO CLI outside of the corp proxy? Or are you completely blocked?

Also, could you please share the output of `aio info` on your machine?

gokula
Level 5
Level 5

@duypnguyen- Thank you for quick reply. Yes I'm completely bound to proxy setup and can't go above that. as requested below is the screenshot of aio-info.

 

gokula_0-1626089401832.png

 

duypnguyen
Employee
Employee
@gokula - We have an enhancement ticket internally for this request. Our engineering team is currently blocked by the end of July release, so there is no ETA yet for the enhancement. We will let you know once there's further update for it. In the mean time, you could do app development outside of the corporate proxy.
dr_venture
Employee
Employee
in the blog post did you do step 3 "Create a new project on Adobe I/O Console to access Adobe Experience Platform Launch APIs"
dr_venture
Employee
Employee
to find out more about setting up a project you can see this recording https://www.youtube.com/watch?v=AwL0QRxH9JQ&t=51s