Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Cannot initiate login: says Company or School Account not supported

rbrowne_jcp1
Level 2
Level 2

Hi,

 

I recently received my Project Firefly access, did the Console I/O integration and setup the npm libs.

 

But when I try to run "aio login", open the access page, and try to login in it tells me that my account is not supported - it tells me "Company or school accounts are not supported. continue with a personal account."

 

My account is linked to my org with a federated login backed by okta.

 

I really fail to see the point of the personal account, because in that case I wouldn't have access to the data I need. Any ideas? 

 

rbrowne_jcp1_0-1593608338229.png

 

1 Accepted Solution
duypnguyen
Correct answer by
Employee
Employee

Hi @rbrowne_jcp1 , the issue has been fixed and deployed. Please make sure you have the latest AIO CLI (uninstall and re-install it with `npm install -g @adobe/aio-cli`).

Then, `aio login` with your company account should be working now.

View solution in original post

7 Replies
duypnguyen
Employee
Employee
Hi - our team is looking into the issue and will update here.
rbrowne_jcp1
Level 2
Level 2
Hi, thanks for the response. No change so far, still cannot login. Please do let me know once this is fixed.
rbrowne_jcp1
Level 2
Level 2
hi, any updates on this? I have some free time now to build this out. So would really appreciate a resolution to this issue. Thanks.
SarahXu
Level 3
Level 3
Hi @rbrowne_jcp1 we are working on this issue currently! You can tract the progress here. https://github.com/adobe/aio-cli-plugin-auth/issues/49 Our apologies for the belated response -- Adobe was in shutdown last week so we are just coming back to work.
duypnguyen
Correct answer by
Employee
Employee

Hi @rbrowne_jcp1 , the issue has been fixed and deployed. Please make sure you have the latest AIO CLI (uninstall and re-install it with `npm install -g @adobe/aio-cli`).

Then, `aio login` with your company account should be working now.

View solution in original post

rbrowne_jcp1
Level 2
Level 2
thank you so much @duypnguyen works now... really appreciate the response
rbrowne_jcp1
Level 2
Level 2
thanks @SarahXu for the update... wasn't aware of the break.... thank you