Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

Auth error: 401 with or without extension

Anil_Umachigi
Level 2
Level 2

Hey Guys! 

@dr_venture @duypnguyen 

I have been trying to wrap my head around extension and looking forward to the recording of the Aug 12 event, Meanwhile i have issues when i bootstrap an app with or without extension added. 

 

I get an error

 

failed request to 'https://115564-digitalbau-stage.adobeioruntime.net/api/v1/web/nonExtnDemo/analytics' with status: 401 and message: {
  "error": "request is invalid, reason: failed authorization. Please verify your token and organization id."
}

The app includes .env file with required details and i can see the frontend sending headers with required information. 

Also i observed that the action url in config.json and in adobe io console stage workspace are different. Not sure if that makes any difference 

nonextndemo.jpg

 

 

 

4 Replies
duypnguyen
Employee
Employee

Hi @Anil_Umachigi -

For the action URLs, what is called by the UI is the config.json. The list on Console is just for reference purpose and the hostname could be different (it was a legacy hostname not used anymore).

For the 401 error: Did it work before and only failed since the extension point feature was released?

Along with the new feature release, the auth validator for SPA was updated as well. It should still work as before, because all the conditions remain the same (that your account should have developer role in the org for all the services / APIs that the project includes).

Anil_Umachigi
Level 2
Level 2

Thanks for getting back and for the clarification on the action URL's.

Since the time extension was released i am unable to get this working irrespective of with or without extension option. 

I get the same error and since i'm admin i do not see that can be an issue, or does the user need to be included as developer apart from being an admin? 

 

 

 

 

duypnguyen
Employee
Employee
I could somewhat reproduce the issue. It didn't help to be a user / developer / admin of the single product profiles. I got around it by being an admin of the entire product (such as Campaign Standard or Analytics). I'm verifying with the auth back-end team as this is quite unexpected.
Anil_Umachigi
Level 2
Level 2

Thank you! Please let us know when you hear back. A regular user in a defined profile should have this working. We cannot really grant product admin to make this work.

 

Editing to add 

Being a product admin (analytics) did not make this work either

Even for a generic action not tied to any adobe experience cloud products i got the same error.