Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

App run or deploy fails with: Could not locate bindings file

Marcin_Czeczko
Level 2
Level 2

Hi,

I recently updated AIO CLI together with all my plugins and now I'm unable to run or deploy any app as it fails fast with the error message: "Could not locate the bindings file"

For instance, running aio app:run I'm getting error like below

aio app:run
  @adobe/aio-cli-plugin-auth:upgrade-config-hook:debug hook running.
    Error: Could not locate the bindings file. Tried:
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/build/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/build/Debug/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/build/Release/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/out/Debug/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/Debug/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/out/Release/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/Release/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/build/default/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/compiled/14.6.0/darwin/x64/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/addon-build/release/install-root/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/addon-build/debug/install-root/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/addon-build/default/install-root/deasync.node
     → /Users/marcin.czeczko/.local/share/@adobe/aio-cli/node_modules/deasync/lib/binding/node-v83-darwin-x64/deasync.node

Versions I'm using:

$> aio version
@adobe/aio-cli/3.7.0 darwin-x64 node-v14.6.0

$> aio plugins
@adobe/aio-cli-plugin-aem 1.0.4
@adobe/aio-cli-plugin-aep 1.0.5
├─ @anycli/plugin-version 0.1.34
└─ @oclif/plugin-help 2.2.3
@adobe/aio-cli-plugin-app 3.5.1
@adobe/aio-cli-plugin-asset-compute 1.3.8
@adobe/aio-cli-plugin-cloudmanager 0.12.0
@adobe/aio-cli-plugin-cna 0.2.1

$> sw_vers
ProductName:	Mac OS X
ProductVersion:	10.15.5
BuildVersion:	19F101

 

Could you please advice ? 

3 Replies
Marcin_Czeczko
Level 2
Level 2

Already sorted out. I was using Node 14.6.0. Swithing back to 12.x solved the issue

duypnguyen
Employee
Employee
Hi Marcin - good to know that you managed to run your app with node v12. Please check our docs for the latest supported versions. https://github.com/AdobeDocs/project-firefly/blob/master/getting_started/setup.md#required-tools