Highlighted

Using hard coded on-page variables with DTM

kjph2

15-10-2015

We are currently implementing DTM. We want to use it to implement new variables going forward. However, there are a number of variables like eVars and props that are currently being set on the page itself, hard coded before the image request is sent. Ideally we would like to add DTM to the site while still capturing these variable (making the full migration and implement them all through DTM would be a very big undertaking at this stage).

The issue is that DTM does not include any of the variables we set on the page in the image request sent to Adobe. Is it possible to hard code variables on the page and have DTM pick these up? Regardless of how I load it it will not include anything set on the page currently.

 

So on the page, we have something like this

 

<!-- SiteCatalyst code version: H.17. Copyright 1997-2008 Omniture, Inc. More info available at http://www.omniture.com --> //<script language="JavaScript" type="text/javascript" src="/scripts/s_code.js"></script> <script language="JavaScript" type="text/javascript"><!-- /* You may give each page an identifying name, server, and channel on the next lines. */ s.pageName="Login"; s.state = ""; s.zip = ""; //s.channel=""; s.server = "548812-OECWEB02"; s.prop1="Self-Care"; s.prop2="Login"; s.prop4="Utility"; s.events=""; s.eVar3="Home > Self-Care > Login"; /************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/ psOmn.events.fireCustomEvents(); var s_code=s.t();if(s_code)document.write(s_code) //--></script>

 

The issue here is, if we implement the s_code through DTM (and comment out the line calling the s_code as above) then this code will fire a second image request. DTM sends one first without any of the variables, then the code below sends a second on with the variables. I have not found a way to be able to set these variables and have DTM include it in it's own image request. Does anyone know how that can be done?

 

Thanks

Replies

Highlighted

jantzen_belliston-Adobe

Community Manager

07-06-2017

Hi,

I'm following up on some old threads and I noticed this is still opened.

I assume you have already solved this question, but you should be able to use the "page code already present" option in your library management settings. You can read more about the setting in the documentation here.

Cheers,
Jantzen