Highlighted

I wrote two event based rules to fire different variables on click of hyper links (<a> tags) , but some times only one image beacon is firing instead of two.

potnurus3964341

23-03-2016

Hi,

I have written few event based rules to track some links(<a> tags) on some pages[lets call specialty pages]  in my site. Now I have written another event based rule to fire on all pages when any link is clicked on any page. So now on those some links in specialty pages we have two event based rules. The issue is some times when we click any link on those specialty pages only one image beacon is firing from either of the rules.

 

I have tested using Adobe Dtm Switch, and noticed that two rules are firing and also getting console statements from two rules in browser console.

 

So in the process of fixing the issue, i moved the generic event rule(which fires on all pages) to s_code, still issue is existing. Here also console statements are printing in console which are written after s.tl() call also.

 

Could you please help me on  this?

 

Thanks in advance.

Replies

Highlighted

ParitMittal

23-03-2016

Hi ,

Can you please provide your DTM company login credentials and Test Url ( for speciality pages & normal pages)  in a private message so that we reproduce the issue at our end and further deep dive to find root cause of the issue.

Thanks & Regards

Parit Mittal

Highlighted

ParitMittal

27-03-2016

Hi , 

It would be very difficult for us to debug the issue without having the Account credential. However , Atleast share the snapshot of the Adobe DTM Switch showing the two rules are firing and also getting console statements from two rules in browser console.

Also, Please share the snapshot of rule configuration's in DTM so that we can look into the issue from our end.

Thanks & Regards

Parit Mittal