Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Why do my event-based DTM rules result in no custom link data going to Adobe Analytics?

Avatar

Avatar
Validate 1
Level 1
mikea36017390
Level 1

Likes

2 likes

Total Posts

12 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 1
mikea36017390
Level 1

Likes

2 likes

Total Posts

12 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile
mikea36017390
Level 1

12-09-2017

I have a new Web Property and I added the Adobe Analytics tool via manual configuration.  I'm fairly confident that the Adobe Analytics tool is correctly configured as I'm seeing data for Visitors and other basic stats in Adobe Analytics Reports.

I have created a couple of event-based rules in DTM.

The rules trigger in response to clicks on certain DOM elements.  I have confirmed that the rules are triggering when expected by adding Javascript tags that make entires in the console.log().

I have added this type of Adobe Analytics configuration to each rule:

dtm-aa-1.png

Using Chrome dev tools Network tab, at the time the rules are triggered, I am not seeing the browser load anything.  Furthermore, I'm not seeing any Custom Event data appear in Adobe Analytics Reports.

I've had a look at the logs in the global _satellite object created by DTM and I see only the expected messages about rules being triggered, but I don't see anything about Adobe Analytics.

Any ideas what might be wrong here or how I can further debug?  Am I right to expect the browser to load something from my reporting server hostname?  Any gotchas on configuration of the Adobe Analytics Tool to look out for?  Or maybe I'm overlooking some required value in the Rule configuration?

View Entire Topic

Avatar

Avatar
Springboard
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

331 likes

Total Posts

2,247 posts

Correct Reply

811 solutions
Top badges earned
Springboard
Validate 500
Validate 250
Validate 100
Validate 50
View profile

Avatar
Springboard
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

331 likes

Total Posts

2,247 posts

Correct Reply

811 solutions
Top badges earned
Springboard
Validate 500
Validate 250
Validate 100
Validate 50
View profile
jantzen_belliston-Adobe
Community Manager

10-10-2017

Ah yes, sorry I didn't think to mention that. That flag isn't selected by default but I do agree, having a message in the console indicating the flag is on would be helpful. I'll be sure to mention it to the team.