Script for mobile site

guys90272422

11-08-2017

I am new in this forum, so a basic question . We got this script to enter in our website and I get many statistics, but only for the basic /fr/ site.

HEADER : <script src="//<"http://assets.adobedtm.com/bbcf1926d872997a7934ffbbdf062faa3e07ecd5/satelliteLib-b3df986876bb307f2b1..." target="_blank">assets.adobedtm.com/bbcf1964368906667777799990.js"></script>

END : <script type="text/javascript">_satellite.pageBottom()</script>

But we have also EN site , same url , but  /en at the end.

Where can I can define this  ? Or I need a new specific script ?

Other question, can I integrate the same script in our mobile site (not responsive) , who use the same url , but m instead of www before it ?

Thanks for your help.

GUY

Accepted Solutions (1)

Accepted Solutions (1)

ursboller

MVP

11-08-2017

im thinking of 3 reasons:

1) no dtm loaded

is dtm loading on /en/ site? open web browser console on /en/ site and type

_satellite.buildDate

do you get a valuenor error/empty?

2) javascript error

if you relode the page and look at console, do you have any js-errors?

3) page load rule condition

do you have any conditions on the "page load rule" which affect that the tracking call doesn't fire on /en/ sites?

Answers (11)

Answers (11)

jantzen_belliston-Adobe

Community Manager

14-09-2017

I'm seeing Analytics beacons on each of these pages

http://www.statistiques.public.lu/stat/ReportFolders/ReportFolder.aspx?IF_Language=eng&Mai nTheme=3&FldrName=2

1 Request Displayed
#1 - SiteCatalyst Image 388 chars
Third Party Cookiesctie.d3.sc.omtrdc.net
Report Suite ID(s)ctiestatistiques
Version of CodeJS-1.7.0-D6L7
Query String Beginning1
Sent From JavaScript File?1
pf=1
Date/TimeSeptember 14, 2017 at 2:02 PM
Dynamic Copy of: D=
Visitor ID1A14C957E5471753-29BBBBDF87F923FC
charSetUTF-8
Current URLhttp://www.statistiques.public.lu/stat/ReportFolders/ReportFolder.aspx?IF_Language=eng&MainTheme=3&F...
currencyCodeEUR
Screen Resolution1920x1200
Color Depth24
JavaScript Version1.6
JavaScript EnabledN
Cookies SupportedY
Browser Width1920
Browser Height607
Query String End1

http://www.statistiques.public.lu/stat/ReportFolders/ReportFolder.aspx?IF_Language=eng&MainTheme=3&F...

1 Request Displayed
#1 - SiteCatalyst Image 388 chars
Third Party Cookiesctie.d3.sc.omtrdc.net
Report Suite ID(s)ctiestatistiques
Version of CodeJS-1.7.0-D6L7
Query String Beginning1
Sent From JavaScript File?1
pf=1
Date/TimeSeptember 14, 2017 at 2:04 PM
Dynamic Copy of: D=
Visitor ID1A14C957E5471753-29BBBBDF87F923FC
charSetUTF-8
Current URLhttp://www.statistiques.public.lu/stat/ReportFolders/ReportFolder.aspx?IF_Language=eng&MainTheme=3&F...
currencyCodeEUR
Screen Resolution1920x1200
Color Depth24
JavaScript Version1.6
JavaScript EnabledN
Cookies SupportedY
Browser Width1920
Browser Height607
Query String End1

http://www.statistiques.public.lu/stat/TableViewer/tableView.aspx?ReportId=12979&IF_Langua ge=eng&MainTheme=3&FldrName=2

#1 - SiteCatalyst Image 402 chars
Third Party Cookiesctie.d3.sc.omtrdc.net
Report Suite ID(s)ctiestatistiques
Version of CodeJS-1.7.0-D6L7
Query String Beginning1
Sent From JavaScript File?1
pf=1
Date/TimeSeptember 14, 2017 at 2:00 PM
Dynamic Copy of: D=
Visitor ID1A14C957E5471753-29BBBBDF87F923FC
charSetUTF-8
Current URLhttp://www.statistiques.public.lu/stat/TableViewer/tableView.aspx?ReportId=12979&IF_Language=eng&Mai...
currencyCodeEUR
Screen Resolution1920x1200
Color Depth24
JavaScript Version1.6
JavaScript EnabledN
Cookies SupportedY
Browser Width1920
Browser Height607
Query String End1

It doesn't look like there is an issue with the Analytics beacon being sent from the pages. If you are not seeing this data inside Analytics, you may need to check a few things:

  • Make sure you are in the correct report suite "ctiestatistiques" in this case
  • Make sure you don't have any processing rules or vista rules filtering out this data

If you've checked these things, you may need to open a ticket with client care to investigate further.

If i've misunderstood and you aren't seeing an Analytics beacon on certain pages, please let me know what pages those are.

Thanks,
Jantzen

guys90272422

14-09-2017

Thanks. Here you find the pages with the dynamic URL with report folders at the beginning, then THEME (1 to 5) and FOlDER NAME /1 to 5 or maximum to 7)

http://www.statistiques.public.lu/stat/ReportFolders/ReportFolder.aspx?IF_Language=eng&MainTheme=3&F...

And then we have under theses folders the last level with the tables, again dynamic URL with REPORT ID = number of 5 positions

http://www.statistiques.public.lu/stat/TableViewer/tableView.aspx?ReportId=12979&IF_Language=eng&Mai...

All theses dynamic pages are not appearing in the analytics results of the site ( but should have to 30 hits or more per day the day they are published). The default load page beacon (see you image) is on theses pages, but not in the analytics .

Thanks

jantzen_belliston-Adobe

Community Manager

13-09-2017

I'm not sure I understand where the "results pages" are. Can you give me instructions to get to those pages?

If your finding data in Analytics on those pages, your analytics is receiving a beacon from those pages. If the data is only the basic page data, it is likely just the default page load beacon. If you need more than just the default information, you'll want to setup rules in DTM that extract and send the required information.

guys90272422

13-09-2017

Yes, this is the good URL (and the script is inside), but on the result pages (pages hits,....)  under ANALYTICS we only find data on the basic URL, not the the diiferent tables with dynamic URL (as the example just mentionned).

What to do have the analytics data on all the 800  URL's?

Thanks

GS

jantzen_belliston-Adobe

Community Manager

08-09-2017

I am seeing an analytics beacons on the link you provided (http://www.statistiques.public.lu/stat/TableViewer/tableView.aspx?ReportId=12853&IF_Langua ge=eng&MainTheme=2&FldrName=1)

1 Request Displayed
#1 - SiteCatalyst Image 400 chars
Third Party Cookiesctie.d3.sc.omtrdc.net
Report Suite ID(s)ctiestatistiques
Version of CodeJS-1.7.0-D6L7
Query String Beginning1
Sent From JavaScript File?1
pf=1
Date/TimeSeptember 8, 2017 at 9:02 AM
Dynamic Copy of: D=
Visitor ID1A14C957E5471753-29BBBBDF87F923FC
charSetUTF-8
Current URLhttp://www.statistiques.public.lu/stat/TableViewer/tableView.aspx?ReportId=12853&IF_Language=eng&Mai...
currencyCodeEUR
Screen Resolution3840x2160
Color Depth24
JavaScript Version1.6
JavaScript EnabledN
Cookies SupportedY
Browser Width1920
Browser Height1522
Query String End1

Is this not what you are seeing on your end? If you aren't seeing this on your end, you may need to clear out your cache/cookies.

If I've misunderstood and the link provided was not the page you are experiencing issues with, please provide me with the link to the page in question.

Thanks,
Jantzen

guys90272422

06-09-2017

Thanks, I deleted the http part of the script, and we have now data on the subfolder /stat/, but only on first level with reportfolders dynamic URL, but the subpages (where the same new script is deployed) with the different tables have no analytics data ??

http://www.statistiques.public.lu/stat/TableViewer/tableView.aspx?ReportId=12853&IF_Language=eng&Mai...

What is missing there ?

jantzen_belliston-Adobe

Community Manager

25-08-2017

The URL you provided (http://www.statistiques.public.lu/stat/ReportFolders/ReportFolder.aspx?IF_Language=eng&Mai nTheme=2&FldrName=1) does appear to have DTM deployed correctly.

When I try and access the DTM object in the console (_satellite) I get an error indicating it is not defined. A quick glance at the source code revealed the header embed code had a problem.

The code being deployed is

<script src="//assets.adobedtm.com/bbcf1926d872997a7934ffbbdf062faa3e07ecd5/satelliteLib-b3df986876bb307f2b1b7e8a6f1ed60f5b719fbe.js<http://assets.adobedtm.com/bbcf1926d872997a7934ffbbdf062faa3e07ecd5/satelliteLib-b3df986876bb307f2b1...>"></script>

Where the code that should be deployed for production is:

<script src="//assets.adobedtm.com/bbcf1926d872997a7934ffbbdf062faa3e07ecd5/satelliteLib-b3df986876bb307f2b1b7e8a6f1ed60f5b719fbe.js"></script>

You can see there is a bit of extra content in the script link. Try updating your embed code to see if that fixes the issue.

jantzen_belliston-Adobe

Community Manager

14-08-2017

It may be a problem with your web property settings. Have a look at the video on this documentation page. Specifically, around the 3:40 mark. They show the settings for subdomains and multiple domains. The video itself is a few years old, but 90% of the content is still relevant.

The other replies are also great things to check. If all else fails, you can always have a supported user contact customer care.

guys90272422

11-08-2017

Hi

Thanks, concerning the EN extension at the end of website URL, as I have no statistics on EN site. What and where to launch statistics on EN site ?