No requests found in Debugger

cathyw49544988

06-09-2017

I have a page I already added adobe tracking code. DTM debugger tool can turn on debug and staging on this page. But when I open the adobe marketing clould debugger, it showed "no request found". Does anyone know maybe what's wrong with my setup?

Thanks

Accepted Solutions (1)

Accepted Solutions (1)

cathyw49544988

06-09-2017

Hi Jantzen,

I solved my issue. It is because the data layer is different from the other page. Once I change the way to get data, I am all set.

Thanks for you help!

Answers (4)

Answers (4)

jantzen_belliston-Adobe

Community Manager

06-09-2017

Hi,

A few questions that might help narrow down the problem:

  • Do you have any tools added to your DTM web property?
  • If you open the browser console and type "_satellite", does it say initialized: true?
  • Do you mind sharing the url of your site so we can investigate further?

Thanks,
Jantzen

jantzen_belliston-Adobe

Community Manager

11-09-2017

I'm glad you were able to find the root issue.

As for your follow up question, if something is working in staging but not production, it's because some change has not been approved and published. If you look through your approval tab in DTM, do you see data elements or rules that are related to this project that still need to be approved?

Secondly, you may need to check your publish queue. If there are items in the publish queue that are related to this project, they will need to be published in addition to approved before they will be reflected in the production library.

Hopefully this helps.

- Jantzen

cathyw49544988

06-09-2017

Hi Jantzen,

Sorry, I still need to ask you a question. I found the issue was it tried to get data element from invalid data layer value. Once I deactive those data element in property, in the debugger, if I turn on stagging, it is fine, but if I turn off stagging, I got error again. I feel very confused, does stage and prod report suite share the same data elements? how could one works and not the other one?

Thanks,

cathyw49544988

06-09-2017

Hi Jantzen,

I added adobe analytics tool

in the console,

_satellite

{initialized: true, uuid: 31, dataCache: {…}, $data: ƒ, keys: ƒ, …}

the url is: http://whatsnext.nuance.com

Thanks,

-Cathy