Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

DTM: All links tracking as external

Avatar

Avatar
Contributor
Level 2
LAE
Level 2

Likes

5 likes

Total Posts

22 posts

Correct Reply

2 solutions
Top badges earned
Contributor
Shape 1
Ignite 1
Validate 1
Boost 5
View profile

Avatar
Contributor
Level 2
LAE
Level 2

Likes

5 likes

Total Posts

22 posts

Correct Reply

2 solutions
Top badges earned
Contributor
Shape 1
Ignite 1
Validate 1
Boost 5
View profile
LAE
Level 2

15-10-2015

I am very new to DTM and am working on implementing Adobe Analytics in our staging environment. I am using just the base s_code, and am building things up a little at a time. I have some basic evars and props working fine, but I am currently having a problem where all internal links are being detected as external (everything is lnk_e), even though the subdomain is identical from link to link.

I have "Track Outbound Links" checked in the Link Tracking tab, but nothing in the "Always Track" box.  Do I need to enter anything there?  I can't find any documentation for what that actually does.

In Edit Property, I have only the single subdomain (call it stage.mysite.org) listed, and do not have "spans multiple domains" checked.

In addition, in the DTM-hosted s_code, I have:
s.trackExternalLinks=true

s.linkInternalFilters="javascript:,stage.mysite.org"

Do I have a conflict somewhere?  I don't really understand what I need to set in settings and what needs to be set in s_code -- and what overrides what or conflicts with what.

Does anyone have any suggestions?

Thanks!

View Entire Topic

Avatar

Avatar
Contributor
Level 2
LAE
Level 2

Likes

5 likes

Total Posts

22 posts

Correct Reply

2 solutions
Top badges earned
Contributor
Shape 1
Ignite 1
Validate 1
Boost 5
View profile

Avatar
Contributor
Level 2
LAE
Level 2

Likes

5 likes

Total Posts

22 posts

Correct Reply

2 solutions
Top badges earned
Contributor
Shape 1
Ignite 1
Validate 1
Boost 5
View profile
LAE
Level 2

23-08-2016

Hi Deep,
When you view one of your pages, have you looked at what is being set in s.linkInternalFilters? You can look at the value in the console and see if the link's domain is missing. See if it is the same as what's in your s_code, or if the DTM version is overwriting it.  (That's what was happening to me.)

Looking at what it is set fr s.linkInternalFilters might help figure out where the problem is.