[ADBMobile setDebugLogging:YES] - Not working

prathumca

18-04-2017

Hello,

Does '[ADBMobile setDebugLogging:YES]' work in RELEASE mode for an iOS App? I see the logs in console when I run this app in iPhone directly from XCode but not when the same installed from OTA portal (its release mode). So, I'm assuming that it works only in DEBUG mode. Please correct me if I'm wrong.

 

Thanks in advance.

Accepted Solutions (1)

Accepted Solutions (1)

jantzen_belliston-Adobe

Community Manager

25-04-2017

Hi Prathap,

Sorry, I misunderstood your last response. If you are unable to see the messages within the console, we may need you to open a ticket with Customer Care so they can look more closely at your implementation. I've confirmed with the Adobe Mobile engineering team that the SDK does not automatically disable logging in release mode.

You can open a ticket by email Client Care at clientcare@adobe.com.

 

Once you are able to find an answer to your question, it would be great to have you post it here. This will ensure others facing the same issue are able to find the solution quickly and efficiently.

 

Thanks,
Jantzen

Answers (4)

Answers (4)

prathumca

19-04-2017

Thnaks,

 

I'm pretty sure that I'm a pro user of Xcode since its ages (I think I'm using Xcode since 2008). Well my issue is ADBMobile debug log is not showing on my console, if the app is installed from the OTA. If I run it from Xcode I see it in the console. Hope I'm clear on my issue.

 

-Prathap.

jantzen_belliston-Adobe

Community Manager

19-04-2017

On a connected device, you can see the log when you aren't debugging an app. In the Xcode menus, you can click Window -> Devices -> Select the connected device in the left-hand column.

prathumca

19-04-2017

Thanks for the reply Jantzen. However in release mode I don't see the logs in console but I can see them on console if I run the app through Xcode (as of below).

 

ADBMobile Debug: Analytics - Request Queued 

 

(ndh=1&t=XXXXXXXX&c.&a.&Resolution=1242x2208&internalaction=Interaction&DayOfWeek=4&CarrierName=XXXXX&HourOfDay=13&DaysSinceLastUse=0&LaunchEvent=LaunchEvent&DaysSinceFirstUse=0&OSVersion=iOS%2010.1.1&RunMode=Application&AppID=XXXXX&Launches=4&DeviceName=iPhone9%2C2&CrashEvent=CrashEvent&.a&.c&mid=54014909883665517010806855848579949240&pev2=XXXXXX&ts=1492588317&pageName=XXXXXX&pe=lnk_o&ce=UTF-8&aamlh=3&aamb=XXXXXXX)

 

But I can't see this console log in the Xcode console. Do you think, only Analytics team member can see it in their debugging tools?

 

Thanks,

Prathap.