Why is Target Premium not rendering our site? is it due to iFrame buster?

divya_isaiah

15-10-2015

Following the latest update to Adobe Target: When attempting to view or configure tests on our site with iframe buster the following happens: 

When Target tries to render the test page with the "experience" on it, it tries to open an iframe. However, if the page has an iframe buster on it then the page cannot render and is redirected away from the test page.

Is there a way around this? what can we do to get these tests working on our site? for security issues we need the iFrame buster to be active.

Accepted Solutions (1)

Accepted Solutions (1)

shekhardhiman

Employee

15-10-2015

Hi Divya,

Apologies for the delay. 

This has been identified as a known issue: 

There are some known issues with the current release of Target.

  • Unable to support editing on iframes having iframe buster code

    Proxy cannot bypass contents on an iframe.

Please see the known issues doc for more.

Thanks!

Answers (2)

Answers (2)

Nikhil_Bisne

15-10-2015

I also see that you've already a support ticket (ticket number 150526-000129) for this query. I'll follow up with the support team to have an answer for you soon.

Nikhil_Bisne

15-10-2015

Hi Divya,

 

If I understood your query correctly when you try to simulate the experience live the correct experience does not render and the user is redirected to another page?

Can you let us know what you see if you try to preview this activity in Target Premium "View Experience URL"?

 

Thanks

Nikhil