We are getting 400 error while sending parameter with Aray value in Target v2.

Avatar

Avatar
Validate 1
Level 1
bhargav102
Level 1

Likes

3 likes

Total Posts

6 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 1
bhargav102
Level 1

Likes

3 likes

Total Posts

6 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
bhargav102
Level 1

24-03-2020

We are in process to migrate Target V1 to Target V2.

 

While working with activities which are using parameter which are having values stored in arrays. For example, Sub Categories. We are getting 400 bad request error in network. It works fine with TargetV1. We also tried to see if we can get the value as data element and pass it with launch rule to fire parameter. (Example. digital.page.<variableName>[0]. - this prints value  on console log but that comes blank in actual target request.)

 

Can some helps us to read and use values which are stored as Array in data elements.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Shape 25
MVP
Andrey_Osadchuk
MVP

Likes

538 likes

Total Posts

971 posts

Correct reply

263 solutions
Top badges earned
Shape 25
Bedrock
Coach
Boost 500
Affirm 250
View profile

Avatar
Shape 25
MVP
Andrey_Osadchuk
MVP

Likes

538 likes

Total Posts

971 posts

Correct reply

263 solutions
Top badges earned
Shape 25
Bedrock
Coach
Boost 500
Affirm 250
View profile
Andrey_Osadchuk
MVP

05-04-2020

Change the syntax to digital.page.variableName.0. (instead of using square brackets).

Answers (0)