Target Activity Showing Default Content on local AEM

Avatar

Avatar

justinl40680371

Avatar

justinl40680371

justinl40680371

15-11-2019

Hello all,

I am currently trying to set-up an Adobe Target demo on a local AEM 6.4 instance. I integrated AEM with Target using Adobe Launch and currently have it set-up with the following rules:

Screen Shot 2019-11-15 at 2.29.35 PM.png

This was done following this tutorial and I added a message box at the end notifying me when the actions have run for debugging purposes: https://helpx.adobe.com/experience-manager/using/aem_adobetarget_integration.html

Integrating Adobe Experience Manager with Adobe Target using Adobe Launch

In Adobe Target, I have set-up an A/B test that is pointing at [http://localhost:4502/content/we-retail/us/en.html] and changed both Experience A and B to say "Shop Later" and "Shop Tomorrow" respectively.

Screen Shot 2019-11-15 at 3.02.38 PM.png

After setting this all up and integrating my local instance with Launch, I navigated to the page and the message box appears successfully as shown below but the "Shop Now" button is still there when neither of my experiences have that. Is there a step that I am missing here? I understand how AEM connects with Launch but I think the issue must be where Launch isn't connected with Target. Both Launch and Target and used within the same enterprise account. Any help or suggestions would be greatly appreciated!

View Entire Topic

Avatar

Avatar

settytb1

Employee

Avatar

settytb1

Employee

settytb1
Employee

19-11-2019

How is the launch hosted is it akamai adapter you are using?  If so, do you see the assets.adobedtm.com network requests firing in your developer tools?  Also, in the web console in the dev tools, try _satellite.setDebug(true);  Once done, you refresh the page, and it should list off everything launch is doing in the console, each rule, initializing extensions etc.  I'm wondering if you are seeing any of that and if the launch urls are loading.  Here's a pretty good blog that walks through it a little bit: Using Debug Mode and _satellite.logger in Adobe Launch | Bounteous 

I hope that helps,

Seth