latest version of at.js not working

Avatar

Avatar
Validate 1
Level 2
mattf96384379
Level 2

Likes

9 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
mattf96384379
Level 2

Likes

9 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
mattf96384379
Level 2

18-10-2017

Hi,

I added Target 1.0.1 was via DTM install wizard, but with at.js added manually via the code section of Target (because DTM doesn't automatically implement at.js)

Since updating from 0.9.6 to 1.0.1 I can see warning messages but can't see any target tracking in the Adobe Cloud Console.
Plus there are some console message that suggest we need to make changes in the setting (see below)

What does this message mean? Does it mater?
mbox-contents-d0768a61657c891f27102502ae2940474a5e499b-staging.js:8 AT: Adobe Target content delivery is disabled. Ensure that you can save cookies to your current domain, there is no "mboxDisable" cookie and there is no "mboxDisable" parameter in query string.

If I use out the box mbox.js through DTM everything appears OK, but we require at.js due to the site being a Single Page App.

I have attached screen grabs of the error in the console, as well as the target cookies being deployed.

cookies_deployed.png

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Boost 5
Employee
arturc85303583
Employee

Likes

12 likes

Total Posts

13 posts

Correct reply

7 solutions
Top badges earned
Boost 5
Boost 3
Boost 10
Boost 1
Affirm 5
View profile

Avatar
Boost 5
Employee
arturc85303583
Employee

Likes

12 likes

Total Posts

13 posts

Correct reply

7 solutions
Top badges earned
Boost 5
Boost 3
Boost 10
Boost 1
Affirm 5
View profile
arturc85303583
Employee

07-11-2017

The are a couple of root causes for this error: "AT: Adobe Target content delivery is disabled. Ensure that you can save cookies to your current domain, there is no "mboxDisable" cookie and there is no "mboxDisable" parameter in query string"

- mboxDisable cookie or query string is present

- at.js can't save cookies on the current domain

at.js prior to version 1.2.0 couldn't save cookies to IP based addresses. This has been addressed in at.js 1.2.0. You can find more details here: at.js Version Details. Also you might check at.js FAQ, the FAQ tries to cover issues like these, here is the FAQ: at.js Frequently Asked Questions.

I would recommend upgrading to at.js 1.2.0 or later.

Answers (7)

Answers (7)

Avatar

Avatar
Validate 1
Level 2
mattf96384379
Level 2

Likes

9 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
mattf96384379
Level 2

Likes

9 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
mattf96384379
Level 2

08-11-2017

Perfect thank you! I have since upgraded and this appears to have fixed the issue!

Regards,

Matt

Avatar

Avatar
Boost 1
Level 1
piyush_mishra4
Level 1

Like

1 like

Total Posts

1 post

Correct reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
piyush_mishra4
Level 1

Like

1 like

Total Posts

1 post

Correct reply

0 solutions
Top badges earned
Boost 1
View profile
piyush_mishra4
Level 1

24-04-2019

I am also seeing the same error:
AT: Adobe Target content delivery is disabled. Ensure that you can save cookies to your current domain, there is no "mboxDisable" cookie and there is no "mboxDisable" parameter in query string.

I am using Adobe Target extension in Adobe Launch to integrate this.

Avatar

Avatar
Boost 1
Level 1
ladann
Level 1

Like

1 like

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
ladann
Level 1

Like

1 like

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Boost 1
View profile
ladann
Level 1

26-02-2018

I realize now that I needed to set the cookie domain — it works as expected now Thanks!

Avatar

Avatar
Boost 10
Level 2
kimonp31365843
Level 2

Likes

10 likes

Total Posts

34 posts

Correct reply

3 solutions
Top badges earned
Boost 10
Affirm 3
Validate 1
Ignite 3
Ignite 1
View profile

Avatar
Boost 10
Level 2
kimonp31365843
Level 2

Likes

10 likes

Total Posts

34 posts

Correct reply

3 solutions
Top badges earned
Boost 10
Affirm 3
Validate 1
Ignite 3
Ignite 1
View profile
kimonp31365843
Level 2

29-01-2020

I don't know if the original issue is fixed now, however I recently managed to fix this by providing the mbox property "at_property", with the value you get from Adobe Target for your property there.

 

This was required only in the case where we didn't use the default AT workspace for our activities.

Avatar

Avatar
Level 1
benoitl56052893
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
benoitl56052893
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
benoitl56052893
Level 1

31-07-2019

Hello,

Did you manage to fix your issue ?

Avatar

Avatar
Boost 10
Level 2
kimonp31365843
Level 2

Likes

10 likes

Total Posts

34 posts

Correct reply

3 solutions
Top badges earned
Boost 10
Affirm 3
Validate 1
Ignite 3
Ignite 1
View profile

Avatar
Boost 10
Level 2
kimonp31365843
Level 2

Likes

10 likes

Total Posts

34 posts

Correct reply

3 solutions
Top badges earned
Boost 10
Affirm 3
Validate 1
Ignite 3
Ignite 1
View profile
kimonp31365843
Level 2

01-04-2019

May I ask how you did this? I tried via AT Settings>Implementation but no luck. Maybe I am missing something?

Screen Shot 2019-04-01 at 17.02.19.png

Kind regards,

K.

Avatar

Avatar
Boost 1
Level 1
ladann
Level 1

Like

1 like

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
ladann
Level 1

Like

1 like

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Boost 1
View profile
ladann
Level 1

26-02-2018

Hi @arturc85303583

I'm also seeing the following warning:

AT: Adobe Target content delivery is disabled. Ensure that you can save cookies to your current domain, there is no "mboxDisable" cookie and there is no "mboxDisable" parameter in query string.

And can confirm I have the latest version of at.js loaded. Do you have any further troubleshooting steps to try? I'm trying to test a basic implementation of at.js here: Home Questionaire http://ladanazita.github.io/

Thanks!