Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Experience Fragment Not Working - Error: atComponentInserted is not defined

Avatar

Avatar
Validate 1
Level 2
patrickb8312284
Level 2

Likes

3 likes

Total Posts

9 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
patrickb8312284
Level 2

Likes

3 likes

Total Posts

9 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
View profile
patrickb8312284
Level 2

03-02-2021

I am trying to use experience fragments in a simple a/b test.

 

The XF's have been successfully been imported into Target, but will not show up in the test variation. 

 

When test using the Activity QA URL... I am getting an error and the XF isn't loading. 

I can see the page is trying to load the XF...

 

<div class="at-script-wrapper"><script class="at-loader" id="atloader-a85d8898-2" type="text/javascript">atComponentInserted({"scriptId":"atloader-a85d8898-2","path":"/content/experience-fragments/large-format/language-masters/en/site/TEST/eDM50.nocloudconfigs.html"});</script></div>

 

...but the atComponentInserted function is not found...

 

1 Uncaught ReferenceError: atComponentInserted is not defined at <anonymous>:1:1

 

The error seems to be originating from Launch, but I can't find any documentation on the atComponentInserted function, so I'm not sure where to start to troubleshoot. 

 

Any information on this would be helpful. 

 

 

 

 

 

Accepted Solutions (0)

Answers (1)

Answers (1)

Avatar

Avatar
Ignite 1
Level 4
josejr19
Level 4

Likes

60 likes

Total Posts

117 posts

Correct Reply

13 solutions
Top badges earned
Ignite 1
Validate 1
Give Back 5
Give Back 3
Give Back 10
View profile

Avatar
Ignite 1
Level 4
josejr19
Level 4

Likes

60 likes

Total Posts

117 posts

Correct Reply

13 solutions
Top badges earned
Ignite 1
Validate 1
Give Back 5
Give Back 3
Give Back 10
View profile
josejr19
Level 4

03-02-2021

@patrickb8312284 Is this response from Target or inside the experience Target is trying to deliver on the front-end? Can you share the payload that Target responds with? Please remove any private data. Right now I am thinking that you have inline JS that might be having a race issue one when this atComponentInsert function is needed.