Adobe Target API error - VersionConflict.Resource - Cannot delete activity with options in this version of API

Avatar

Avatar
Boost 1
Level 1
paulakfleck
Level 1

Like

1 like

Total Posts

1 post

Correct reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
paulakfleck
Level 1

Like

1 like

Total Posts

1 post

Correct reply

0 solutions
Top badges earned
Boost 1
View profile
paulakfleck
Level 1

03-11-2020

Hello!

I've been trying to do a cleanup in our Dell Target activities. Here's the request I'm doing:

                       var options = {
                            url: 'https://mc.adobe.io/{tenant}/target/activities/xt/' + activity.id,
                            method: 'DELETE',
                            headers: {
                                'Content-Type': 'application/vnd.adobe.target.v3+json',
                                'Authorization': 'Bearer ' + bearerToken + '',
                                'cache-control': 'no-cache',
                                'X-Api-Key': clientId
                            }
                        };
This is the response I'm getting:
ERROR: Check the log for more info: {"httpStatus":409,"requestId":"{hidden for security reasons}","requestTime":"2020-11-03T18:51:47.053Z","errors":[{"errorCode":"VersionConflict.Resource","message":"Cannot delete activity with options in this version of API"}]}
 
I'm not sending any options. This is happening on over 300 activities. Could you help me out figuring out how to do it?
I'm able to remove offers and audiences just fine. Only activities is not working.
 
Thank you in advance!

Accepted Solutions (0)

Answers (2)

Answers (2)

Avatar

Avatar
Affirm 10
Level 3
karandhawan
Level 3

Likes

35 likes

Total Posts

41 posts

Correct reply

10 solutions
Top badges earned
Affirm 10
Give Back
Boost 5
Boost 3
Boost 25
View profile

Avatar
Affirm 10
Level 3
karandhawan
Level 3

Likes

35 likes

Total Posts

41 posts

Correct reply

10 solutions
Top badges earned
Affirm 10
Give Back
Boost 5
Boost 3
Boost 25
View profile
karandhawan
Level 3

26-11-2020

@paulakfleck Can you please try to add the below header in the API and then check

 

Accept: application/vnd.adobe.target.v3+json

 

Regards,

Karan 

Avatar

Avatar
Contributor
Level 7
Eric_Vidana
Level 7

Likes

157 likes

Total Posts

151 posts

Correct reply

37 solutions
Top badges earned
Contributor
Shape 1
Give Back 5
Give Back 3
Give Back 25
View profile

Avatar
Contributor
Level 7
Eric_Vidana
Level 7

Likes

157 likes

Total Posts

151 posts

Correct reply

37 solutions
Top badges earned
Contributor
Shape 1
Give Back 5
Give Back 3
Give Back 25
View profile
Eric_Vidana
Level 7

05-11-2020

Does application/vnd.adobe.target.v2+json work?