Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Issue with A/B experience test

Avatar

Avatar
Level 1
emily_nixon
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
emily_nixon
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
emily_nixon
Level 1

16-05-2017

I set up a simple A/B test recently. It shows as live in the Target interface, but I am not being entered into an experience. Other users have successfully tested for me, but when I visit the site, I am not entering an experience. My views are not being counted as experience A (even though that is what I am seeing), and I have cleared my cookies many times. I experienced the same issue during the Target training class I took, with no resolution during that class.

I was able to see experiences yesterday, but am no longer able to (even after restarting my PC). The test is currently set up for All Visitors with a 50/50 split between Experience A and B.

Thanks!

Replies

Avatar

Avatar
Validate 1
Level 4
Løjmann
Level 4

Likes

35 likes

Total Posts

117 posts

Correct Reply

42 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 25
Boost 10
View profile

Avatar
Validate 1
Level 4
Løjmann
Level 4

Likes

35 likes

Total Posts

117 posts

Correct Reply

42 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 25
Boost 10
View profile
Løjmann
Level 4

16-05-2017

Did you setup that a user only could be in the experiment once? Try delete your cookies, and see if that helps 🙂

/Løjmann

Avatar

Avatar
Level 1
emily_nixon
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
emily_nixon
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
emily_nixon
Level 1

16-05-2017

As stated in my original post, I have cleared my cookies many times. 

There were no limitations to qualify for the A/B test, or limits on the number of times you could enter. It was set to All Users with a 50/50 split between A and B. 

Avatar

Avatar
Validate 10
Level 10
ParitMittal
Level 10

Likes

90 likes

Total Posts

817 posts

Correct Reply

349 solutions
Top badges earned
Validate 10
Validate 1
Boost 50
Boost 5
Boost 3
View profile

Avatar
Validate 10
Level 10
ParitMittal
Level 10

Likes

90 likes

Total Posts

817 posts

Correct Reply

349 solutions
Top badges earned
Validate 10
Validate 1
Boost 50
Boost 5
Boost 3
View profile
ParitMittal
Level 10

17-05-2017

HI Emily ,

What is the Goal Metric/ SuccessMetric you are using to measure the success for your activity ?.

Aslo, It would be great if you can share the activity URL  and account credentials in a private message so that we can Debug the issue at our end.

Regards

Parit Mittal

Avatar

Avatar
Level 1
emily_nixon
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
emily_nixon
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
emily_nixon
Level 1

17-05-2017

I want to clarify: There is NO issue with the A/B test itself. The test works as intended for everyone else. All issues are specific to my PC only. Even after clearing all cookies from my browser, I am still not entered into an experience (I see the page itself, but my page views are not counted as a view for Experience A). 

Avatar

Avatar
Validate 1
Level 4
Løjmann
Level 4

Likes

35 likes

Total Posts

117 posts

Correct Reply

42 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 25
Boost 10
View profile

Avatar
Validate 1
Level 4
Løjmann
Level 4

Likes

35 likes

Total Posts

117 posts

Correct Reply

42 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 25
Boost 10
View profile
Løjmann
Level 4

17-05-2017

Did you check, if your browser request the target.js and target content? (see the network tab in your browser)

/Løjmann

Avatar

Avatar
Give Back 25
Employee
ryanr701
Employee

Likes

197 likes

Total Posts

217 posts

Correct Reply

86 solutions
Top badges earned
Give Back 25
Give Back 10
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Give Back 25
Employee
ryanr701
Employee

Likes

197 likes

Total Posts

217 posts

Correct Reply

86 solutions
Top badges earned
Give Back 25
Give Back 10
Give Back 5
Give Back 3
Give Back
View profile
ryanr701
Employee

17-05-2017

Hi Emily,

First I'd try a different browser. Perhaps for some reason your browser is not firing the Target mbox request on the page.

You can verify this by adding the "&mboxDebug=1" parameter to your url. It needs to go in the query portion of the URL. So after the "?". You can add a question mark at the end of the URL if one doesn't exist. Something like this: http://www.sb.com/lounge/?mboxDebug=1 or like this: http://www.sb.com/lounge/?param=value&mboxDebug=1

If you are using at.js you'll need to open your browser's debugging console to see the messages. Cntl-Shift-I in FF/Chr, F12 in Edge/IE. Any lines that start with "AT: " are about Target. Please copy and paste or screen shot your result after reloading the page.

If you are on the older mbox.js implemenation it will try to open a popup window. Similary check for errors and paste your response back to the thread. That will perhaps inform us to why your browser is not getting into the test.

Avatar

Avatar
Level 1
emily_nixon
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
emily_nixon
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
emily_nixon
Level 1

18-05-2017

Ryan,

The issue is isolated to Google Chrome. I do not have the same problem when using IE. I've attached a screenshot of the debug console in Chrome. Let me know if this isn't what you were looking for. 

 

Avatar

Avatar
Give Back 25
Employee
ryanr701
Employee

Likes

197 likes

Total Posts

217 posts

Correct Reply

86 solutions
Top badges earned
Give Back 25
Give Back 10
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Give Back 25
Employee
ryanr701
Employee

Likes

197 likes

Total Posts

217 posts

Correct Reply

86 solutions
Top badges earned
Give Back 25
Give Back 10
Give Back 5
Give Back 3
Give Back
View profile
ryanr701
Employee

18-05-2017

Thanks Emily. I'd like to take a closer look. Would you send the URL to view the test? You can direct message it to me if you prefer.

Avatar

Avatar
Validate 10
Level 10
ParitMittal
Level 10

Likes

90 likes

Total Posts

817 posts

Correct Reply

349 solutions
Top badges earned
Validate 10
Validate 1
Boost 50
Boost 5
Boost 3
View profile

Avatar
Validate 10
Level 10
ParitMittal
Level 10

Likes

90 likes

Total Posts

817 posts

Correct Reply

349 solutions
Top badges earned
Validate 10
Validate 1
Boost 50
Boost 5
Boost 3
View profile
ParitMittal
Level 10

29-05-2017

Hi Emily,

Is the above issue resolved ?. if not , Please do let us know the URL to view the test so that we can debug the same at our end.

Regards

Parit Mittal