Experience test not following rule conditions

andrew_r-GrfLbX

27-10-2016

Hi there,

Got an issue with an experience test I'm hoping to find out where I'm going wrong!

I'm trying to get a Target personalisation set up and I feel like I'm skirting around the solution but not quite hitting it on the head so a help in the right direction would be amazing.

I want to display a banner to customers who have completed an enquiry form to remind them of their reference number and to call in and at all other times/when the cookie isn't present display the default content.

I have so far done the following:

  • On the enquiry form completion I cookie the reference number for 30 days
  • In DTM I have an mbox called "banner" wrapped around the existing banner we want to replace and a parameter called "profile.aipRef" with the reference
  • In Target I have set up the banner with {$profile.aipRef} where I want to display the reference.
  • For the audience I have when mbox "banner" - profile.aipRef is present


When I preview this it all works fine, the reference is displayed as expected all great however when I delete the cookie or when it's not there I still get experience just with no reference number displayed and I can't figure out why. The same thing also happens when I set the experience live and try it that way just incase it was with the preview system.

Any help in resolving this appreciated.

Replies

Highlighted

ParitMittal

02-11-2016

Hi Andrew,

Can you please share your Adobe Target account login details as well as URL of the website and Personalization activity details  in a private message so that we can debug the issue at our end.

Thanks & Regards

Parit Mittal