Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

XML Source Tab not working, please test this form on LiveCycle

Avatar

Level 3

Hello,

I've recently posted this form to solve a few issues.

Now I have a new problem.

While in LiveCycle ES, I select the  XML Source Tab....

LiveCycle thinks for a bit but nothing happens!....

Does anyone know how to fix this problem?

I do not want to go back to an old form and redo all the work.

Thank You

Arnold

1 Accepted Solution

Avatar

Correct answer by
Former Community Member

This one is wierd .....I found a way to fix it but I cannot explain why it is doing what it is doing.

Simply add an xfa.layout.relayout() command to the Print button. Add that command before the print command. I think the issue is happening because you are doing all of this from Master Pages .....I want to move all of that to the Body page and see if the same thing happens.

Paul

View solution in original post

29 Replies

Avatar

Former Community Member

Had a look at  your form and found issues in the template. There was a bug in the 8.x series of Designer where a set of instructions (intended for Designer) woudl get repeated in the template (it happened when copy and paste was used). It was an exponential problem such that each time you copy and paste on your form these instructions woudl multiple. In your case your template grew to the size of 82Mgs (in native XDP format). You woudl not notice the size change when you save as a PDF because of compression. In version 9 a fix was introduced where the template woudl be cleaned up when it was opened. That is why the one I sent you via email opens quicker. If you do not want to go to version 9 there is a style sheet I can apply to your template that will fix up the version that you have saved for Designer 8. Just let me know if you want it.

Paul

Avatar

Level 3

Hi Paul,

Yes I would love to have this issue resolved. It has been creating problems for so many forms. I assumed that it could be some virus. It's also causing problems when sent via email to other doctors.

Thank Please send me the solution.

Arnold

Avatar

Former Community Member

The resolution is to go to Designer 9 .....I have a style sheet that I can apply to the xdp version of the forms but it requires Java on th machine. If you want to send me the forms I can apply the style sheet and send them back. You might want to send them to LiveCycle8@gmail.com instead of posting them here.

Paul

Avatar

Level 3

Hi paul,

This would be great. I ran into a problem. I was able to change the wording but can't seem figure out how to bring back some of the trigger information when printing. On the form I sent to you the Trigger would list out.

Medicine  (trigger)                 .Use these medications (Avoidance)

On the form u sent to back only the Avoidance appears.

What can I do to show the trigger information & Avoidance information at print?

Thank you,

Arnold

Avatar

Level 3

Hi Paul,

I've been working with the form and found that the Trigger Information no longer appears,

What should be done to make sure the Trigger information also generates beside the Avoidance Box. I've been trying to add it with your settings.

All i get is no response from the checkboxes.

example missing trigger

Trigger                                Avoidance

Animal/Dander....etc           Avoid Animal Dander

The trigger no longer appears as my old form did.

I've tried this whole week but I can't seem to get it to work.

Could you add some commands to Triggers?

Here is where I had the form populate.

topmostSubform.Page1.Trig.RowTrig.Triggers.rawValue = "Animal dander/Dust/Mold/Cockroach

Thank you Arnold.

Avatar

Former Community Member

Can you post your latest form so that we are working from the same base?

Paul

Avatar

Level 3

Hi Paul,

Actually the form you worked from is fine.

I only updated some words.

Arnold

Avatar

Level 3

Hi Paul,

Here are the lines I was using on the checkboxes.

The script activated generated text and corresponded with the Avoidance.

How can these commands be activated along with the Avoidances.

if (this.rawValue == "A1"){

     topmostSubform.Page1.Trig.RowTrig.Triggers.rawValue = "Animal dander/Dust/Mold/Cockroach" + "\n" +  topmostSubform.Page1.Trig.RowTrig.Triggers.rawValue;

}

if (this.rawValue == "0"){

     topmostSubform.Page1.Trig.RowTrig.Triggers.rawValue = "";

I sent you the copy of what you recently sent.

Thanks Arnold

Avatar

Former Community Member

I no longer have the form (I delete them as soon as I am done with it).

Paul

Avatar

Level 3

Hi Paul

i sent another copy last night.

Let me know if u recieved it

Thanks,Arnold

Avatar

Former Community Member

No ...I did not ..where did you send it? Just post it on the forum.

Paul

Avatar

Level 3

Here's another copy, I'm at work so it's harder for me to actively post into the forum, but I will try.

Arnold

Avatar

Former Community Member

OkI found the form .....you changed the way I created it. I used a scripting object to recreate the Avoidance field each time a checkbox is changed. That is the only way I coudl keep the checkboxes in sync with that field. Is there something else that needs to be added other than a brief phrase when each checkbox is checked?

Paul

Avatar

Level 3

Yes on the form the Trigger's also corresponded to another text box. it generated the trigger information along with the avoidance.

Trigger                      Avoidance

Animal                      Animal Dander

right now it only shows

Trigger                      Avoidance

(Blank)                      Animal Dander

Arnold

Avatar

Level 3

Here's a copy I think will show you how it looks,

It will show after printing.

Thank You Paul,

Avatar

Former Community Member

OK Now I understand ....I didn't realize that it was only showing up when you print.

You did not attach your form to the message so I used an earlier version. I simply modified the script object to update the hidden field accordingly.

Again, you may want to change the phrases being used but I think you get the idea of rebuilding the update boxes each time a checkbox is changed.

Paul

Avatar

Level 3

When I made changes, I would go directly to the XML Source. It's the only way I understood to rewrite the wording.

Thanks for updating me the info.

Arnold

Avatar

Former Community Member

No ...use the scripting editor. If it is not open hit Ctrl-Shift-F5 ..It will be on top of the form area. It can be resized to fit your need. Now click on the scripting object in the hierarchy view and you will be able to see all of the code. Mush easier to edit in there.

Paul

Avatar

Level 3

Hi Paul,

Did you figure out how it will print up the trigger and avoidance information?

I'll be able to test it from work if it's ready.

Although, I'm not home on LiveCycle I can test the PDF.

If it matches the Trigger and Avoidance I can post the form for the hospital.

Thank You

Arnold

Avatar

Former Community Member

I posted it 1st thing this AM....it is in an earlier post.

Paul

The following has evaluated to null or missing: ==> liqladmin("SELECT id, value FROM metrics WHERE id = 'net_accepted_solutions' and user.id = '${acceptedAnswer.author.id}'").data.items [in template "analytics-container" at line 83, column 41] ---- Tip: It's the step after the last dot that caused this error, not those before it. ---- Tip: If the failing expression is known to be legally refer to something that's sometimes null or missing, either specify a default value like myOptionalVar!myDefault, or use <#if myOptionalVar??>when-present<#else>when-missing. (These only cover the last step of the expression; to cover the whole expression, use parenthesis: (myOptionalVar.foo)!myDefault, (myOptionalVar.foo)?? ---- ---- FTL stack trace ("~" means nesting-related): - Failed at: #assign answerAuthorNetSolutions = li... [in template "analytics-container" at line 83, column 5] ----