Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Workbench - querying LDAP from a different domain

Avatar

Avatar
Level 1
alexb125
Level 1

Likes

0 likes

Total Posts

2 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
alexb125
Level 1

Likes

0 likes

Total Posts

2 posts

Correct Reply

0 solutions
View profile
alexb125
Level 1

26-11-2020

Hi There,

 

My organisation has multiple domains and I need to query users on a domain that is different to the one that the workbench process is running off of.

Usually when querying LDAP from any other software you can specify LDAP://domainA.com/DC=domainA,DC=com, however from what I can see with the LDAP task in workbench you can only specify the base DN, not the domain itself, so say I have domainA.com and domainB.org and my workbench process is on domainA.com I can use DC=domainA,DC=com to query active directory users on domainA.com, but if I try DC=domainB,DC=org, it seems to be actually trying to query the following: LDAP://domainA.com/DC=domainB,DC=org.

Is there any way to specify the actual domain in the LDAP task?

 

Kind Regards, Alex.

Accepted Solutions (0)

Answers (1)

Answers (1)

Avatar

Avatar
Affirm 100
Employee
Kosta_Prokopiu1
Employee

Likes

165 likes

Total Posts

369 posts

Correct Reply

107 solutions
Top badges earned
Affirm 100
Validate 1
Establish
Give Back 5
Give Back 3
View profile

Avatar
Affirm 100
Employee
Kosta_Prokopiu1
Employee

Likes

165 likes

Total Posts

369 posts

Correct Reply

107 solutions
Top badges earned
Affirm 100
Validate 1
Establish
Give Back 5
Give Back 3
View profile
Kosta_Prokopiu1
Employee

26-11-2020

Here is how I understand the LDAP Query task:

There is a service which need to be configured to point t the LDAP server you want to query. This is done in the adminui:

Home > Services > Applications and Services > Service Management > Configure LDAPService

Kosta_Prokopiu1_0-1606395092434.png

Did you set your server and domains in there?