Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

White screen randomly appears "under" messageBoxes and dialogBoxes when a Livecycle Designer form is viewed on MAC

Avatar

Level 3

Hi all:

Oddball question here; form was created using LiveCycle 11.

When the form is viewed on a PC, there's no issues with message or dialog boxes.  They appear as expected; nothing funky is happening.

However, when viewed on a MAC and a message box or dialog box has been triggered, there are times where the form will, for lack of a better word, just "disappear" --- and is replaced by a white background.  In essence, the message or dialog box is now visible but the form itself has been replaced with just a white background. Everything returns when the "ok" or another button within the message/dialog is clicked but I can't figure out why it's happening in the first place. Friggin' maddening.

While my testing cannot be considered exhaustive, it appears that:

1) Operating system of the MAC doesn't seem to matter;

2) Whether it's Acrobat or Reader doesn't seem to matter;

3) VERSION of Acrobat or Reader doesn't seem to matter;

4) And if there's a pattern as to when and why it happens, I can't see it. As far as I can tell, there isn't one.

Anybody else experience this? Thoughts?

Thanks in advance,

0 Replies

Avatar

Level 6

Are you 100% positive the form is being opened in Adobe Reader or Acrobat and not some other default PDF application on Mac?

Avatar

Level 3

Hi guys,

Thanks, as always, for the reads/replies.  Think I may have "solved" it so I'll detail out and hopefully save someone else two days of maddening trial and error. Gut tells me I may still be wrong as to what EXACTLY is happening (i.e., is this an Mac bug or, more likely, a sequencing error on my part) but whatever the cause, here's what I discovered.

SHORT VERSION: Watch out for scripts involving color changes (or perhaps any scripts?) that run when a message/dialog box may also be triggered. A sequence of scripting that works on PCs may, for lack of a better word on Reader/Acrobat for Mac, "confuse" Reader/Acrobat for Mac and trigger a white-out of the form until a response is received from the message/dialog box.

DETAILED VERSION:

1) I have fields with captions that change color when entered or exited, to let the end-user know which field is active.

2) These same fields also have scripts to turn the field's VALUE color to white on exit if the data is not null or  "". (There's a "did I answer everything" button that turns empty fields' values yellow.)

3) BUT, some fields also have scripts running to test the data entered, either in the change event or exit event.

4) If user-entered data doesn't pass the script's conditions, a message or dialog box is triggered and then focus is eventually returned to the field.

What I think is happening is the combination of scripts running when exiting the field (the script for changing the field's caption color, the script for changing the value color and, if triggered, the message/dialog box script) trips up the Macs. Pardon the upcoming bad example, but not sure how else to describe all this.

If the Mac could talk, it's as if it's saying...

     1) "We've exited, so I'm supposed to turn the caption color back to normal.  Got it."

     2) "We've exited AND data has been entered, so I'm supposed to turn the value color white. Not a problem."

     3) "We've exited AND the data has not met my conditions so I'm triggering a message box. Sure thing."

     4) "Wait a minute...so have we really exited?  I mean, we were supposed to exit, but now there's a message box, so does that "count" as exiting?  Am I supposed to change the

           field's caption and value colors or not? Better punt and just show a white screen of nothingness."

... then, once the return from the the message/dialog box is received...

     5) "Well, not sure what I was supposed to do there, but, whatever.  Bring everything back and lets wait for the next command."

WHAT I THEN DISCOVERED WAS:

By commenting out the scripts to change the field's caption and value colors, and not changing anything else, the remaining scripts would run fine on both PC and Mac. No more white screen when the message/dialog box was created. So it could be something to do with the color change scripts or, more likely I think, something to do with WHERE I had placed the color change scripts in the sequence of scripts that run on exit.

I don't have a Mac with me now to test a possible solution to both reinstate the color changes on enter/exit AND have the message/dialog box appear without the white screen, but I'm guessing that by moving the scripts re field caption and value color changes INTO the scripts that run when a return value is received from the message/dialog box (and not as a stand-alone script within the sequence of scripts that all run on exit) should resolve it and get the full effect working again.   Will at least post a quick follow-up when I know.  If I have the time, a full follow up with example PDF showing both the issue and its resolution.

Still, incredibly odd that a sequence of scripts that run on PCs without issue would, on Macs, cause a white-out of the screen when the message/dialog box appears.  And to make matters worse, it doesn't happen consistently so it's really frustrating.

B