Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

What is going on: exception 'RTCError' with message 'connection-failed'?

Rex98757
Level 2
Level 2

Hello,

I have focused second time this week that there are problems with connection to LCCS servers. Last problem was at ca. 10:30 am CEST. This takes at least 15-20 minutes - I don't know how long this problem appears really, because I know about it only if my clients report me problems. From the same reason, I don't know if this isn't happend more often, because I'm not checking it every 5 minutes.

When this problem occurs I have exception:

exception 'RTCError' with message 'connection-failed' in /var/www/lib/LCCS/lccs.php:774

Stack trace:

#0 /var/www/lib/LCCS/lccs.php(666): RTC::http_get('http://collabor...', Array)

#1 /var/www/lib/LCCS/lccs.php(255): RTCAccount->do_initialize()

#2 (...) RTCAccount->__construct('http://collabor...')

(...)

Any idea what is worng? Some work on Adobe servers?

1 Accepted Solution
Rex98757
Correct answer by
Level 2
Level 2

I hope this will be helpful for persons with similar problems.

We have searched together with Jamie Ho where is the problem, but it's impossible to detect the reason. Traceroute test didn't show nothing interesting. Logs analyse also.

The solution that we found is using other server (locatet in other location/data center) as gate to comunicate with LCCS services. This has helped and this gate connects without problems now.

But what is strange, we have tested more servers and it's a lottery. One of our test servers couldn't make any connection with LCCS services. I have found here http://forums.adobe.com/thread/772442 that this isn't new situation.

This is how it looks now. We are monitoring it all time, but for now this gate server solution looks good and it's the only that solve problems.

View solution in original post

5 Replies
Rex98757
Level 2
Level 2

Again (2012.09.14 01:20pm CEST):

exception 'RTCError' with message 'connection-failed' in /var/www/lib/LCCS/lccs.php:774

Stack trace:

#0 /var/www/lib/LCCS/lccs.php(666): RTC::http_get('https://na2.col...', Array)

#1 /var/www/lib/LCCS/lccs.php(267): RTCAccount->do_initialize()

#2 (...): RTCAccount->login('***', '***')

(...)

I'm using LCCS almost year and I haven't got such problems before.

jamieqho
Level 3
Level 3

Hi,

What is your account name?  I can check the server logs for problems affecting your account.  We have not received complaints from other users this week.

-Jamie

Rex98757
Level 2
Level 2

Thank you Jamie Ho for answer. I have write to you on private.

Rex98757
Level 2
Level 2

I have a question to Adobe Team, with who can I contact, because I have sended more details and logs to Mr. Jamie Ho, but I haven't got any answer for last 3 days?

Rex98757
Correct answer by
Level 2
Level 2

I hope this will be helpful for persons with similar problems.

We have searched together with Jamie Ho where is the problem, but it's impossible to detect the reason. Traceroute test didn't show nothing interesting. Logs analyse also.

The solution that we found is using other server (locatet in other location/data center) as gate to comunicate with LCCS services. This has helped and this gate connects without problems now.

But what is strange, we have tested more servers and it's a lottery. One of our test servers couldn't make any connection with LCCS services. I have found here http://forums.adobe.com/thread/772442 that this isn't new situation.

This is how it looks now. We are monitoring it all time, but for now this gate server solution looks good and it's the only that solve problems.

View solution in original post