Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

WebService; Error attempting to read from file http://dotnetserver/ws.asmx

Avatar

Level 10

I am trying to connect to a web service written on .Net

2.0 framework

The web service has two web methods.

From within a form (with Reader Extended), am trying to access both the web methods.

One method is working while the other is not. What might be the reason?

Thanks,

Nith

8 Replies

Avatar

Level 10

I feel this is a bug in Designer SP1 (9.0.0.1)

The problem is, whenever I update any field on the form, and save it to repository, the Data Connection has been modified from the cash settings, This prevents the web services from being invoked.

I just uninstalled SP1 (only designer SP1 while the workbench SP1 remains same), and now its working fine.

Nith

Avatar

Former Community Member

Then you should report the issue to support and get the issue fixed.

Paul

Avatar

Level 10

Hi Paul,

We are facing certain issues in contacting Adobe Support. Though we have purchased Platinum support, we are not able to register calls or contact Adobe to report any issues.

There is mediator who processed our payment and they delayed paying to Adobe on time. We tried to contact Adobe for direct payment which was also not accepted (We must go through a registered Adobe Vendor in Middle East;).

However, we are helpless for the past two years; Running financial applications with few critical issues which are not yet reported to Adobe.

Nith

Avatar

Former Community Member

The Adobe vendor must have an Adobe sales rep or technical SE...you may be able to do it through them.

Paul

Avatar

Level 10

Thanks Paul, I will try to contact them.

Nith

Avatar

Level 2

$Nith$

I have the same problem. 

How did you recover?  I uninstalled Designer SP1, made a minor change to the form and re-deployed, but still cannot connect to my web service.  Do I just need to re-boot the server (kind of a big deal on our production instance, but still possible)?  Do you have any suggestions?

Thanks!

Toby

Avatar

Level 10

1. Make sure that you desinger version is 9.0.0.0 , which means if you have installed sp1 for designer ES2, you might need to uninstall it.

2. Goto reports pallette and look for "cached data description has been modified blah blah... refresh your data connection". If this warning found, you will have to refresh the data connection:

  To do this: goto data connection panel and right click on each connection-> connection properties -> next -> next -> finish.

Now you should see the warning disappeared.

3. Try to connect to the web services now. I Hope it will work from there.

PS: NO NEED TO RE-BOOT YOUR PRODUCTION SERVER.

Nith

Avatar

Level 2

Nith

Thank you!  This worked.

Toby