Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Users not leaving rooms

Avatar

Avatar
Validate 1
Level 1
asciibn
Level 1

Likes

0 likes

Total Posts

90 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
asciibn
Level 1

Likes

0 likes

Total Posts

90 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
asciibn
Level 1

06-05-2011

Hi,

I have a room where users are listed even though I know its empty.

the probem is everything I check it I add anoher instance and I can't delete streams or users from the room console.

It seems that over time a few rooms get like this. any way reset?

thanks.

....russ

Accepted Solutions (0)

Answers (13)

Answers (13)

Avatar

Avatar
Boost 50
Employee
Raff_
Employee

Likes

80 likes

Total Posts

758 posts

Correct Reply

75 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile

Avatar
Boost 50
Employee
Raff_
Employee

Likes

80 likes

Total Posts

758 posts

Correct Reply

75 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile
Raff_
Employee

12-05-2011

That's good to know too! Tomorrow we should be able to start testing in our dev environment and hopefully we'll reproduce the problem.

Avatar

Avatar
Validate 1
Level 1
tracedwax
Level 1

Likes

0 likes

Total Posts

58 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
tracedwax
Level 1

Likes

0 likes

Total Posts

58 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
tracedwax
Level 1

12-05-2011

Interestingly, leaving all audio streams on constantly and just subscribing to the relevant ones at the right times hasn't broken the rooms.  As described, having the relevant ones start publishing consistently broke the rooms.  Still need a fix of course as this could recur at other times and having many times the audio streams we need can cause other problems.  Looking forward to what you come up with.

-Trace

Avatar

Avatar
Validate 1
Level 1
tracedwax
Level 1

Likes

0 likes

Total Posts

58 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
tracedwax
Level 1

Likes

0 likes

Total Posts

58 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
tracedwax
Level 1

12-05-2011

Sounds good. Thanks again.

-Trace

Avatar

Avatar
Boost 50
Employee
Raff_
Employee

Likes

80 likes

Total Posts

758 posts

Correct Reply

75 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile

Avatar
Boost 50
Employee
Raff_
Employee

Likes

80 likes

Total Posts

758 posts

Correct Reply

75 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile
Raff_
Employee

12-05-2011

We'll try to reproduce this in our lab so that we can debug it. If we still can't we may ask you for help.

Sorry for the slow responses, but this week we are all scattered around. We should be back to a "normal" schedule starting tomorrow.

Avatar

Avatar
Validate 1
Level 1
tracedwax
Level 1

Likes

0 likes

Total Posts

58 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
tracedwax
Level 1

Likes

0 likes

Total Posts

58 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
tracedwax
Level 1

11-05-2011

We were able to reproduce the issue in a few minutes several times today by doing the following:

*User 1 enters room and starts publishing webcam.  No one subscribed to the webcam duing this test.

*Users 2 and 3 enter room.

*User 1 starts and stops pubishing their audio repeatedly, once or twice per second or so.

An example room configuration we're using can be found in room 'yrtv8', if needed.

Our code that publishes and unpublishes audio is similar to the following:

private function checkAudio():void

{

  if (view.audioPublisher.isPublishing){

    view.audioPublisher.stop();

  } else {

    view.audioPublisher.publish();

  }

}

Please let me know if you are able to reproduce the problem, and if you'd still like access to a development server where the steps above can be reliably reproduced.

Thanks again,

-Trace

Avatar

Avatar
Validate 1
Level 1
tracedwax
Level 1

Likes

0 likes

Total Posts

58 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
tracedwax
Level 1

Likes

0 likes

Total Posts

58 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
tracedwax
Level 1

11-05-2011

Much appreciated.  Perhaps the easiest way to reproduce would be to give you access to one of our development servers and the steps that we've used to reproduce the problem in the past.  Will that work well?

Please email me at tracedwax (at) gmail.com and we'll email you the URL and credentials.

Thanks,

-Trace

Avatar

Avatar
Boost 50
Employee
Raff_
Employee

Likes

80 likes

Total Posts

758 posts

Correct Reply

75 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile

Avatar
Boost 50
Employee
Raff_
Employee

Likes

80 likes

Total Posts

758 posts

Correct Reply

75 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile
Raff_
Employee

10-05-2011

So, this is a problem we have been chasing for a while but we are not able to reproduce. We suspect it's a bug in FMS related to A/V streams (and you both seems to experience the problem when multiple streams "go bad"). It would be great if you had a simple test program that simulates what you do in your application (switching between multiple video streams ?). If we can get a reproducible case I am sure we can get this solved.

Avatar

Avatar
Validate 1
Level 1
tracedwax
Level 1

Likes

0 likes

Total Posts

58 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
tracedwax
Level 1

Likes

0 likes

Total Posts

58 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
tracedwax
Level 1

07-05-2011

This happened again just now - with a different account and roomname.  (Can email you those details - just let me know where to send them).  What happened was this:

*A current video and audio publisher crashed after subscribing to another video and audio stream

*This worked fine many times, but the final time we lost the ability to make any changes to the room - to remove users, add or retract items, etc, from anywhere.  Can still read all data in the room.

We very much appreciate your resetting dcourse2.  It's been easy for us to create new rooms as needed, but that won't keep us from losing all our users each time a session with many users already exists in a room that suddenly becomes corrupted in this way.  We seem to be able to reproduce this every 30 minutes or so when we have users online. 

Is there anything you or we can do to prevent rooms from entering this broken state? 

Also, to the extent that the broken state is unavoidable for now, is there something that can be done on the fly to restore the room to a working state?

Thanks very much,

-Trace

Avatar

Avatar
Validate 1
Level 1
asciibn
Level 1

Likes

0 likes

Total Posts

90 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
asciibn
Level 1

Likes

0 likes

Total Posts

90 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
asciibn
Level 1

06-05-2011

Thanks,

It's happened across rooms. I think its when cams come on and off and if people crash.

I'll check it out.

...russ

Avatar

Avatar
Boost 5
Level 2
jamieqho
Level 2

Likes

9 likes

Total Posts

52 posts

Correct Reply

3 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile

Avatar
Boost 5
Level 2
jamieqho
Level 2

Likes

9 likes

Total Posts

52 posts

Correct Reply

3 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile
jamieqho
Level 2

06-05-2011

Hi Russ,

Sorry to hear you are having problems!  I checked about an hour ago and only saw dcourse2 running with 32 users.  I did not see any other rooms running from your account.  We have reset dcourse2 so your user list problem should be resolved.

-Jamie

Avatar

Avatar
Validate 1
Level 1
asciibn
Level 1

Likes

0 likes

Total Posts

90 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
asciibn
Level 1

Likes

0 likes

Total Posts

90 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
asciibn
Level 1

06-05-2011

Hi,

I think one of the things that could be happening is that users may crash while they are in the room.

Since switching video is an expensive process. I found that one your CPU hits 100% you freeze up and the player crashes.

thanks.

...russ

Avatar

Avatar
Validate 1
Level 1
asciibn
Level 1

Likes

0 likes

Total Posts

90 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
asciibn
Level 1

Likes

0 likes

Total Posts

90 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
asciibn
Level 1

06-05-2011

https://collaboration.adobelivecycle.com/goodcrush/dcourse2

It seems like a few rooms on this account are acting up.

I also tried the room cleaner but it didnt seem to work.

thanks.

...russ

Avatar

Avatar
Boost 50
Employee
Raff_
Employee

Likes

80 likes

Total Posts

758 posts

Correct Reply

75 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile

Avatar
Boost 50
Employee
Raff_
Employee

Likes

80 likes

Total Posts

758 posts

Correct Reply

75 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile
Raff_
Employee

06-05-2011

send us the room URLs and we'll have a look