Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

URGENT Chat&: Max Monthly Usage Reached in 24hrs on Commercial Account?

Avatar

Level 2

So we're developing this enterprise LCCS app and the max concurrent connections error kept coming up, so I upgraded to the commercial account so we could more than have 5 sessions going. Which was fine, until a few days later, when I got this error:

LCCS_monthly_usage_limit_error_2011-08-30_01.jpg

So I thought, okay fine, I'll check the usage for the app, maybe I didn't assign enough money to the monthly limit. This is what the developer portal showed me:

LCCS_monthly_usage_limit_error_2011-08-30_02.jpg

I tried re-installing the Navigator SDK Viewer, thinking maybe I need a new one for a commercial account? The download is the same, and re-installing it didn't do anything. So I'm thinking it's a problem with my account?

How can I be over the monthly limit with 13 concurrent users, and under the moneys alocated to the app?

THIS IS A MAJOR PROBLEM. We are launching an alpha demo of this product within 48 hours, and all development has stopped, as hosts and users get booted out of rooms whenever this message pops up, and our software does not work reliably anymore.

Please help ASAP. You can reach me by phone at 705-352-1020 or by email at jbdesign@joeflash.ca

Thank you,

Joseph Balderson

Flex & Flash Platform Developer

http://joeflash.ca

0 Replies

Avatar

Level 2

Hello,

I work with Joe and an in attempt to put a Bandaid on this problem we had him move the application to my personal LCCS commerical developer acount.

This account has had no usage and I increased the monthly limit to $2000.00 this still did not fix the issue.

See Joseph's response below.  I have also included a screen shot of our subscription info.

Thanks for the help,

Daniel

Screen Shot 2011-08-31 at 9.42.15 AM.png

I created new rooms for your account, changed the code to use the new account info, and...

It didn't work. Same error. Thanks, it was worth a try...

If you take a look at the two attached screenshots you'll see what I mean: the first image shows the error I get, which I wasn't getting before. The second screenshot of my test app shows what happens when the error shows up: the window on the left is the customer, on the right is the csr with admin test lists. The bottom list under "CSR Room" should show two people logged in: "susyq" and "rob" -- although the "rob" customer app shows that the session with the "susyq" is connected, the admin list shows that no one is in the room. This used to work earlier yesterday. Now the app is behaving unpredictably, which means I have no idea if what's not working is the server error or my code.

LCCS_monthly_usage_limit_error_2011-08-31_01.jpgLCCS_monthly_usage_limit_error_2011-08-31_02.jpg

Avatar

Level 4

Hi Joseph,

We will look at this ASAP.

Thanks,

Nikola

Avatar

Level 3

Hi Joseph,

Sorry to hear you are having issues.  I checked the logs and was not able to find any quota errors related to your account.  I also did not see any errors when I entered your room named "lobby" as a guest.  Are you also having issues with your application or only the developer console?

-Jamie

Avatar

Level 3

Hi Daniel,

I checked the server logs and can confirm that guest "rob" and user "Daniel Lebor" were logged into the csrsusyq room sometime between 8:30 and 9:30 eastern.  If you still have issues, it might help to run your app in the debugger and send us the client logs.

-Jamie

Avatar

Level 10

  Hi guys.

Ditto what Jamie's saying - client logs would be the key here to seeing what's going on. It's my suspicion that the monthly quota exceeded message is a (very unhelpful) bug in the Room Console - it's likely responding to some other condition which it's mistaking for this.

   nigel

Avatar

Level 10

Just confirmed - the Room Console has at least one condition where it might mistake another SessionError for this quota problem.

I do find it suspicious that you were just talking about noHostTimeout right before this issue started. Have you been messing with that setting?

  nigel

Avatar

Level 2

Hi all,

Thanks for getting back to us, Joseph will be unavailble for the next couple of hours and he is the one who would be able to answer any of the technical questions, as to what and any changes that were made to the code.

in the interm, I am happy to provide my personal log in via private message, to my developer account if you want to poke around. Otherwise we can just wait until Joseph is available.

Thanks for all the help.

Daniel

Avatar

Level 2

Thanks for getting back to us Nigel. I just tried the app again, without launching the Room Console. If it were solely a Room Console bug, it might not come up. I ran the app even back several versions, and some weird things are still happening. I also tried nuking the SDK Navigator/Room Console air app and reinstalling it, but it still happens.

The way the app did work is this:

• The CSR logs into three rooms simultaneously: prelobby, lobby and their own private room. I was getting some MessageItem sync problems doing this from one authentication session early on (not related to this issue), so I have the CSR log into three rooms, three sessions, each with thier own AdobeHSAuthenticator object.

• The prelobby room has a CollectionNode that is set by the CSR app which the Customer app "binds" to, allowing them to see whether a CSR is online or not. Later, we'll move the setting of this shared object to a server-side script, so the CSR won't have to log into the pre-lobby.

• The lobby room is to keep track of which customers have requested to start a session with a CSR. When the user wants to connect with a CSR, they click on the green image, and the customer app logs them out of the prelobby and into the lobbyb. The middle list in the CSR prototype app shows which users are logged into the lobby, in reverse order of arrival.

• The CSR then selects a customer from the lobby list and clicks the connect button below. The CSR app then sends a private MessageItem through a CollectionNode in the lobby to the customer app, containing the room name of the CSR's private room. The Customer app receives the private message, then logs themselves out of the lobby and into the CSR room.

• The CSR may then terminates the room session by clicking 'End Session", which sets the room state to ROOM_STATE_ENDED, thereby ejecting the customer from the room. The customer app senses the disconnect, and logs themselves back into the prelobby.

This has worked, I have seen it work, flawlessly. But as soon as the Room Console reports that weird error, the connections go squirrely.

I thought it might be that the room state is getting "stuck", thereby ejecting the user as soon as they try to log into the room, but even after I roll back to a previous version without the "end session" feature, customers are still getting booted out of the csr room. And sometimes the csr room list will not show that the csr is logged into their own room, or the list will not show that the csr and the customer is logged into the csr room, when they clearly are.

Even when the console is not launched, some weird things are happening. I tried it again just now, with the Navigator/Room Console air app not running, and after running both apps a few times, now even customer apps cannot log into the lccs service as guest, it just hangs... which has never happened before now.

It would be helpful to know whether it is the Room Console air app or the account setting, which would then enable you to issue a fix for the console or something. Or even, if I'm doing something funky and undocumented with my app that I don't know about which may be inadvertently causing this. Bottom line that error should not be coming up, so even if it is my app for some weird reason, the console should not be telling me that the account limit has been reached and start booting users and causing funky connection issues.

Would it help if I send you the code that we're working with? I can't post the link on this open forum, do you have an email I could send it to?

Thanks,

Joseph Balderson

Flex & Flash Platform Developer

http://joeflash.ca

Avatar

Level 2

Hi Nigel,

No it can't be that. I noticed that the Flash Builder autocomplete showed me that such a property was available, I tried setting it, and I got a complier error that the value is read-only. So that was the end of that. The account limit error problem had come up before I played with that value yesterday. As I said, the problem came up, then I went for diner for a few hours, came back and the error didn't come up again until a few hours later. Now it comes up all the time even if I take a rest in between.

Thanks,

Joseph Balderson

Flex & Flash Platform Developer

http://joeflash.ca

Avatar

Level 10

Hi Joe,

Client logs that show what's going on when customers are getting kicked out would be really, really useful.

  nigel

Avatar

Level 2

Where can I find the client connection logs?

Joseph

UPDATE: thought you might be referring to a text file log somewhere... never mind.

Message was edited by: joeflashTO2

Avatar

Level 2

I had the Room Console open at the Logs tab of one of the csr rooms. Then I started the customer app, which logged in, no problem. Then I logged in with the CSR app, and the console immediately showed me the usage limit error:

LCCS_monthly_usage_limit_error_2011-08-31_03.jpg

So I logged clicked ok in the error dialog, then back into the logs tab for the CSR room. Then re-launched the CSR app, whcih worked this time. The log showed this:

LCCS_monthly_usage_limit_error_2011-08-31_04.jpg

Then I played with the app a little more, and without going too far, I was was able to break it quite spectacularly:

LCCS_monthly_usage_limit_error_2011-08-31_05.jpg

Which of course should not be happening.

At this point I am open to suggestions.

Joseph Balderson

Flex & Flash Platform Developer

http://joeflash.ca

Avatar

Level 2

And now I'm not getting the max limit error, but the guest and csr login hung for minutes. Then the customer and CSR apps successfully logged in, but the csr got booted out of the csr room... things always act a little funky after that massage pops up.

LCCS_monthly_usage_limit_error_2011-08-31_06.jpg

LCCS_monthly_usage_limit_error_2011-08-31_07.jpg

It may be a room console bug. If I continue using the app while the console is displaying the "usage limit" error dialog, but before I click "ok", the app works absolutely fine for a few minutes before the issue reasserts itself again.

Joseph Balderson

Flex & Flash Platform Developer

http://joeflash.ca

Avatar

Level 2

Lemme know who you want me to email the code to so I can help us to solve this issue. You can email me whom to send it to at jbdesign@joeflash.ca.

Thanks,

Joseph Balderson

Flex & Flash Platform Developer

http://joeflash.ca

Avatar

Level 10

Hi Joe,

Sorry, I don't think anyone offered to look through your code.

  Again, could you please send us client logs - these are the trace outs that Flash Builder shows while you're debugging.

  nigel

Avatar

Level 10

A couple of followup questions/thoughts :

Are you reusing the same room that you've put into STATE_ENDED? If you are, an easier way to do this would be to kick out the customer user, rather than shutting down the whole room. userManager.removeUser() would accomplish this - the user won't be allowed back in unless you re-authenticate them.

In theory, this shouldn't be causing your issue, but it's definitely easier to manage. Once I see this error (the user getting kicked out of the room) from your client logs, I'll have a better idea what's going on. Are your client applications running in the debug player? Are they throwing runtime exceptions? If not, I'd add some code in your ConnectSession's error event handler to print out any error messages.

  hope that helps

   nigel

Avatar

Level 2

No worries about the code, just offering in case it helps you debug your Room Console.

I'll add a few things to make the debug trace a little more descriptive in indicating events received, and I'll post it tomorrow when I'm in front of my machine again.

Thanks again very much for all your help.

Joseph Balderson

Flex & Flash Platform Developer

http://joeflash.ca

Avatar

Level 2

It could be that in using STATE_ENDED, the room lands up getting "stuck" in status ended mode when the CSR is booted from the room by the Room Console bug (assuming that's what it is), which could prevent the user from logging back in. But, as you've indicated, the CSR should not be getting booted from the room on account of a "monthly limit" reached in the first place. I'll look into changing that to userManager.removeUser() as per your suggestion tomorrow when I'm back at work and see if it makes a difference.

Thanks again,

Joseph Balderson

Flex & Flash Platform Developer

http://joeflash.ca

Avatar

Level 2

Okay, I think I finally caught it in the act, so to speak. With logs.

First I added some event hooks and visual indicators for the connection status to the rooms in the CSR app:

grey = not synchronized/disconnected;

green = synchronized/connected;

red = an error event.

(see screenshots below)

I did figure out that the user was indeed getting refused re-entry because of the ENDED state of the room, which was solved when I followed your suggestion and used csrUserManager.removeUser(customerUserID);

But the two problems still occurred after I fixed that:

a) the "monthly user limit" error in the Room Console, and

b) dropped connections, resulting in SessionEvent.ERROR events

At no time did I get any runtime errors throughout any of this. I am running the latest 10,3,183,5 debug player with the 10.3 LCCS SDK download from the SDK Navigator. The SDK Navigator app is the latest currently available from the developer account.

The customer app on the left is logging into one room at a time as guest, with an autopromote in the CSR rooms. The CSR app is logging into the prelobby and the lobby room simultaneously using two different AdobeHSAuthenticator objects; once the lobby session has begun, the CSR app logs into his own private CSR room using a third AdobeHSAuthenticator object. All connections in both apps are made using client-side authentication; although we have some ruby-based server-side authentication for the CSR app set up and ready to go, we have not integrated it into the app code yet -- that was going to be our next step when these errors started happening.

When I had finished making the improvements mentioned, I launched both the customer app (left) and the csr app (right) under a debug session in Flash Builder. Then I logged in with the CSR app. This is what happened:

LCCS_monthly_usage_limit_error_2011-09-01_01.jpg

Note that the customer app on the left is running but is not logged in yet.

Here is the debug trace I pulled from Flash Builder when that happened: http://is.gd/zXON8V

Then I rebooted the apps and played with it for a while. The customer was logging in, transfering his connection from prelobby to lobby, then after receiving a MessageItem from the CSR app, logged into the CSR room; then the CSR would eject him from the CSR room session, and the customer app would log back into the prelobby. And then I would start the whole process over again. The app was working really well, as it was designed to do, no runtime errors; I was actually getting worried the  dropped connection error would not come up as I had observed before.

Then I logged the customer out of the CSR room one last time, which disconnected the customer from the CSR room and triggered the customer app to re-enter the prelobby room -- and then this happened:

LCCS_monthly_usage_limit_error_2011-09-01_03.jpg


The server dropped all connections in the prelobby room, resulting in four debug traces of:

Session ERROR = ZOMBIE: Another client with your same ticket connected. You need to disconnect.

Session ERROR = ZOMBIE: Another client with your same ticket connected. You need to disconnect.

Session ERROR = ZOMBIE: Another client with your same ticket connected. You need to disconnect.

Session ERROR = ZOMBIE: Another client with your same ticket connected. You need to disconnect.

And when I used the Room Console to re-enter the lobby room, it ejected the CSR user "jsmith" from the room, with a debug trace of:

### lobby Session is: Disconnected. ###
    Lobby Session ERROR = ZOMBIE: Another client with your same ticket connected. You need to disconnect.

To see if it would do that when I entered the jsmith room, I entered that room with the Room Console, but the connection stayed. Here is the resulting screenshot:

LCCS_monthly_usage_limit_error_2011-09-01_04.jpg

Since I was no longer in a debug session in Flash Builder, here is the resulting  flashlog.txt file from the dropped connection session: http://is.gd/UEfosO

Of particular interest are the lines which say "Session ERROR = ZOMBIE..." What does that mean? I checked with the other dev on the project, and as far as I know no one had the Flex app or another Room Console connected at the same time as me. Where the trace says "Daniel Lebor 2 has entered the room" that's just me checking out rooms in the Room Console.

Thanks very much for all your help! I hope we can get to bottom of this.

Joseph Balderson

Flex & Flash Platform Developer

http://joeflash.ca

Message was edited by: joeflashTO

Message was edited by: joeflashTO

Avatar

Level 2

And now I'm getting this:

LCCS_monthly_usage_limit_error_2011-09-01_05.jpg

Tried it again and the Room Console logged in fine, but that was the first time I'd ever gotten that particular error from the room console...

Joseph Balderson

Flex & Flash Platform Developer

http://joeflash.ca