Troubleshooting a Subform set that automatically insert a subform on save/load

soft_io

27-05-2015

Greetings everyone,

I have a form (which I can provide on demand) which contains several levels of Subform Sets; the entire form is working as expected except one of the subform set which, for unknown reason, seems to want to create one new subform between the time the user save and reload the PDF.

Just to clarify, from the point of view of the user, they are in the document and add a new subform "A".  Within that subform A, I have several different subform sets, let's say "Aa", "Ab", "Ac", "Ad" etc..

On the screen, the user as a single subform "A" without any other subforms, Saves the document.  After re-opening the document saved, the form now include "A" (as expected) and "Aa" (not desired).  Again, "Aa" was NOT present at save time.

Steps I have taken to avoid common mistakes

- Try to rename "Aa" to a different name, say "Ax": same issue still happens, changing the name of the subform has no impact

- Delete the entire subform set "Aa", so that "Ab" is now the first subform set contained within "A": Well now I have subform "Ab" incorrect created during save/load.

- Relocate "Aa" after "Ab": Same as deleting "Aa", "Ab" now gets created by the save/load process

I have looked through the code for "addInstance()" calls, in all defined code objects and events and I cannot locate anything that would produce this behaviour.  Is there any way to debug this kind of issue?  Are there any tips on how to solve this problem?  And I guess finally, is there a technical support staff from Adobe, that would be available for paid support to look in-depth at this issue and clearly point out where in the document the issue is located?

While not hyper time sensitive, I'm hoping this issue can be resolved in days rather than weeks.  Thanks!

-------

Additional technical details

- Development System: Windows 7 64bit

- Live Cycle Designer ES4 version 11.0.0.20130303.1.892433

- Saved with reader_extended_pdf functionality using Adobe Acrobat Pro DC version 2015.007.20033

- Issue presenting itself when saving/loading from Adobe Reader XI version 11.0.11

- Reproducible with the mentioned document: 100% of the time

Accepted Solutions (0)

Answers (1)

Answers (1)

soft_io

03-06-2015

*BUMP*

This issue is still pending, anyone with the knowledge to troubleshoot this and willing to help us out would be extremely appreciated.