Security error accessing url" faultCode="Channel.Security.Error" faultDetail="Unable to load WSDL

Avatar

Avatar

G_S_SAINI

Avatar

G_S_SAINI

G_S_SAINI

03-12-2008

[Thread Edited By Adobe]

/*Don’t forget to meet and greet your fellow peers virtually by telling them about yourself here

Go ahead and to it now: https://adobe.ly/3eDnB4v */

 

Actual Question:

HI



I am using a webservice(.net webservice) that is on my
localhost and using it in flex application that is also on my
system. Means both the webservice and flex application are on the
same system.

But when i gives the reference of the webservice using the
system ip and run the application by the flex builder it generates
the error as:



mx.messaging.messages::ErrorMessage)#0

body = (Object)#1

clientId = "DirectHTTPChannel0"

correlationId = "24CD6542-F141-1A05-BA35-00A108CB30A0"

destination = ""

extendedData = (null)

faultCode = "Channel.Security.Error"

faultDetail = "Destination: DefaultHTTP"

faultString = "Security error accessing url"

headers = (Object)#2

messageId = "CC123DF0-0E6C-05FF-7894-00A109676283"

rootCause = (flash.events::SecurityErrorEvent)#3

bubbles = false

cancelable = false

currentTarget = (flash.net::URLLoader)#4

bytesLoaded = 0

bytesTotal = 0

data = (null)

dataFormat = "text"

eventPhase = 2

target = (flash.net::URLLoader)#4

text = "Error #2170: Security sandbox violation:
http://localhost:3000/MYCIMS/flex_bin/Design.swf
cannot send HTTP headers to
http://myip/MyServer/AdminWS.asmx."

type = "securityError"

timestamp = 0

timeToLive = 0



I have put crossdomain.xml file in the root of the localhost
and made every changes possible in the crossdomain.xml file but the
application is not running.

Please somebody provide an effective solution, I have spend
lots of time to resolve the problem but its not being....



Thanks in advance

Gopi Saini

View Entire Topic

Avatar

Avatar

Zee_Yang

Avatar

Zee_Yang

Zee_Yang

06-01-2009

Can you post your x-domain file here? also, can you use a
http proxy, such as the charles debug proxy, to see if the x-domain
file is indeed fetched. it could be just a permission issue with
the file.