Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Screen share freezes on Windows XP and 7 (FMS + LCCS Possible cause?)

lordalexworks
Level 2
Level 2

Hi Guys,

We created a demo app in the past to do a simple screen-sharing app with LCCS, we figure out the issue with the Acaddin and things were running smooth with the exception of some Windows 64 Machines but this is something we can live with for the moment.

When we implemented the code to an existing application we are now experiencing a new issue: After a few seconds once the screen-sharing takes place the subscriber feed stops refreshing, however the cursor position from the Publisher continues to update normally in the Subscriber. To make things a little clear lets say you start the screen share (sharing Desktop) you see everything updating fine in the subscriber and few seconds after, the image freezes, if you for example resize a particular window, that change is not reflected in the subscriber feed but the cursor continues to update normally until you end the screen-share session.

We are not sure why, but on mac os x this problem does not occur (Using FP 10.2 Debug version). It only seems to happen on Windows 7 (32 bit) and Windows XP. (We tested on Explorer 8 and 9 and latest version of Firefox all running Flash Player 10.2

We are running on the latest SDK updated I belive yesterday.

We are wondering if the fact the application is already having a connection to a separate FMS server and using BlazeDS in the background to handle other features may be causing some sort of problem by adding LCCS in the mix. At the moment we are using LCCS exclusively for the screen-share feature.

1) Do you think having FMS doing video and sharing objects between the Publisher and Subscriber could affect somehow the screen-sharing via LCCS ?

2) Why would the cursor continue to update when the rest of the background being shared won't?

Kind regards.

+LA

Message was edited by: lordalexworks

I wanted to add that further testing on part found that things update but with lag of approximately 3+ minutes. I am sort of adding this in hopes that this would help you, point us in the right direction to find out what could be the problem.

Kind regards.

+LA

Message was edited by: lordalexworks

13 Replies
aponnusa
Employee
Employee

Hi Alex,

Can you try the simpler version of Screensharing and see if you are able to reproduce the issue you reported http://blogs.adobe.com/arunpon/files/2011/02/SimpleScreenShare2.swf

This would help us isolate if the issue pertains to code or settings of ScreenShare.

Thanks

Arun

lordalexworks
Level 2
Level 2

Hi Arun,

The link provided on windows 7 and Mac osx 10.6.7 both counts do not work. On mac the accadin does not seem to launch and on windows it launches but the share selection windows does not show up.

However, when we run our own simple screensharing demo app, we don't have the problem. is works ok. If you want we could send you our test version.

Same demo we created with your help and Nigel when we had accadin issues BTW.

Here is the trace I get on yours on mac:

19:30:59 GMT-0400    #TicketService# ticket received: 1ulteeg9tktrk

19:30:59 GMT-0400    Getting FMS at https://na2.collaboration.adobelivecycle.com/fms?ticket=1ulteeg9tktrk&proto=rtmfp, attempt #1/3

19:30:59 GMT-0400    result: <fms>

  <origin>fms2.acrobat.com</origin>

  <proto_ports>rtmfp:1935,rtmps:443</proto_ports>

  <retry_attempts>2</retry_attempts>

</fms>

19:30:59 GMT-0400    protocols: [object ProtocolPortPair],[object ProtocolPortPair]

19:30:59 GMT-0400    [attempt 1 of 2] Connecting to 0/1: rtmfp://fms2.acrobat.com/cocomo/na2-sdk-1dceb493-62d3-4aff-9a43-3e27d88e766e/screen2 #startProtosConnect#

19:31:00 GMT-0400    tempNetStatusHandler 0/2,NetConnection.Connect.Success

19:31:00 GMT-0400    isTunneling? false

19:31:00 GMT-0400    is using RTMPS? false

19:31:00 GMT-0400    RECEIVED LOGIN AT SESSION

19:31:00 GMT-0400      .user descriptor from server [object]

19:31:00 GMT-0400        \\

19:31:00 GMT-0400        .displayName [string]= screenShareTester

19:31:00 GMT-0400        .userID [string]= GUEST-3605862A-0AB9-41D6-8E7F-01181884DD96

19:31:00 GMT-0400        .affiliation [number]= 5

19:31:00 GMT-0400        .role [number]= 10

19:31:00 GMT-0400    RECEIVENODES UserManager

19:31:00 GMT-0400    receiveAllSynchData UserManager

19:31:00 GMT-0400    RECEIVENODES FileManager

19:31:00 GMT-0400    receiveAllSynchData FileManager

19:31:00 GMT-0400    checkManagerSync:[object FileManager]

19:31:00 GMT-0400    RECEIVENODES AVManager

19:31:00 GMT-0400    receiveAllSynchData AVManager

19:31:00 GMT-0400    checkManagerSync:[object StreamManager]

19:31:00 GMT-0400    RECEIVENODES RoomManager

19:31:00 GMT-0400    receiveAllSynchData RoomManager

19:31:00 GMT-0400    checkManagerSync:[object RoomManager]

19:31:00 GMT-0400    checkManagerSync:[object UserManager]

lordalexworks
Level 2
Level 2

This one worked, just be sure it share it's own screen.

This is log:

09:02:14 GMT-0400    #TicketService# ticket received: 352t3wnk3nas

09:02:14 GMT-0400    Getting FMS at https://na2.collaboration.adobelivecycle.com/fms?ticket=352t3wnk3nas&proto=rtmfp, attempt #1/3

09:02:14 GMT-0400    result: <fms>

  <origin>fms4.acrobat.com</origin>

  <proto_ports>rtmfp:1935,rtmps:443</proto_ports>

  <retry_attempts>2</retry_attempts>

</fms>

09:02:14 GMT-0400    protocols: [object ProtocolPortPair],[object ProtocolPortPair]

09:02:14 GMT-0400    [attempt 1 of 2] Connecting to 0/1: rtmfp://fms4.acrobat.com/cocomo/na2-sdk-1dceb493-62d3-4aff-9a43-3e27d88e766e/screen3 #startProtosConnect#

09:02:15 GMT-0400    tempNetStatusHandler 0/2,NetConnection.Connect.Success

09:02:15 GMT-0400    isTunneling? false

09:02:15 GMT-0400    is using RTMPS? false

09:02:15 GMT-0400    RECEIVED LOGIN AT SESSION

09:02:15 GMT-0400      .user descriptor from server [object]

09:02:15 GMT-0400        \\

09:02:15 GMT-0400        .userID [string]= GUEST-BA341076-A18D-4CDA-9129-02E74A83E77F

09:02:15 GMT-0400        .displayName [string]= screenShareTester

09:02:15 GMT-0400        .role [number]= 50

09:02:15 GMT-0400        .affiliation [number]= 5

09:02:15 GMT-0400    RECEIVENODES UserManager

09:02:15 GMT-0400    receiveAllSynchData UserManager

09:02:15 GMT-0400    RECEIVENODES FileManager

09:02:15 GMT-0400    receiveAllSynchData FileManager

09:02:15 GMT-0400    checkManagerSync:[object FileManager]

09:02:15 GMT-0400    RECEIVENODES AVManager

09:02:15 GMT-0400    receiveAllSynchData AVManager

09:02:15 GMT-0400    checkManagerSync:[object StreamManager]

09:02:15 GMT-0400    RECEIVENODES RoomManager

09:02:15 GMT-0400    receiveAllSynchData RoomManager

09:02:15 GMT-0400    checkManagerSync:[object RoomManager]

09:02:15 GMT-0400    checkManagerSync:[object UserManager]

09:02:18 GMT-0400    #AddInLocalConnection# connected to Cocomo0

09:02:18 GMT-0400    #AddinLocalConnection# calling installService: domain:blogs.adobe.com, _lcName:Cocomo0, fuzzedDomain:adobe.com, url:https://collaboration.adobelivecycle.com/static/screenshare/screenshareshell_player9_sgn.swf, version:Windows

09:02:18 GMT-0400    #AddInLocalConnection# onStatus:null, status

09:02:18 GMT-0400    #AddInLocalConnection# InstallStatus: Open.Success, version:undefined

09:02:23 GMT-0400    [Event type="activate" bubbles=false cancelable=false eventPhase=2]

Let me now if you need anything else.

+LA

aponnusa
Employee
Employee

Hi,

So was the performance ok at your end with the link that was posted. And yes the app subscribes to its own screen.

Thanks

Arun

Artour_Arifoull
Level 2
Level 2

Here's a sample code we were using that caused this problem

ScreenShareStandalone.mxml:

ScreenShareStandaloneSub.mxml:

ScreenShare.as :

We found out that if we create the screenshare in AS it freezes/delays when we publish on a Windows machine so we've change it to an ScreenShare.mxml and it seems to work fine now.

David_Welch
Level 3
Level 3

Artour:

I've had exactly the same issue on another post for weeks (http://forums.adobe.com/post!reply.jspa?message=3655738), but, no one has provided a good reason why this is occurring.  It basically renders screen sharing unusable.

Can you clarify what you did to resolve this?  I don't see a "screenshare.mxml", nor in any example code, can you post?

I'm using one call to start the publishing:

sspublisher.publish();

<rtc:ScreenSharePublisher id="sspublisher" playerVersion="10" connectSession="{cSession}" enableHFSS="false" fps="15" quality="70" />

Using player 10.1 libs, it runs for a few seconds, freezes (get cursor updates), then will repaint in a few minutes, and start the cycle over.

Thanks,

David

Artour_Arifoull
Level 2
Level 2

Hi David,

sorry I haven't been clear we converted our screen share class to a mxml we're using flex 3.5 and player 9 lib.

Artour.

LordAlex Works Inc.

David_Welch
Level 3
Level 3

Artour:

Thanks for the info...can you tell me the config settings you used...I'm

curious if this is causing the issue:

...

screenPub.quality = config.quality;

screenPub.fps = config.FPS;

screenPub.bandwidth = config.bandwidth;

...

thanks!

David

Artour_Arifoull
Level 2
Level 2

Hi David here's the config we used:

bandwidth = 125000

fps = 24

quality = 90

Artour

LordAlex Works Inc.

David_Welch
Level 3
Level 3

Thanks, tried these, but, still hangs as before.  Interesting that I've also set the ScreenSharePublisher to use playerVersion=10, but, the lccs code in ScreenSharePublisher.as runs thru the code correctly, but, the logs indicate it used the player 9 version:

21:15:38 GMT-0400    #AddinLocalConnection# calling installService: domain:app#ScreenShareTest, _lcName:Cocomo0, fuzzedDomain:app#ScreenShareTest, url:http://collaboration.adobelivecycle.com/static/screenshare/screenshareshell_player9_sgn.swf, version:Windows
21:15:38 GMT-0400    #AddInLocalConnection# onStatus:null, status
21:15:38 GMT-0400    #AddInLocalConnection# InstallStatus: Open.Success, version:undefined
21:15:42 GMT-0400    [Event type="activate" bubbles=false cancelable=false eventPhase=2]
21:16:29 GMT-0400    [Event type="activate" bubbles=false cancelable=false eventPhase=2]

aponnusa
Employee
Employee

David,

Sorry abt the playerVersion API. As you have mentioned, setting the playerVersion has no effect and it was just place holder for future updates of the addin.

Thanks

Arun

sunny_chandel
Level 2
Level 2

Hello Arun

Arun will you please tell me that what is the difference between the component for which you have given links above i.e

difference between http://blogs.adobe.com/arunpon/files/2011/02/SimpleScreenShare2.swf     and   http://blogs.adobe.com/arunpon/files/2011/02/SimpleScreenShare3.swf  because the same thing is happening with my screen share component that addin launches but choosing screen share option window (i.e desktop , application or window) never appear which is the problem with your 1st component. Your 2nd component is very stable and also there is no delay or freeze in the sharing process which I was experiencing in my component created in AS, running on the same machine and same network so that I tried to change my component to mxml but now this issue of popup window I am feeling. Please tell the changes you made in your 1st component.

Thanks.