Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Problem with hyperlinks to pages in PDF

Avatar

Level 1

Hello,

I am a novice user of LiveCycle Designer. I have created a calendar in InDesign and in it have included page links from each monthly page to the other months of the year. I then export to PDF and import into LiveCycle Designer to make each day of the month 'fillable'. Problem is, when I import the PDF to LiveCycle Designer the links to the pages no longer work (either in Preview or after saving the doc) and I can't figure out why.

I created a similar calendar last year and the page links worked fine. I have also included URL links in the new PDF and these work fine after import to LiveCycle Designer, just not the page links.

Any suggestions?

Cheers

Deb

PS thought I should probably mention that I"m using Version 8.0..

2 Replies

Avatar

Level 10

Hi,

I haven't done that workflow before and it is difficult to say what is going on without seeing the form.

However check the script in the hyperlink/button. Set the language to Javascript and insert the following line for the next page:

xfa.host.pageDown();

and this in the hyperlink for the previous page:

xfa.host.pageUp();

There are equivalent scripts, but try that first. I am not sure how you have set up the hyperlink for changing pages. It may be that you will need to drag in a button over the hyperlink and put the script in the button. If this is the case then you can set the button for no border and no fill.

Good luck,

Niall

Avatar

Level 1

Thanks for your help. It appears the problem was with tags and also possibly with my version of Livecycle Designer, and another Adobe forum user found me ranting on Twitter and helped fix the problem.

The document seemed to work when imported into v. 8.2, I'm using v. 8.0, has anyone else experienced problems with hyperlinks not working in v. 8.0 (links to URL seem OK, links to pages do not...)? The same document worked perfectly well when I made it in 2008 in v. 8.0, so seems strange it would suddenly not work! I have made a dummy doc including links to another page in the document in the same way I made the calendar, exported from InDesign as a tagged PDF, and again they don't work when i import into LiveCycle Designer 8.0.

I've attached the dummy doc in case anyone wants to check it.

Cheers

Deb