Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Problem with dynamic tables, XML schemas, and JavaScript

Avatar

Avatar
Validate 1
Level 1
bmillhaus
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
bmillhaus
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
bmillhaus
Level 1

04-11-2009

With the XML schema applied my JavaScript does not work correctly when a 2nd row is added to my dynamic table. Instead of a blank row being added the data from the 1st row is copied to the 2nd row and if you change the data in the 2nd row it changes the data in the 1st row also. It works fine if the XML schema data connection is deleted though.

Any idea what I can do to get this working with the schema applied the same way it works without the schema?

Thanks for your help,

Brian

View Entire Topic

Avatar

Avatar
Validate 1
Level 1
BPM_Developer
Level 1

Likes

0 likes

Total Posts

28 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
BPM_Developer
Level 1

Likes

0 likes

Total Posts

28 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
BPM_Developer
Level 1

10-11-2009

Hi Paul,

Brian and I work together on this project.  Thanks for your help with Brian thus far.  I do have a broader question directly related to this.  Many of our forms will be rendered in Workspace and most will be pre-populated from an Enterprise database.  To make this easier, especially with the 'query to XML' service, we want our forms to have a 3 level xml structure.  To ease the pre-population and the data extraction, we decided to create xml schemas for all our forms and bind to xml schema. Some of our form developers have created forms where each field has been wrapped in a subform, so that the lines automatically appear on the form.  The extensive use of subforms has altered the default xml structure so much, that we decided that we really do have to use data connections.

My questions to you would be:

1) Should we wrap each form field in a subform in order to have lines automatically on the form?

2) Is there a best practice in terms of using data connections to sml schema in order to more easily pre-populate and extract data in the form?

Thanks!