PDFs rendering as XDPs

Avatar

Avatar

NW987

Avatar

NW987

NW987

13-01-2011

We're using version 9 SP2 with a version 8.2 process.

We have forms that are rendered and submitted as PDFs in workspace.  Occasionally, when a form is proceeding through the process steps, it is somehow becoming an XDP only, so when the the next approver logs into workspace to view the form, the only data they are presented with is XDP XML.

I can replay an example of this occurring.  A form is rendered and submitted at step 1 as a PDF. Following this step, I can view the form in the process recording, and it is in fact a PDF.   However, when the approver logs in at step 2 though, the only data that appears in the workspace is the XDP XML.

Has anyone seen this issue before?

Accepted Solutions (0)

Answers (6)

Answers (6)

Avatar

Avatar

NW987

Avatar

NW987

NW987

18-01-2011

Nith, thanks for the reply, but no, it is not necessary to render the form again after the import operation.

Avatar

Avatar

_Nith_

Avatar

_Nith_

_Nith_

16-01-2011

It is not so easy to locate your issue without looking at the activity settings & variables.

However, I'm guessing what might gone wrong with your process design:

-> In the Import Updated form data activity, you are supplying the XDP URL + the XML data to be imported

-> The output of the Import Updated form data is saved into a Document variable (say  myImportedDoc)

-> You are assigning the document variable "myImportedDoc" to the next activity "Center Director Approval"

If all the steps mentioned above are true from your side, the third step causing the issue.

To resolve it, place an RenderPDF activity just before the AssignTask (Center Director Approval) and supply the myImportedDoc variable as input and save the output in the same variable (myImportedDoc).

Let me know what happens!

Nith

Avatar

Avatar

Jasmin_Charbonn

Avatar

Jasmin_Charbonn

Jasmin_Charbonn

13-01-2011

Hmmm.

I'm not sure why you get the name of the XDP in the URL. At that point you have a PDF and there shouldn't be any reference to the original XDP.

Can you try to put the submitted PDF in a new Document Form variable? I'm wondering if the Document Form variable you're using is the one you use in the initial step and it still contains a reference to the original XDP.

Just add a setValue and use an xPath like /process_data/myNewDocForm/object/document = /process_data/OldDocForm/object/document and see if that helps.

Jasmin

Avatar

Avatar

NW987

Avatar

NW987

NW987

13-01-2011

Please take a look at the attached screenshots.  I removed the name of the form.  The bottom line is that the form appears to be fine during the process replay(I can view the PDF) but it is not appearing in the workspace correctly.  This has occurred multiple times.  Thanks.

Nick

Capture1.JPG

Capture2.JPG

Capture4.JPG

Avatar

Avatar

NW987

Avatar

NW987

NW987

13-01-2011


We're using an 8.2 process so I don't think the "Presentation and Data tab" question applies.

We are using a Document Form variable to hold the PDF.  And I can confirm with the process recording that the variable does in fact contain the form.  When that form is presented to the next approver, though, only XDP XML appears.  This only happens with some form instances.

We also have to use the entire PDF because we're using digital signatures.

Avatar

Avatar

Jasmin_Charbonn

Avatar

Jasmin_Charbonn

Jasmin_Charbonn

13-01-2011

How are you setting your application assets on the Presentation and Data tab for Step 2?

If you submit the entire PDF, you need to make sure to use the document variable that contains the PDF for the application assets. Is there a reason why you submit the entire PDF and not just the data?

Jasmin