Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

PDF form submission problem - works in Acrobat and Reader, but not when embedded in browser

Avatar

Level 1

Hello everyone,

I am trying to submit a PDF form to an application server.

To do this, I added a "Submit" button to the PDF, configured the server's address and submit format, and tested the button.

I opened the PDF in Acrobat Pro, clicked the button, and my web application received the form in PDF format just as I wanted.

To make it work in Reader, I had to extend user rights via Acrobat Pro, and then the form worked inside Reader as well.

Up to here, everything went fine.

Then I embedded the PDF in a web page (which will be the final scenario) and it all stopped working.

The submit button doesn't do anything anymore, and no data is sent to the application server.

I even tried switching from the form's submit mechanism to calling event.target.submitForm(...) in Javascript directly, but nothing changed (meaning this too worked only when opening the form as an "offline" pdf, but not when embedding it in a web page).

Is there something I am missing? Something else that must be configured/activated in order to be able to submit the PDF when it is in the form of an embedded object?

Many thanks in advance,

Alex

2 Replies

Avatar

Level 10

Just tried it here and it worked fine for me ...... which version of Reader are you using? Which version of Acrobat did you use to RE the file?

Paul

Avatar

Level 1

Thanks for your reply, Paul.

I tested the submit button both in Reader 9.3 and Acrobat 8 (which is the same I used to RE the PDF).

Apparently I got it working too, but only by deploying my embedding web page to an application server.

The final environment the PDF will be embedded into will be inside a web application deployed to an application server, so I guess my problem is solved.

It didn't work only when embedded into a local test.html web page saved on my PC...

Thanks again, have a good day.

Alex